Update to 1.20.1
This commit is contained in:
parent
eabd20e807
commit
1f1b01a90d
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
||||
/grpc-1.17.0.tar.gz
|
||||
/grpc-1.17.1.tar.gz
|
||||
/grpc-1.18.0.tar.gz
|
||||
/grpc-1.20.1.tar.gz
|
||||
|
@ -1,43 +0,0 @@
|
||||
From ad0cae3d6eb5a47e8ec0a52b78013e658aa1720b Mon Sep 17 00:00:00 2001
|
||||
From: Mathieu Bridon <bochecha@daitauha.fr>
|
||||
Date: Mon, 17 Dec 2018 11:41:34 +0100
|
||||
Subject: [PATCH] Do not build the Ruby plugin
|
||||
|
||||
Unfortunately, this can't build without protobuf 3.6, so we must disable
|
||||
it for Fedora 28 and 29 which only have protobuf 3.5.
|
||||
---
|
||||
Makefile | 4 +---
|
||||
1 file changed, 1 insertion(+), 3 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 066c191..09ad70a 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -802,7 +802,7 @@ PC_LIBS_GRPCXX =
|
||||
|
||||
CPPFLAGS := -Ithird_party/googletest/googletest/include -Ithird_party/googletest/googlemock/include $(CPPFLAGS)
|
||||
|
||||
-PROTOC_PLUGINS_ALL = $(BINDIR)/$(CONFIG)/grpc_cpp_plugin $(BINDIR)/$(CONFIG)/grpc_csharp_plugin $(BINDIR)/$(CONFIG)/grpc_node_plugin $(BINDIR)/$(CONFIG)/grpc_objective_c_plugin $(BINDIR)/$(CONFIG)/grpc_php_plugin $(BINDIR)/$(CONFIG)/grpc_python_plugin $(BINDIR)/$(CONFIG)/grpc_ruby_plugin
|
||||
+PROTOC_PLUGINS_ALL = $(BINDIR)/$(CONFIG)/grpc_cpp_plugin $(BINDIR)/$(CONFIG)/grpc_csharp_plugin $(BINDIR)/$(CONFIG)/grpc_node_plugin $(BINDIR)/$(CONFIG)/grpc_objective_c_plugin $(BINDIR)/$(CONFIG)/grpc_php_plugin $(BINDIR)/$(CONFIG)/grpc_python_plugin
|
||||
PROTOC_PLUGINS_DIR = $(BINDIR)/$(CONFIG)
|
||||
|
||||
ifeq ($(HAS_SYSTEM_PROTOBUF),true)
|
||||
@@ -3151,7 +3151,6 @@ install-plugins: $(PROTOC_PLUGINS)
|
||||
$(Q) $(INSTALL) -d $(prefix)/bin
|
||||
$(Q) $(INSTALL) $(BINDIR)/$(CONFIG)/grpc_python_plugin $(prefix)/bin/grpc_python_plugin
|
||||
$(Q) $(INSTALL) -d $(prefix)/bin
|
||||
- $(Q) $(INSTALL) $(BINDIR)/$(CONFIG)/grpc_ruby_plugin $(prefix)/bin/grpc_ruby_plugin
|
||||
|
||||
install-grpc-cli: grpc_cli
|
||||
$(E) "[INSTALL] Installing grpc cli"
|
||||
@@ -7162,7 +7161,6 @@ LIBGRPC_PLUGIN_SUPPORT_SRC = \
|
||||
src/compiler/objective_c_generator.cc \
|
||||
src/compiler/php_generator.cc \
|
||||
src/compiler/python_generator.cc \
|
||||
- src/compiler/ruby_generator.cc \
|
||||
|
||||
PUBLIC_HEADERS_CXX += \
|
||||
include/grpc++/impl/codegen/config_protobuf.h \
|
||||
--
|
||||
2.17.2
|
||||
|
@ -1,28 +0,0 @@
|
||||
From aefd1a3782bf67e894bfcaeaacb961ee2e3b9b68 Mon Sep 17 00:00:00 2001
|
||||
From: Sergey Avseyev <sergey.avseyev@gmail.com>
|
||||
Date: Wed, 16 Jan 2019 19:32:40 +0300
|
||||
Subject: [PATCH] tcp_posix.cc: fix typo in bitwise condition
|
||||
|
||||
src/core/lib/iomgr/tcp_posix.cc:725:40: error: bitwise comparison always evaluates to false [-Werror=tautological-compare]
|
||||
if ((msg.msg_flags & MSG_CTRUNC) == 1) {
|
||||
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~
|
||||
---
|
||||
src/core/lib/iomgr/tcp_posix.cc | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/core/lib/iomgr/tcp_posix.cc b/src/core/lib/iomgr/tcp_posix.cc
|
||||
index c268c18664..03077e3a0d 100644
|
||||
--- a/src/core/lib/iomgr/tcp_posix.cc
|
||||
+++ b/src/core/lib/iomgr/tcp_posix.cc
|
||||
@@ -722,7 +722,7 @@ static void process_errors(grpc_tcp* tcp) {
|
||||
return;
|
||||
}
|
||||
if (grpc_tcp_trace.enabled()) {
|
||||
- if ((msg.msg_flags & MSG_CTRUNC) == 1) {
|
||||
+ if (msg.msg_flags & MSG_CTRUNC) {
|
||||
gpr_log(GPR_INFO, "Error message was truncated.");
|
||||
}
|
||||
}
|
||||
--
|
||||
2.20.1
|
||||
|
@ -1,7 +1,7 @@
|
||||
From dfd09ced8657f7b3eac79038418fc5a452c396d6 Mon Sep 17 00:00:00 2001
|
||||
From 5d56d52e0829e503e403568de66bb6cebfec3202 Mon Sep 17 00:00:00 2001
|
||||
From: Sergey Avseyev <sergey.avseyev@gmail.com>
|
||||
Date: Wed, 28 Nov 2018 18:53:22 +0300
|
||||
Subject: [PATCH] enforce system crypto policies
|
||||
Subject: [PATCH 1/4] enforce system crypto policies
|
||||
|
||||
---
|
||||
test/core/handshake/client_ssl.cc | 3 +--
|
||||
@ -37,5 +37,5 @@ index 41b2829d8b..8b21ea7c73 100644
|
||||
ERR_print_errors_fp(stderr);
|
||||
gpr_log(GPR_ERROR, "Couldn't set server cipher list.");
|
||||
--
|
||||
2.19.1
|
||||
2.21.0
|
||||
|
@ -1,14 +1,14 @@
|
||||
From d75addf6b5ef94ba9f6b5684523a587c6dc35ccb Mon Sep 17 00:00:00 2001
|
||||
From 58691d6301984afe2dbdab52e1cb2ea0d83a3686 Mon Sep 17 00:00:00 2001
|
||||
From: Sergey Avseyev <sergey.avseyev@gmail.com>
|
||||
Date: Fri, 16 Nov 2018 15:03:30 +0300
|
||||
Subject: [PATCH] patch from #15532
|
||||
Subject: [PATCH 2/4] patch from #15532
|
||||
|
||||
---
|
||||
Makefile | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 8469a5fd50..0d06d1fc29 100644
|
||||
index 53e70c95ba..2bdfa6395d 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -348,7 +348,7 @@ HOST_LD ?= $(LD)
|
||||
@ -20,7 +20,7 @@ index 8469a5fd50..0d06d1fc29 100644
|
||||
ifeq ($(SYSTEM),Darwin)
|
||||
CXXFLAGS += -stdlib=libc++
|
||||
endif
|
||||
@@ -7899,7 +7899,7 @@ LIBBORINGSSL_OBJS = $(addprefix $(OBJDIR)/$(CONFIG)/, $(addsuffix .o, $(basename
|
||||
@@ -8007,7 +8007,7 @@ LIBBORINGSSL_OBJS = $(addprefix $(OBJDIR)/$(CONFIG)/, $(addsuffix .o, $(basename
|
||||
|
||||
$(LIBBORINGSSL_OBJS): CPPFLAGS += -Ithird_party/boringssl/include -fvisibility=hidden -DOPENSSL_NO_ASM -D_GNU_SOURCE -DWIN32_LEAN_AND_MEAN -D_HAS_EXCEPTIONS=0 -DNOMINMAX
|
||||
$(LIBBORINGSSL_OBJS): CXXFLAGS += -fno-rtti -fno-exceptions
|
||||
@ -29,7 +29,7 @@ index 8469a5fd50..0d06d1fc29 100644
|
||||
|
||||
$(LIBDIR)/$(CONFIG)/libboringssl.a: $(ZLIB_DEP) $(CARES_DEP) $(ADDRESS_SORTING_DEP) $(LIBBORINGSSL_OBJS)
|
||||
$(E) "[AR] Creating $@"
|
||||
@@ -10094,7 +10094,7 @@ PUBLIC_HEADERS_C += \
|
||||
@@ -8251,7 +8251,7 @@ PUBLIC_HEADERS_C += \
|
||||
LIBARES_OBJS = $(addprefix $(OBJDIR)/$(CONFIG)/, $(addsuffix .o, $(basename $(LIBARES_SRC))))
|
||||
|
||||
$(LIBARES_OBJS): CPPFLAGS += -Ithird_party/cares -Ithird_party/cares/cares -fvisibility=hidden -D_GNU_SOURCE $(if $(subst Darwin,,$(SYSTEM)),,-Ithird_party/cares/config_darwin) $(if $(subst FreeBSD,,$(SYSTEM)),,-Ithird_party/cares/config_freebsd) $(if $(subst Linux,,$(SYSTEM)),,-Ithird_party/cares/config_linux) $(if $(subst OpenBSD,,$(SYSTEM)),,-Ithird_party/cares/config_openbsd) -DWIN32_LEAN_AND_MEAN -D_HAS_EXCEPTIONS=0 -DNOMINMAX $(if $(subst MINGW32,,$(SYSTEM)),-DHAVE_CONFIG_H,)
|
||||
@ -39,5 +39,5 @@ index 8469a5fd50..0d06d1fc29 100644
|
||||
$(LIBDIR)/$(CONFIG)/libares.a: $(LIBARES_OBJS)
|
||||
$(E) "[AR] Creating $@"
|
||||
--
|
||||
2.19.1
|
||||
2.21.0
|
||||
|
@ -1,7 +1,7 @@
|
||||
From eae007381722c82eb2e17697075803e99457f1ce Mon Sep 17 00:00:00 2001
|
||||
From fe221f7d6fcf04e296f3b8598f57abc9e3dea821 Mon Sep 17 00:00:00 2001
|
||||
From: Sergey Avseyev <sergey.avseyev@gmail.com>
|
||||
Date: Wed, 16 Jan 2019 20:00:40 +0300
|
||||
Subject: [PATCH] use shell loop instead makefile function
|
||||
Subject: [PATCH 3/4] use shell loop instead makefile function
|
||||
|
||||
this avoids failure when too long string passed to exec
|
||||
---
|
||||
@ -9,10 +9,10 @@ this avoids failure when too long string passed to exec
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 8646b7f1de..ebc985fe78 100644
|
||||
index 2bdfa6395d..51614620af 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -2996,7 +2996,7 @@ install-headers_c:
|
||||
@@ -2950,7 +2950,7 @@ install-headers_c:
|
||||
install-headers_cxx:
|
||||
$(E) "[INSTALL] Installing public C++ headers"
|
||||
$(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
|
||||
@ -22,5 +22,5 @@ index 8646b7f1de..ebc985fe78 100644
|
||||
install-static: install-static_c install-static_cxx
|
||||
|
||||
--
|
||||
2.20.1
|
||||
2.21.0
|
||||
|
25
grpc-0004-use-gettid-from-glibc.patch
Normal file
25
grpc-0004-use-gettid-from-glibc.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From ec4ea511a15aef0de9760f3aad265faf4bf65cfa Mon Sep 17 00:00:00 2001
|
||||
From: Sergey Avseyev <sergey.avseyev@gmail.com>
|
||||
Date: Fri, 17 May 2019 10:53:34 +0300
|
||||
Subject: [PATCH 4/4] use gettid from glibc
|
||||
|
||||
---
|
||||
src/core/lib/gpr/log_linux.cc | 2 --
|
||||
1 file changed, 2 deletions(-)
|
||||
|
||||
diff --git a/src/core/lib/gpr/log_linux.cc b/src/core/lib/gpr/log_linux.cc
|
||||
index 561276f0c2..2656492d43 100644
|
||||
--- a/src/core/lib/gpr/log_linux.cc
|
||||
+++ b/src/core/lib/gpr/log_linux.cc
|
||||
@@ -40,8 +40,6 @@
|
||||
#include <time.h>
|
||||
#include <unistd.h>
|
||||
|
||||
-static long gettid(void) { return syscall(__NR_gettid); }
|
||||
-
|
||||
void gpr_log(const char* file, int line, gpr_log_severity severity,
|
||||
const char* format, ...) {
|
||||
/* Avoid message construction if gpr_log_message won't log */
|
||||
--
|
||||
2.21.0
|
||||
|
23
grpc.spec
23
grpc.spec
@ -1,6 +1,6 @@
|
||||
Name: grpc
|
||||
Version: 1.18.0
|
||||
Release: 2%{?dist}
|
||||
Version: 1.20.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Modern, open source, high-performance remote procedure call (RPC) framework
|
||||
License: ASL 2.0
|
||||
URL: https://www.grpc.io
|
||||
@ -21,14 +21,13 @@ BuildRequires: python3-devel
|
||||
BuildRequires: python3-setuptools
|
||||
BuildRequires: python3-Cython
|
||||
|
||||
Patch0: 0001-enforce-system-crypto-policies.patch
|
||||
Patch0: grpc-0001-enforce-system-crypto-policies.patch
|
||||
# https://github.com/grpc/grpc/pull/15532
|
||||
Patch1: 0002-patch-from-15532.patch
|
||||
# F29 and older has too old protobuf without ruby plugin
|
||||
Patch2: 0001-Do-not-build-the-Ruby-plugin.patch
|
||||
Patch1: grpc-0002-patch-from-15532.patch
|
||||
# https://github.com/grpc/grpc/pull/17732
|
||||
Patch3: 0003-tcp_posix.cc-fix-typo-in-bitwise-condition.patch
|
||||
Patch4: 0004-use-shell-loop-instead-makefile-function.patch
|
||||
# Patch3: 0003-tcp_posix.cc-fix-typo-in-bitwise-condition.patch
|
||||
Patch2: grpc-0003-use-shell-loop-instead-makefile-function.patch
|
||||
Patch3: grpc-0004-use-gettid-from-glibc.patch
|
||||
|
||||
%description
|
||||
gRPC is a modern open source high performance RPC framework that can run in any
|
||||
@ -85,11 +84,8 @@ Python3 bindings for gRPC library.
|
||||
%autosetup -N
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%if 0%{?fedora} && 0%{?fedora} < 30
|
||||
%patch2 -p1
|
||||
%endif
|
||||
%patch3 -p1
|
||||
sed -i 's:^prefix ?= .*:prefix ?= %{_prefix}:' Makefile
|
||||
sed -i 's:$(prefix)/lib:$(prefix)/%{_lib}:' Makefile
|
||||
sed -i 's:^GTEST_LIB =.*::' Makefile
|
||||
@ -141,6 +137,9 @@ find %{buildroot} -type f -name '*.a' -exec rm -f {} \;
|
||||
%{python3_sitearch}/grpcio-%{version}-py?.?.egg-info
|
||||
|
||||
%changelog
|
||||
* Fri May 17 2019 Sergey Avseyev <sergey.avseyev@gmail.com> - 1.20.1-1
|
||||
- Update to 1.20.1
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.18.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
|
1
sources
1
sources
@ -1 +1,2 @@
|
||||
SHA512 (grpc-1.18.0.tar.gz) = 2489860a395b9f59d4eb81db5a8d873683e317145ad140b72fabb13693e166c122ce8526d34e2380a52d18493e8b2b49d6d28e53878af2c43523a5791da8fe52
|
||||
SHA512 (grpc-1.20.1.tar.gz) = e0dd0318d2b4ec07e0eafffa218938d91b1440c5053a557460ea7fceaab3d76f0cccc1d595abe7de9fa79f068b71cfbc5a28a3b688bc9c1e2737086928149583
|
||||
|
Loading…
Reference in New Issue
Block a user