- Re-added tcl/tk 8.5 patch

- Tweaked ming stuff
FWIW, it won't build with this patch, either, but it still helps. :-)
This commit is contained in:
Patrick Laughton 2008-01-04 05:11:28 +00:00
parent 34ed651fc5
commit c472fbb836
2 changed files with 71 additions and 121 deletions

View File

@ -1,37 +1,37 @@
diff -urN graphviz-2.12/configure graphviz-2.12-patched/configure diff -urN graphviz-2.16.orig/configure graphviz-2.16/configure
--- graphviz-2.12/configure 2006-12-04 16:02:10.000000000 -0600 --- graphviz-2.16.orig/configure 2007-11-09 23:41:41.000000000 -0600
+++ graphviz-2.12-patched/configure 2007-02-07 08:20:19.000000000 -0600 +++ graphviz-2.16/configure 2008-01-03 08:52:00.000000000 -0600
@@ -26251,8 +26251,8 @@ @@ -28003,8 +28003,8 @@
fi;
if test "x$TCLSH" = "x"; then if test "x$TCLSH" = "x"; then
- # Extract the first word of "tclsh8.4", so it can be a program name with args. - # Extract the first word of "tclsh8.4", so it can be a program name with args.
-set dummy tclsh8.4; ac_word=$2 -set dummy tclsh8.4; ac_word=$2
+ # Extract the first word of "tclsh8.5", so it can be a program name with args. + # Extract the first word of "tclsh8.5", so it can be a program name with args.
+set dummy tclsh8.5; ac_word=$2 +set dummy tclsh8.5; ac_word=$2
echo "$as_me:$LINENO: checking for $ac_word" >&5 { echo "$as_me:$LINENO: checking for $ac_word" >&5
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6 echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
if test "${ac_cv_path_TCLSH+set}" = set; then if test "${ac_cv_path_TCLSH+set}" = set; then
@@ -26291,8 +26291,8 @@ @@ -28044,8 +28044,8 @@
fi
if test "x$TCLSH" = "x"; then if test "x$TCLSH" = "x"; then
- # Extract the first word of "tclsh8.3", so it can be a program name with args. - # Extract the first word of "tclsh8.3", so it can be a program name with args.
-set dummy tclsh8.3; ac_word=$2 -set dummy tclsh8.3; ac_word=$2
+ # Extract the first word of "tclsh8.4", so it can be a program name with args. + # Extract the first word of "tclsh8.4", so it can be a program name with args.
+set dummy tclsh8.4; ac_word=$2 +set dummy tclsh8.4; ac_word=$2
echo "$as_me:$LINENO: checking for $ac_word" >&5 { echo "$as_me:$LINENO: checking for $ac_word" >&5
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6 echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
if test "${ac_cv_path_TCLSH+set}" = set; then if test "${ac_cv_path_TCLSH+set}" = set; then
@@ -26331,7 +26331,47 @@ @@ -28085,7 +28085,48 @@
fi
if test "x$TCLSH" = "x"; then if test "x$TCLSH" = "x"; then
- # Extract the first word of "tclsh", so it can be a program name with args. - # Extract the first word of "tclsh", so it can be a program name with args.
+ # Extract the first word of "tclsh8.3", so it can be a program name with args. + # Extract the first word of "tclsh8.3", so it can be a program name with args.
+set dummy tclsh8.3; ac_word=$2 +set dummy tclsh8.3; ac_word=$2
+echo "$as_me:$LINENO: checking for $ac_word" >&5 +{ echo "$as_me:$LINENO: checking for $ac_word" >&5
+echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6 +echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
+if test "${ac_cv_path_TCLSH+set}" = set; then +if test "${ac_cv_path_TCLSH+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6 + echo $ECHO_N "(cached) $ECHO_C" >&6
+else +else
@ -46,60 +46,72 @@ diff -urN graphviz-2.12/configure graphviz-2.12-patched/configure
+ IFS=$as_save_IFS + IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=. + test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do + for ac_exec_ext in '' $ac_executable_extensions; do
+ if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then + if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
+ ac_cv_path_TCLSH="$as_dir/$ac_word$ac_exec_ext" + ac_cv_path_TCLSH="$as_dir/$ac_word$ac_exec_ext"
+ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5 + echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2 + break 2
+ fi + fi
+done +done
+done +done
+IFS=$as_save_IFS
+ +
+ ;; + ;;
+esac +esac
+fi +fi
+TCLSH=$ac_cv_path_TCLSH +TCLSH=$ac_cv_path_TCLSH
+
+if test -n "$TCLSH"; then +if test -n "$TCLSH"; then
+ echo "$as_me:$LINENO: result: $TCLSH" >&5 + { echo "$as_me:$LINENO: result: $TCLSH" >&5
+echo "${ECHO_T}$TCLSH" >&6 +echo "${ECHO_T}$TCLSH" >&6; }
+else +else
+ echo "$as_me:$LINENO: result: no" >&5 + { echo "$as_me:$LINENO: result: no" >&5
+echo "${ECHO_T}no" >&6 +echo "${ECHO_T}no" >&6; }
+fi +fi
+ +
+
+ if test "x$TCLSH" = "x"; then + if test "x$TCLSH" = "x"; then
+ # Extract the first word of "tclsh", so it can be a program name with args. + # Extract the first word of "tclsh", so it can be a program name with args.
set dummy tclsh; ac_word=$2 set dummy tclsh; ac_word=$2
echo "$as_me:$LINENO: checking for $ac_word" >&5 { echo "$as_me:$LINENO: checking for $ac_word" >&5
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6 echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
@@ -26370,6 +26410,7 @@ @@ -28125,6 +28166,7 @@
echo "${ECHO_T}no" >&6
fi fi
+ fi + fi
fi fi
fi fi
if test "x$TCLSH" = "x"; then
@@ -28413,8 +28455,8 @@
fi fi
@@ -26674,8 +26715,8 @@
WISH=$withval
fi;
if test "x$WISH" = "x"; then if test "x$WISH" = "x"; then
- # Extract the first word of "wish8.4", so it can be a program name with args. - # Extract the first word of "wish8.4", so it can be a program name with args.
-set dummy wish8.4; ac_word=$2 -set dummy wish8.4; ac_word=$2
+ # Extract the first word of "wish8.5", so it can be a program name with args. + # Extract the first word of "wish8.5", so it can be a program name with args.
+set dummy wish8.5; ac_word=$2 +set dummy wish8.5; ac_word=$2
echo "$as_me:$LINENO: checking for $ac_word" >&5 { echo "$as_me:$LINENO: checking for $ac_word" >&5
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6 echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
if test "${ac_cv_path_WISH+set}" = set; then if test "${ac_cv_path_WISH+set}" = set; then
@@ -26714,7 +26755,47 @@ @@ -28454,8 +28496,8 @@
fi
if test "x$WISH" = "x"; then if test "x$WISH" = "x"; then
- # Extract the first word of "wish8.3", so it can be a program name with args. - # Extract the first word of "wish8.3", so it can be a program name with args.
+ # Extract the first word of "wish8.4", so it can be a program name with args. -set dummy wish8.3; ac_word=$2
+ # Extract the first word of "wish8.4", so it can be a program name with args.
+set dummy wish8.4; ac_word=$2 +set dummy wish8.4; ac_word=$2
+echo "$as_me:$LINENO: checking for $ac_word" >&5 { echo "$as_me:$LINENO: checking for $ac_word" >&5
+echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6 echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
if test "${ac_cv_path_WISH+set}" = set; then
@@ -28495,7 +28537,48 @@
if test "x$WISH" = "x"; then
- # Extract the first word of "wish", so it can be a program name with args.
+ # Extract the first word of "wish8.3", so it can be a program name with args.
+set dummy wish8.3; ac_word=$2
+{ echo "$as_me:$LINENO: checking for $ac_word" >&5
+echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
+if test "${ac_cv_path_WISH+set}" = set; then +if test "${ac_cv_path_WISH+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6 + echo $ECHO_N "(cached) $ECHO_C" >&6
+else +else
@ -114,52 +126,42 @@ diff -urN graphviz-2.12/configure graphviz-2.12-patched/configure
+ IFS=$as_save_IFS + IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=. + test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do + for ac_exec_ext in '' $ac_executable_extensions; do
+ if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then + if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
+ ac_cv_path_WISH="$as_dir/$ac_word$ac_exec_ext" + ac_cv_path_WISH="$as_dir/$ac_word$ac_exec_ext"
+ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5 + echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2 + break 2
+ fi + fi
+done +done
+done +done
+IFS=$as_save_IFS
+ +
+ ;; + ;;
+esac +esac
+fi +fi
+WISH=$ac_cv_path_WISH +WISH=$ac_cv_path_WISH
+
+if test -n "$WISH"; then +if test -n "$WISH"; then
+ echo "$as_me:$LINENO: result: $WISH" >&5 + { echo "$as_me:$LINENO: result: $WISH" >&5
+echo "${ECHO_T}$WISH" >&6 +echo "${ECHO_T}$WISH" >&6; }
+else +else
+ echo "$as_me:$LINENO: result: no" >&5 + { echo "$as_me:$LINENO: result: no" >&5
+echo "${ECHO_T}no" >&6 +echo "${ECHO_T}no" >&6; }
+fi +fi
+ +
+ if test "x$WISH" = "x"; then +
+ # Extract the first word of "wish8.3", so it can be a program name with args. + if test "x$WISH" = "x"; then
set dummy wish8.3; ac_word=$2
echo "$as_me:$LINENO: checking for $ac_word" >&5
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
@@ -26753,8 +26834,8 @@
echo "${ECHO_T}no" >&6
fi
- if test "x$WISH" = "x"; then
- # Extract the first word of "wish", so it can be a program name with args.
+ if test "x$WISH" = "x"; then
+ # Extract the first word of "wish", so it can be a program name with args. + # Extract the first word of "wish", so it can be a program name with args.
set dummy wish; ac_word=$2 set dummy wish; ac_word=$2
echo "$as_me:$LINENO: checking for $ac_word" >&5 { echo "$as_me:$LINENO: checking for $ac_word" >&5
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6 echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
@@ -26793,6 +26874,7 @@ @@ -28535,6 +28618,7 @@
echo "${ECHO_T}no" >&6
fi fi
+ fi + fi
fi fi
fi fi
fi fi
@@ -26815,7 +26897,7 @@ @@ -28557,7 +28641,7 @@
WISH_EXEC_PREFIX=`echo $WISH|sed -e 's%/bin/wish.*$%%'` WISH_EXEC_PREFIX=`echo $WISH|sed -e 's%/bin/wish.*$%%'`
if test -f ${WISH_EXEC_PREFIX}/include/tk${TK_VERSION_FOUND}/tk.h; then if test -f ${WISH_EXEC_PREFIX}/include/tk${TK_VERSION_FOUND}/tk.h; then
@ -168,65 +170,7 @@ diff -urN graphviz-2.12/configure graphviz-2.12-patched/configure
else else
if test "x${WISH_EXEC_PREFIX}" != "x/usr" -a -f ${WISH_EXEC_PREFIX}/include/tk.h; then if test "x${WISH_EXEC_PREFIX}" != "x/usr" -a -f ${WISH_EXEC_PREFIX}/include/tk.h; then
TK_INCLUDES=-I${WISH_EXEC_PREFIX}/include TK_INCLUDES=-I${WISH_EXEC_PREFIX}/include
@@ -33490,7 +33572,7 @@ @@ -34721,7 +34805,7 @@
# -----------------------------------
# tkInt.h
if test -f "$TK_SRC_DIR/generic/tkInt.h"; then
-TKINT_INCLUDES="-I$TK_SRC_DIR/generic"
+TKINT_INCLUDES="-I$TK_SRC_DIR/generic -I$TK_SRC_DIR/unix"
else
if test -f "/usr/include/tkInt.h"; then
TKINT_INCLUDES=""
diff -urN graphviz-2.12/configure.ac graphviz-2.12-patched/configure.ac
--- graphviz-2.12/configure.ac 2006-12-04 15:11:58.000000000 -0600
+++ graphviz-2.12-patched/configure.ac 2007-02-07 08:20:02.000000000 -0600
@@ -755,11 +755,14 @@
TCLSH=$withval,)
if test "x$TCLSH" = "x"; then
- AC_PATH_PROG(TCLSH,tclsh8.4)
+ AC_PATH_PROG(TCLSH,tclsh8.5)
if test "x$TCLSH" = "x"; then
- AC_PATH_PROG(TCLSH,tclsh8.3)
+ AC_PATH_PROG(TCLSH,tclsh8.4)
if test "x$TCLSH" = "x"; then
- AC_PATH_PROG(TCLSH,tclsh)
+ AC_PATH_PROG(TCLSH,tclsh8.3)
+ if test "x$TCLSH" = "x"; then
+ AC_PATH_PROG(TCLSH,tclsh)
+ fi
fi
fi
fi
@@ -904,11 +907,14 @@
[ --with-wish=PROG build graphviz for specific wish],
WISH=$withval,)
if test "x$WISH" = "x"; then
- AC_PATH_PROG(WISH,wish8.4)
+ AC_PATH_PROG(WISH,wish8.5)
if test "x$WISH" = "x"; then
- AC_PATH_PROG(WISH,wish8.3)
- if test "x$WISH" = "x"; then
- AC_PATH_PROG(WISH,wish)
+ AC_PATH_PROG(WISH,wish8.4)
+ if test "x$WISH" = "x"; then
+ AC_PATH_PROG(WISH,wish8.3)
+ if test "x$WISH" = "x"; then
+ AC_PATH_PROG(WISH,wish)
+ fi
fi
fi
fi
@@ -930,7 +936,7 @@
WISH_EXEC_PREFIX=`echo $WISH|sed -e 's%/bin/wish.*$%%'`
if test -f ${WISH_EXEC_PREFIX}/include/tk${TK_VERSION_FOUND}/tk.h; then
- TK_INCLUDES="-I${WISH_EXEC_PREFIX}/include/tk${TK_VERSION_FOUND} -I${WISH_EXEC_PREFIX}/include/tk${TK_VERSION_FOUND}/generic"
+ TK_INCLUDES="-I${WISH_EXEC_PREFIX}/include/tk${TK_VERSION_FOUND} -I${WISH_EXEC_PREFIX}/include/tk${TK_VERSION_FOUND}/generic -I${WISH_EXEC_PREFIX}/include/tk${TK_VERSION_FOUND}/unix"
else
if test "x${WISH_EXEC_PREFIX}" != "x/usr" -a -f ${WISH_EXEC_PREFIX}/include/tk.h; then
TK_INCLUDES=-I${WISH_EXEC_PREFIX}/include
@@ -1673,7 +1679,7 @@
# ----------------------------------- # -----------------------------------
# tkInt.h # tkInt.h
if test -f "$TK_SRC_DIR/generic/tkInt.h"; then if test -f "$TK_SRC_DIR/generic/tkInt.h"; then

View File

@ -8,7 +8,7 @@ Name: graphviz
Summary: Graph Visualization Tools Summary: Graph Visualization Tools
Version: 2.16 Version: 2.16
%define truerelease 3.1 %define truerelease 3.2
%{?distroagnostic: %define release %{truerelease}} %{?distroagnostic: %define release %{truerelease}}
%{!?distroagnostic: %define release %{truerelease}%{?dist}} %{!?distroagnostic: %define release %{truerelease}%{?dist}}
@ -18,6 +18,7 @@ Group: Applications/Multimedia
License: CPL License: CPL
URL: http://www.graphviz.org/ URL: http://www.graphviz.org/
Source0: http://www.graphviz.org/pub/graphviz/ARCHIVE/%{name}-%{version}.tar.gz Source0: http://www.graphviz.org/pub/graphviz/ARCHIVE/%{name}-%{version}.tar.gz
Patch0: %{name}-tk8.5.patch
# graphviz is relocatable - Caution: this feature is used in AT&T, # graphviz is relocatable - Caution: this feature is used in AT&T,
# but probably will not be supported in Redhat/Fedora/Centos distros # but probably will not be supported in Redhat/Fedora/Centos distros
@ -145,10 +146,10 @@ BuildRequires: cairo-devel >= 1.1.10 pango-devel gmp-devel lua-devel gtk2-devel
%define GDK_PIXBUF --with-gdk-pixbuf %define GDK_PIXBUF --with-gdk-pixbuf
BuildRequires: gd gd-devel perl-devel DevIL-devel BuildRequires: gd gd-devel perl-devel DevIL-devel
%endif %endif
#%if "%fedora" >= "9" %if "%fedora" >= "9"
#%define MING 1 %define MING 0
#BuildRequires: ming ming-devel #BuildRequires: ming ming-devel
#%endif %endif
%endif %endif
#-- main graphviz rpm ------------------------------------------------ #-- main graphviz rpm ------------------------------------------------
@ -504,6 +505,7 @@ Provides some additional PDF and HTML documentation for graphviz.
%prep %prep
%setup -q %setup -q
%patch0 -p1
%build %build
%if ! %{SHARP} %if ! %{SHARP}
@ -582,6 +584,10 @@ rm -rf %{buildroot}
#-- changelog -------------------------------------------------- #-- changelog --------------------------------------------------
%changelog %changelog
* Thu Jan 3 2008 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.16-3.2
- Re-added tcl/tk 8.5 patch
- Tweaked ming stuff
* Thu Jan 3 2008 Alex Lancaster <alexlan[AT]fedoraproject.org> - 2.16-3.1 * Thu Jan 3 2008 Alex Lancaster <alexlan[AT]fedoraproject.org> - 2.16-3.1
- Rebuild against new Tcl 8.5 - Rebuild against new Tcl 8.5