update to 7.0.5, patch out distutils usage to build with Python 3.12

This commit is contained in:
Tom Callaway 2022-12-29 15:22:03 -05:00
parent 5b8ce2dae9
commit b93a6781b5
3 changed files with 29 additions and 2 deletions

View File

@ -0,0 +1,21 @@
diff -up graphviz-7.0.5/configure.ac.fixpy312 graphviz-7.0.5/configure.ac
--- graphviz-7.0.5/configure.ac.fixpy312 2022-12-29 14:11:15.564390331 -0500
+++ graphviz-7.0.5/configure.ac 2022-12-29 14:16:03.923297996 -0500
@@ -1129,7 +1129,7 @@ else
PYTHON_PREFIX=`$PYTHON -c "import sys; print(sys.prefix)"`
PYTHON_INCLUDES=-I$PYTHON_PREFIX/include/python$PYTHON_VERSION
PYTHON_LIBS="-undefined dynamic_lookup"
- PYTHON_INSTALL_DIR="`$PYTHON -c 'from distutils import sysconfig; print(sysconfig.get_python_lib(1,0))'`"
+ PYTHON_INSTALL_DIR="`$PYTHON -c 'import sysconfig; print(sysconfig.get_path("platlib"))'`"
save_CPPFLAGS=$CPPFLAGS
CPPFLAGS="$CPPFLAGS $PYTHON_INCLUDES"
AC_CHECK_HEADER(Python.h,,[
@@ -1189,7 +1189,7 @@ else
use_python3="No (python-$PYTHON3_VERSION.pc not found)"
fi
fi
- PYTHON3_INSTALL_DIR="`$PYTHON3 -c 'from distutils import sysconfig; print(sysconfig.get_python_lib(1,0))'`"
+ PYTHON3_INSTALL_DIR="`$PYTHON3 -c 'import sysconfig; print(sysconfig.get_path("platlib"))'`"
save_CPPFLAGS=$CPPFLAGS
CPPFLAGS="$CPPFLAGS $PYTHON3_INCLUDES"
AC_CHECK_HEADER(Python.h,,[

View File

@ -81,7 +81,7 @@
Name: graphviz
Summary: Graph Visualization Tools
Version: 7.0.4
Version: 7.0.5
Release: 1%{?dist}
License: EPL-1.0
URL: http://www.graphviz.org/
@ -180,6 +180,8 @@ Requires(post): /sbin/ldconfig
Requires(postun): /sbin/ldconfig
# rhbz#1838679
Patch0: graphviz-4.0.0-gvpack-neato-static.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=2155048
Patch1: graphviz-7.0.5-fix-python-3.12.patch
%if ! %{JAVA}
Obsoletes: graphviz-java < %{version}-%{release}
@ -728,6 +730,10 @@ php --no-php-ini \
%endif
%changelog
* Thu Dec 29 2022 Tom Callaway <spot@fedoraproject.org> - 7.0.5-1
- update to 7.0.5
- patch out distutils usage to build with Python 3.12
* Thu Dec 15 2022 Jaroslav Škarvada <jskarvad@redhat.com> - 7.0.4-1
- New version
Resolves: rhbz#2150535

View File

@ -1 +1 @@
SHA512 (graphviz-7.0.4.tar.bz2) = 19d1451fb96731e7c444866941f4664794b1ff6e6521622eca9581cf5cb1035f9de919768481837f4397bcc196b3f943b551a65572fad3fd80cbac49f57d53bf
SHA512 (graphviz-7.0.5.tar.bz2) = 81b7f25676ec1f160d96a1f7238f3323a037d223f82a956e910f9de693bbaac86b5e4f717aaf66d49aa31609b2d23742d7634d2213b23555313389e71367c5e9