New version

Resolves: rhbz#2091383
This commit is contained in:
Jaroslav Škarvada 2022-06-07 01:33:53 +02:00
parent f0418c521d
commit 67eea448aa
4 changed files with 86 additions and 28 deletions

View File

@ -0,0 +1,14 @@
diff --git a/cmd/tools/Makefile.am b/cmd/tools/Makefile.am
index c1764e1..deafb51 100644
--- a/cmd/tools/Makefile.am
+++ b/cmd/tools/Makefile.am
@@ -122,7 +122,8 @@ gvcolor_SOURCES = gvcolor.c colxlate.c colortbl.h
gvcolor_LDADD = \
$(top_builddir)/lib/ingraphs/libingraphs_C.la \
- $(top_builddir)/lib/cgraph/libcgraph.la
+ $(top_builddir)/lib/cgraph/libcgraph.la \
+ -lm
bcomps_SOURCES = bcomps.c

View File

@ -11,5 +11,5 @@ index 4978fea..9fbe2e2 100644
+ $(top_builddir)/lib/pathplan/libpathplan_C.la \
+ $(EXPAT_LIBS) $(Z_LIBS) $(GTS_LIBS) $(SOCKET_LIBS) $(IPSEPCOLA_LIBS) $(MATH_LIBS)
# add a non-existent C++ source to force the C++ compiler to be used for
# linking, so the C++ standard library is included for our C++ dependencies
if ENABLE_STATIC
gvpack_static_SOURCES = gvpack.cpp

View File

@ -50,6 +50,8 @@
%global GUILE 0
%endif
%global GOLANG 1
# Plugins version
%global pluginsver 6
@ -68,8 +70,8 @@
Name: graphviz
Summary: Graph Visualization Tools
Version: 3.0.0
Release: 2%{?dist}
Version: 4.0.0
Release: 1%{?dist}
License: EPL-1.0
URL: http://www.graphviz.org/
Source0: https://gitlab.com/%{name}/%{name}/-/archive/%{version}/%{name}-%{version}.tar.bz2
@ -150,13 +152,23 @@ BuildRequires: librsvg2-devel
BuildRequires: ghostscript
BuildRequires: libgs-devel
BuildRequires: make
BuildRequires: poppler-glib-devel
BuildRequires: freeglut-devel
BuildRequires: libglade2-devel
BuildRequires: gtkglext-devel
BuildRequires: doxygen
%if %{GOLANG}
BuildRequires: golang
%endif
# ISO8859-1 fonts are required by lefty
Requires: urw-base35-fonts
Requires: xorg-x11-fonts-ISO8859-1-100dpi
Requires(post): /sbin/ldconfig
Requires(postun): /sbin/ldconfig
# rhbz#1838679
Patch0: graphviz-2.49.3-gvpack-neato-static.patch
Patch0: graphviz-4.0.0-gvpack-neato-static.patch
# https://gitlab.com/graphviz/graphviz/-/issues/2246
Patch1: graphviz-4.0.0-gvcolor-lm-fix.patch
%description
A collection of tools for the manipulation and layout of graphs (as in nodes
@ -189,6 +201,12 @@ Summary: PDF and HTML documents for graphviz
%description doc
Provides some additional PDF and HTML documentation for graphviz.
%package smyrna
Summary: Graphviz interactive graph viewer
%description smyrna
Smyrna is a viewer for graphs in the DOT format.
%package gd
Summary: Graphviz plugin for renderers based on gd
Requires: %{name} = %{version}-%{release}
@ -334,6 +352,15 @@ Requires: %{name} = %{version}-%{release}, tcl >= 8.3, tk
%description tcl
Various tcl packages (extensions) for the graphviz tools.
%if %{GOLANG}
%package go
Summary: Go extension for graphviz
Requires: %{name} = %{version}-%{release}, golang
%description go
Go extension for graphviz.
%endif
%prep
%autosetup -p1
@ -379,29 +406,29 @@ export CPPFLAGS=-I`ruby -e "puts File.join(RbConfig::CONFIG['includedir'], RbCon
--without-qt \
%endif
%if %{GUILE}
--enable-guile=yes
--enable-guile=yes \
%else
--enable-guile=no
--enable-guile=no \
%endif
%if %{GOLANG}
--enable-go=yes
%else
--enable-go=no
%endif
# drop rpath
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -fno-strict-overflow %{?FFSTORE}" \
%make_build CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -fno-strict-overflow %{?FFSTORE}" \
CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -fno-strict-overflow %{?FFSTORE}"
make doxygen
%install
make DESTDIR=%{buildroot} \
docdir=%{buildroot}%{_docdir}/%{name} \
pkgconfigdir=%{_libdir}/pkgconfig \
install
%make_install docdir=%{_docdir}/%{name} \
pkgconfigdir=%{_libdir}/pkgconfig
find %{buildroot} -type f -name "*.la" -exec rm -f {} ';'
# Move docs to the right place
mkdir -p %{buildroot}%{_docdir}/%{name}
mv %{buildroot}%{_datadir}/%{name}/doc/* %{buildroot}%{_docdir}/%{name}
# Install README
install -m0644 README %{buildroot}%{_docdir}/%{name}
@ -427,8 +454,8 @@ find %{buildroot}%{_docdir}/%{name}/demo -type f -name "*.py" -exec mv {} {}.dem
rm -f %{buildroot}%{_bindir}/dot_builtins
# Remove metadata from generated PDFs
pushd %{buildroot}%{_docdir}/%{name}/pdf
for f in prune lneato.1 lefty.1 gvgen.1 gc.1 dotty.1 dot.1 cluster.1
pushd %{buildroot}%{_docdir}/%{name}
for f in prune gvgen.1 gc.1 dot.1 cluster.1
do
if [ -f $f.pdf ]
then
@ -519,22 +546,24 @@ php --no-php-ini \
%files
%doc %{_docdir}/%{name}
%exclude %{_bindir}/smyrna
%{_bindir}/*
%dir %{_libdir}/graphviz
%{_libdir}/*.so.*
%{_libdir}/graphviz/*.so.*
%exclude %{_mandir}/man1/smyrna.1*
%{_mandir}/man1/*.1*
%{_mandir}/man7/*.7*
%dir %{_datadir}/graphviz
%exclude %{_docdir}/%{name}/html
%exclude %{_docdir}/%{name}/pdf
%dir %{_datadir}/%{name}
%exclude %{_docdir}/%{name}/*.html
%exclude %{_docdir}/%{name}/*.pdf
%exclude %{_docdir}/%{name}/demo
%{_datadir}/graphviz/lefty
%{_datadir}/graphviz/gvpr
%ghost %{_libdir}/graphviz/config%{pluginsver}
%{_datadir}/%{name}/gvpr
%{_datadir}/%{name}/examples
%ghost %{_libdir}/%{name}/config%{pluginsver}
%if %{QTAPPS}
%{_datadir}/graphviz/gvedit
%{_datadir}/%{name}/gvedit
%endif
%exclude %{_libdir}/graphviz/*/*
@ -562,10 +591,15 @@ php --no-php-ini \
%endif
%files doc
%doc %{_docdir}/%{name}/html
%doc %{_docdir}/%{name}/pdf
%doc %{_docdir}/%{name}/*.html
%doc %{_docdir}/%{name}/*.pdf
%doc %{_docdir}/%{name}/demo
%files smyrna
%{_bindir}/smyrna
%{_datadir}/%{name}/smyrna
%{_mandir}/man1/smyrna.1*
%files gd
%{_libdir}/graphviz/libgvplugin_gd.so.*
@ -652,7 +686,17 @@ php --no-php-ini \
# always includes tcldot.3tcl, gdtclft.3tcl
%{_mandir}/man3/*.3tcl*
%if %{GOLANG}
%files go
%{_libdir}/graphviz/go/
%{_mandir}/man3/gv.3go.*
%endif
%changelog
* Mon Jun 6 2022 Jaroslav Škarvada <jskarvad@redhat.com> - 4.0.0-1
- New version
Resolves: rhbz#2091383
* Wed Jun 01 2022 Jitka Plesnikova <jplesnik@redhat.com> - 3.0.0-2
- Perl 5.36 rebuild

View File

@ -1 +1 @@
SHA512 (graphviz-3.0.0.tar.bz2) = 9478731fabf75c67379c63bd3ffdd9b481bcee8610cdb70d24b0bea54c5bb6d56e9139329a62680051e26a9002497a4df977080e4020f477e35882b21743be80
SHA512 (graphviz-4.0.0.tar.bz2) = a42300b6261dc62d3106182862fc0f9e719e6354f015f18ffde3df04c5567caef04edcc8099e9aabac3bc0e09deb0fb2702f17537ece57547d2a045cd39d0161