- New version (#580017)

- Fixed gtk plugin program-name (#640671, gtk-progname patch)
- Fixed broken links in doc index (#642536, doc-index-fix patch)
- Fixed SIGSEGVs on testsuite (#645703, testsuite-sigsegv-fix patch)
- Testsuite now do diff check also in case of err output (#645703,
  rtest-errout-fix patch)
- Testsuite enabled on all arches (#645703)
- Added urw-fonts to BuildRequires
- Compiled with -fno-strict-aliasing
- Fixed rpmlint warnings on spec file
- Removed unused patches
This commit is contained in:
Jaroslav Škarvada 2011-01-07 00:04:57 +01:00
parent 8db864f181
commit 36b7ab18a3
16 changed files with 186 additions and 402 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
graphviz-2.26.0.tar.gz
/graphviz-2.26.3.tar.gz

View File

@ -1,13 +0,0 @@
--- graphviz-2.20.3/configure.orig 2009-02-25 13:14:22.000000000 -0500
+++ graphviz-2.20.3/configure 2009-02-25 13:15:02.000000000 -0500
@@ -27376,8 +27376,8 @@
if test "x$use_swig" != "xYes"; then
use_php="No (swig not available)"
else
- if test `$SWIG -help 2>&1 | $GREP -c '\-php5 *- Generate'` = 0; then
- use_php="No (swig does not support -php5 option)"
+ if test `$SWIG -help 2>&1 | $GREP -c '\-php5* *- Generate'` = 0; then
+ use_php="No (swig does not support -php or -php5 option)"
else
# Extract the first word of "php", so it can be a program name with args.
set dummy php; ac_word=$2

View File

@ -1,45 +0,0 @@
--- graphviz-2.20.3/tclpkg/gv/gv.i.orig 2009-02-25 13:44:36.000000000 -0500
+++ graphviz-2.20.3/tclpkg/gv/gv.i 2009-02-25 13:46:29.000000000 -0500
@@ -15,8 +15,22 @@
**********************************************************/
%module gv
-%{
+#ifdef SWIGTCL
+// A typemap telling SWIG to ignore an argument for input
+// However, we still need to pass a pointer to the C function
+%typemap(in,numinputs=0) char *outdata (char *temp) {
+ $1 = &temp;
+}
+// A typemap defining how to return an argument by appending it to the result
+%typemap(argout) char *outdata {
+ Tcl_Obj *o = Tcl_NewStringObj($1);
+ Tcl_ListObjAppendElement(interp,$result,o);
+}
+#endif
+
+
+%{
/* some language headers (e.g. php.h, ruby.h) leave these defined */
#undef PACKAGE_BUGREPORT
#undef PACKAGE_STRING
@@ -371,18 +385,4 @@
extern bool write(Agraph_t *g, char *filename);
extern bool write(Agraph_t *g, FILE *f);
-
-#ifdef SWIGTCL
-// A typemap telling SWIG to ignore an argument for input
-// However, we still need to pass a pointer to the C function
-%typemap(in,numinputs=0) char *outdata (char *temp) {
- $1 = &temp;
-}
-// A typemap defining how to return an argument by appending it to the result
-%typemap(argout) char *outdata {
- Tcl_Obj *o = Tcl_NewStringObj($1);
- Tcl_ListObjAppendElement(interp,$result,o);
-}
-#endif
-
%}

View File

@ -0,0 +1,85 @@
--- graphviz-2.26.0/doc/index.html.old 2008-08-25 19:09:29.000000000 +0200
+++ graphviz-2.26.0/doc/index.html 2010-10-13 14:52:56.000000000 +0200
@@ -13,7 +13,6 @@
<ul>
<li><a href="FAQ.html">FAQ</a>
<li><a href="build.html">build</a>
- <li><a href="gd.html">gd</a>
<li><a href="tcldot.html">tcldot</a>
</ul>
<li>Guides (PDF)
@@ -26,45 +25,41 @@
</ul>
<li>Command manual pages (PDF)
<ul>
- <li><a href="../pdf/acyclic.pdf">acyclic.1</a>
- <li><a href="../pdf/bcomps.pdf">bcmps.1</a>
- <li><a href="../pdf/ccomps.pdf">ccomps.1</a>
- <li><a href="../pdf/circo.pdf">circo.1</a>
- <li><a href="../pdf/dijkstra.pdf">dijkstra.1</a>
- <li><a href="../pdf/dot.pdf">dot.1</a>
- <li><a href="../pdf/dot2gxl.pdf">dot2gxl.1</a>
- <li><a href="../pdf/dotneato-config.pdf">dotneato-config.1</a>
- <li><a href="../pdf/dotty.pdf">dotty.1</a>
- <li><a href="../pdf/fdp.pdf">fdp.1</a>
- <li><a href="../pdf/gc.pdf">gc.1</a>
- <li><a href="../pdf/gvcolor.pdf">gvcolor.1</a>
- <li><a href="../pdf/gvpack.pdf">gvpack.1</a>
- <li><a href="../pdf/gvpr.pdf">gvpr.1</a>
- <li><a href="../pdf/gxl2dot.pdf">gxl2dot.1</a>
- <li><a href="../pdf/lefty.pdf">lefty.1</a>
- <li><a href="../pdf/lneato.pdf">lneato.1</a>
- <li><a href="../pdf/neato.pdf">neato.1</a>
- <li><a href="../pdf/nop.pdf">nop.1</a>
- <li><a href="../pdf/prune.pdf">prune.1</a>
- <li><a href="../pdf/sccmap.pdf">sccmap.1</a>
- <li><a href="../pdf/tred.pdf">tred.1</a>
- <li><a href="../pdf/twopi.pdf">twopi.1</a>
- <li><a href="../pdf/unflatten.pdf">unflatten.1</a>
+ <li><a href="../pdf/acyclic.1.pdf">acyclic</a>
+ <li><a href="../pdf/bcomps.1.pdf">bcmps</a>
+ <li><a href="../pdf/ccomps.1.pdf">ccomps</a>
+ <li><a href="../pdf/circo.1.pdf">circo</a>
+ <li><a href="../pdf/dijkstra.1.pdf">dijkstra</a>
+ <li><a href="../pdf/dot.1.pdf">dot</a>
+ <li><a href="../pdf/dotty.1.pdf">dotty</a>
+ <li><a href="../pdf/fdp.1.pdf">fdp</a>
+ <li><a href="../pdf/gc.1.pdf">gc</a>
+ <li><a href="../pdf/gvcolor.1.pdf">gvcolor</a>
+ <li><a href="../pdf/gvpack.1.pdf">gvpack</a>
+ <li><a href="../pdf/gvpr.1.pdf">gvpr</a>
+ <li><a href="../pdf/lefty.1.pdf">lefty</a>
+ <li><a href="../pdf/lneato.1.pdf">lneato</a>
+ <li><a href="../pdf/neato.1.pdf">neato</a>
+ <li><a href="../pdf/nop.1.pdf">nop</a>
+ <li><a href="../pdf/prune.pdf">prune</a>
+ <li><a href="../pdf/sccmap.1.pdf">sccmap</a>
+ <li><a href="../pdf/tred.1.pdf">tred</a>
+ <li><a href="../pdf/twopi.1.pdf">twopi</a>
+ <li><a href="../pdf/unflatten.1.pdf">unflatten</a>
</ul>
<li>Tcl package manual pages (PDF)
<ul>
- <li><a href="../pdf/gdtclft.pdf">gdtclft.n</a>
- <li><a href="../pdf/tcldot.pdf">tcldot.n</a>
- <li><a href="../pdf/tkspline.pdf">tkspline.n</a>
+ <li><a href="../pdf/gdtclft.3tcl.pdf">gdtclft</a>
+ <li><a href="../pdf/tcldot.3tcl.pdf">tcldot</a>
+ <li><a href="../pdf/gv.3tcl.pdf">gv</a>
+ <li><a href="../pdf/tkspline.3tk.pdf">tkspline</a>
</ul>
<li>Library manual pages (PDF)
<ul>
- <li><a href="../pdf/agraph.pdf">agraph.3</a>
- <li><a href="../pdf/cdt.pdf">cdt.3</a>
- <li><a href="../pdf/expr.pdf">expr.3</a>
- <li><a href="../pdf/graph.pdf">graph.3</a>
- <li><a href="../pdf/pathplan.pdf">pathplan.3</a>
- <li><a href="../pdf/pack.pdf">pack.3</a>
+ <li><a href="../pdf/cgraph.3.pdf">cgraph</a>
+ <li><a href="../pdf/cdt.3.pdf">cdt</a>
+ <li><a href="../pdf/graph.3.pdf">graph</a>
+ <li><a href="../pdf/pathplan.3.pdf">pathplan</a>
</ul>
</ul>
</body>

View File

@ -0,0 +1,11 @@
--- graphviz-2.26.0/plugin/gtk/callbacks.c.old 2009-06-03 03:10:57.000000000 +0200
+++ graphviz-2.26.0/plugin/gtk/callbacks.c 2010-10-06 17:38:59.703008542 +0200
@@ -187,7 +187,7 @@
NULL };
GtkWindow *window = GTK_WINDOW(gtk_widget_get_toplevel(GTK_WIDGET(menuitem)));
gtk_show_about_dialog(window,
- "name", "DotEdit",
+ "program-name", "DotEdit",
"version", "0.1",
"copyright", "(C) 2005 AT&T Corp.",
"license", "Common Public License, Version 1.0.",

View File

@ -0,0 +1,22 @@
--- graphviz-2.26.0/rtest/rtest.sh.old 2009-12-06 00:27:49.000000000 +0100
+++ graphviz-2.26.0/rtest/rtest.sh 2010-10-22 10:37:42.952893435 +0200
@@ -279,14 +279,16 @@
$testcmd 2> errout
RVAL=$?
+ if [[ -s errout ]]
+ then
+ cat errout
+ fi
+
if [[ $RVAL != 0 || ! -s $OUTPATH ]]
then
(( CRASH_CNT+=1 ))
print -u 2 "Test $TESTNAME:$i : == Layout failed =="
print -u 2 " $testcmd"
- elif [[ -s errout ]]
- then
- cat errout
elif [[ $GENERATE == 1 ]]
then
continue

View File

@ -0,0 +1,26 @@
--- graphviz-2.26.0/lib/gvc/gvconfig.c.old 2009-07-08 17:14:20.000000000 +0200
+++ graphviz-2.26.0/lib/gvc/gvconfig.c 2010-10-20 11:51:21.238392202 +0200
@@ -471,6 +471,7 @@
libdir = gvconfig_libdir(gvc);
rc = stat(libdir, &libdir_st);
if (rc == -1) {
+ gvtextlayout_select(gvc); /* choose best available textlayout plugin immediately */
/* if we fail to stat it then it probably doesn't exist so just fail silently */
return;
}
@@ -485,6 +486,7 @@
if (rescan) {
config_rescan(gvc, gvc->config_path);
gvc->config_found = TRUE;
+ gvtextlayout_select(gvc); /* choose best available textlayout plugin immediately */
return;
}
@@ -492,6 +494,7 @@
rc = stat(gvc->config_path, &config_st);
if (rc == -1) {
+ gvtextlayout_select(gvc); /* choose best available textlayout plugin immediately */
/* silently return without setting gvc->config_found = TRUE */
return;
}

View File

@ -1,29 +0,0 @@
Index: lib/common/Makefile.am
===================================================================
RCS file: /home/cvsroot/graphviz2/lib/common/Makefile.am,v
retrieving revision 1.46
retrieving revision 1.47
diff -u -r1.46 -r1.47
--- lib/common/Makefile.am 26 Jul 2007 13:53:25 -0000 1.46
+++ lib/common/Makefile.am 4 Sep 2007 23:39:07 -0000 1.47
@@ -1,4 +1,4 @@
-# $Id: Makefile.am,v 1.46 2007/07/26 13:53:25 erg Exp $ $Revision: 1.46 $
+# $Id: Makefile.am,v 1.47 2007/09/04 23:39:07 ellson Exp $ $Revision: 1.47 $
## Process this file with automake to produce Makefile.in
AM_CPPFLAGS = \
@@ -14,11 +14,10 @@
AM_CFLAGS = -D_BLD_common=1
endif
-pkginclude_HEADERS = geom.h color.h types.h textpara.h usershape.h
+pkginclude_HEADERS = arith.h geom.h color.h types.h textpara.h usershape.h
noinst_HEADERS = render.h utils.h memory.h \
- geomprocs.h colorprocs.h colortbl.h entities.h \
- logic.h arith.h globals.h \
- const.h macros.h htmllex.h htmltable.h pointset.h
+ geomprocs.h colorprocs.h colortbl.h entities.h globals.h \
+ logic.h const.h macros.h htmllex.h htmltable.h pointset.h
noinst_LTLIBRARIES = libcommon_C.la
if WITH_CODEGENS

View File

@ -1,29 +0,0 @@
--- graphviz-2.12/lib/common/colxlate.c.orig 2006-07-26 22:44:05.000000000 -0500
+++ graphviz-2.12/lib/common/colxlate.c 2007-07-12 14:07:13.000000000 -0500
@@ -1,4 +1,4 @@
-/* $Id: colxlate.c,v 1.11 2006/07/27 03:44:05 erg Exp $ $Revision: 1.11 $ */
+/* $Id: colxlate.c,v 1.13 2007/07/12 16:47:57 erg Exp $ $Revision: 1.13 $ */
/* vim:set shiftwidth=4 ts=8: */
/**********************************************************
@@ -180,6 +180,10 @@
/* resolveColor:
* Resolve input color str allowing color scheme namespaces.
+ * 0) "black" => "black"
+ * NB: This is something of a hack due to the remaining codegen.
+ * Once these are gone, this case could be removed and all references
+ * to "black" could be replaced by "/X11/black".
* 1) No initial / =>
* if colorscheme is defined and no "X11", return /colorscheme/str
* else return str
@@ -214,7 +218,8 @@
char* ss; /* second slash */
char* c2; /* second char */
- if (*str == '/') { /* if begins with '/' */
+ if ((*str == 'b') || !strncmp(str+1,"lack",4)) return str;
+ else if (*str == '/') { /* if begins with '/' */
c2 = str+1;
if ((ss = strchr(c2, '/'))) { /* if has second '/' */
if (*c2 == '/') { /* if second '/' is second character */

View File

@ -1,32 +0,0 @@
--- graphviz-2.16/lib/vpsc/generate-constraints.cpp.orig 2008-02-11 13:42:16.000000000 -0500
+++ graphviz-2.16/lib/vpsc/generate-constraints.cpp 2008-02-11 13:05:19.000000000 -0500
@@ -18,6 +18,7 @@
#include <set>
#include <cassert>
+#include <cstdlib>
#include "generate-constraints.h"
#include "constraint.h"
--- graphviz-2.16/lib/vpsc/csolve_VPSC.cpp.orig 2008-02-11 13:42:00.000000000 -0500
+++ graphviz-2.16/lib/vpsc/csolve_VPSC.cpp 2008-02-11 13:05:19.000000000 -0500
@@ -21,6 +21,7 @@
#include <constraint.h>
#include <generate-constraints.h>
#include <solve_VPSC.h>
+#include <cstdlib>
#include <cassert>
#include "csolve_VPSC.h"
extern "C" {
--- graphviz-2.16/tclpkg/gv/gv.i.orig 2008-02-11 13:41:21.000000000 -0500
+++ graphviz-2.16/tclpkg/gv/gv.i 2008-02-11 13:38:57.000000000 -0500
@@ -25,6 +25,9 @@
#undef TRUE
#undef FALSE
+#ifdef HAVE_CONFIG_H
+#include "config.h"
+#endif
#include "gvc.h"
%}

View File

@ -1,11 +0,0 @@
--- graphviz-2.12/lib/expr/Makefile.am.orig 2006-09-26 11:47:54.000000000 -0500
+++ graphviz-2.12/lib/expr/Makefile.am 2007-05-05 11:49:49.000000000 -0500
@@ -34,7 +34,7 @@
libexpr_la_LDFLAGS = -version-info @VERSION_INFO@
libexpr_la_SOURCES = $(libexpr_C_la_SOURCES)
-libexpr_la_LIBADD = $(libexpr_C_la_LIBADD)
+libexpr_la_LIBADD = $(libexpr_C_la_LIBADD) \
$(top_builddir)/lib/cdt/libcdt.la
$(libexpr_la_OBJECTS): exparse.h exparse.c exgram.h exop.h

View File

@ -1,14 +0,0 @@
diff -urN graphviz-2.16.1.orig/plugin/pango/gvtextlayout_pango.c graphviz-2.16.1/plugin/pango/gvtextlayout_pango.c
--- graphviz-2.16.1.orig/plugin/pango/gvtextlayout_pango.c 2007-11-09 17:31:43.000000000 -0600
+++ graphviz-2.16.1/plugin/pango/gvtextlayout_pango.c 2008-03-03 09:55:01.000000000 -0600
@@ -154,8 +154,8 @@
logical_rect.height = 0;
textlayout_scale = POINTS_PER_INCH / (FONT_DPI * PANGO_SCALE);
- para->width = logical_rect.width * textlayout_scale;
- para->height = logical_rect.height * textlayout_scale;
+ para->width = ROUND(logical_rect.width * textlayout_scale);
+ para->height = ROUND(logical_rect.height * textlayout_scale);
/* The y offset from baseline to 0,0 of the bitmap representation */
iter = pango_layout_get_iter (layout);

View File

@ -1,30 +0,0 @@
diff -urN graphviz-2.12/configure graphviz-2.12-patched/configure
--- graphviz-2.12/configure 2006-12-04 16:02:10.000000000 -0600
+++ graphviz-2.12-patched/configure 2006-12-08 09:45:19.000000000 -0600
@@ -25552,7 +25552,7 @@
fi;
if test "x$enable_php" != "xno"; then
-if test `$SWIG -help 2>&1 | $GREP -c '\-php *- Generate'` = 0; then
+if test `$SWIG -help 2>&1 | $GREP -c '\-php[5 ]*- Generate'` = 0; then
PHP=
{ echo "$as_me:$LINENO: WARNING: swig does not support php. The PHP packages will not be built" >&5
echo "$as_me: WARNING: swig does not support php. The PHP packages will not be built" >&2;}
diff -urN graphviz-2.12/configure.ac graphviz-2.12-patched/configure.ac
--- graphviz-2.12/configure.ac 2006-12-04 15:11:58.000000000 -0600
+++ graphviz-2.12-patched/configure.ac 2006-12-08 08:07:10.000000000 -0600
@@ -1,4 +1,4 @@
-# $Id: graphviz-php5.patch,v 1.1 2006/12/11 18:42:36 jima Exp $ $Revision: 1.1 $
+# $Id: graphviz-php5.patch,v 1.1 2006/12/11 18:42:36 jima Exp $ $Revision: 1.1 $
# Process this file with autoconf to produce a configure script
AC_PREREQ(2.54)
@@ -628,7 +628,7 @@
AC_ARG_ENABLE(php,
[AC_HELP_STRING([--disable-php], [don't support php language bindings])])
if test "x$enable_php" != "xno"; then
-if test `$SWIG -help 2>&1 | $GREP -c '\-php *- Generate'` = 0; then
+if test `$SWIG -help 2>&1 | $GREP -c '\-php[[5 ]]*- Generate'` = 0; then
PHP=
AC_MSG_WARN([swig does not support php. The PHP packages will not be built])
else

View File

@ -1,181 +0,0 @@
diff -urN graphviz-2.16.orig/configure graphviz-2.16/configure
--- graphviz-2.16.orig/configure 2007-11-09 23:41:41.000000000 -0600
+++ graphviz-2.16/configure 2008-01-03 08:52:00.000000000 -0600
@@ -28003,8 +28003,8 @@
if test "x$TCLSH" = "x"; then
- # Extract the first word of "tclsh8.4", so it can be a program name with args.
-set dummy tclsh8.4; ac_word=$2
+ # Extract the first word of "tclsh8.5", so it can be a program name with args.
+set dummy tclsh8.5; ac_word=$2
{ echo "$as_me:$LINENO: checking for $ac_word" >&5
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
if test "${ac_cv_path_TCLSH+set}" = set; then
@@ -28044,8 +28044,8 @@
if test "x$TCLSH" = "x"; then
- # Extract the first word of "tclsh8.3", so it can be a program name with args.
-set dummy tclsh8.3; ac_word=$2
+ # Extract the first word of "tclsh8.4", so it can be a program name with args.
+set dummy tclsh8.4; ac_word=$2
{ echo "$as_me:$LINENO: checking for $ac_word" >&5
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
if test "${ac_cv_path_TCLSH+set}" = set; then
@@ -28085,7 +28085,48 @@
if test "x$TCLSH" = "x"; then
- # Extract the first word of "tclsh", so it can be a program name with args.
+ # Extract the first word of "tclsh8.3", so it can be a program name with args.
+set dummy tclsh8.3; ac_word=$2
+{ echo "$as_me:$LINENO: checking for $ac_word" >&5
+echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
+if test "${ac_cv_path_TCLSH+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+else
+ case $TCLSH in
+ [\\/]* | ?:[\\/]*)
+ ac_cv_path_TCLSH="$TCLSH" # Let the user override the test with a path.
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
+ ac_cv_path_TCLSH="$as_dir/$ac_word$ac_exec_ext"
+ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+done
+IFS=$as_save_IFS
+
+ ;;
+esac
+fi
+TCLSH=$ac_cv_path_TCLSH
+if test -n "$TCLSH"; then
+ { echo "$as_me:$LINENO: result: $TCLSH" >&5
+echo "${ECHO_T}$TCLSH" >&6; }
+else
+ { echo "$as_me:$LINENO: result: no" >&5
+echo "${ECHO_T}no" >&6; }
+fi
+
+
+ if test "x$TCLSH" = "x"; then
+ # Extract the first word of "tclsh", so it can be a program name with args.
set dummy tclsh; ac_word=$2
{ echo "$as_me:$LINENO: checking for $ac_word" >&5
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
@@ -28125,6 +28166,7 @@
fi
+ fi
fi
fi
if test "x$TCLSH" = "x"; then
@@ -28413,8 +28455,8 @@
fi
if test "x$WISH" = "x"; then
- # Extract the first word of "wish8.4", so it can be a program name with args.
-set dummy wish8.4; ac_word=$2
+ # Extract the first word of "wish8.5", so it can be a program name with args.
+set dummy wish8.5; ac_word=$2
{ echo "$as_me:$LINENO: checking for $ac_word" >&5
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
if test "${ac_cv_path_WISH+set}" = set; then
@@ -28454,8 +28496,8 @@
if test "x$WISH" = "x"; then
- # Extract the first word of "wish8.3", so it can be a program name with args.
-set dummy wish8.3; ac_word=$2
+ # Extract the first word of "wish8.4", so it can be a program name with args.
+set dummy wish8.4; ac_word=$2
{ echo "$as_me:$LINENO: checking for $ac_word" >&5
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
if test "${ac_cv_path_WISH+set}" = set; then
@@ -28495,7 +28537,48 @@
if test "x$WISH" = "x"; then
- # Extract the first word of "wish", so it can be a program name with args.
+ # Extract the first word of "wish8.3", so it can be a program name with args.
+set dummy wish8.3; ac_word=$2
+{ echo "$as_me:$LINENO: checking for $ac_word" >&5
+echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
+if test "${ac_cv_path_WISH+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+else
+ case $WISH in
+ [\\/]* | ?:[\\/]*)
+ ac_cv_path_WISH="$WISH" # Let the user override the test with a path.
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+for as_dir in $PATH
+do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+ for ac_exec_ext in '' $ac_executable_extensions; do
+ if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
+ ac_cv_path_WISH="$as_dir/$ac_word$ac_exec_ext"
+ echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
+ break 2
+ fi
+done
+done
+IFS=$as_save_IFS
+
+ ;;
+esac
+fi
+WISH=$ac_cv_path_WISH
+if test -n "$WISH"; then
+ { echo "$as_me:$LINENO: result: $WISH" >&5
+echo "${ECHO_T}$WISH" >&6; }
+else
+ { echo "$as_me:$LINENO: result: no" >&5
+echo "${ECHO_T}no" >&6; }
+fi
+
+
+ if test "x$WISH" = "x"; then
+ # Extract the first word of "wish", so it can be a program name with args.
set dummy wish; ac_word=$2
{ echo "$as_me:$LINENO: checking for $ac_word" >&5
echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
@@ -28535,6 +28618,7 @@
fi
+ fi
fi
fi
fi
@@ -28557,7 +28641,7 @@
WISH_EXEC_PREFIX=`echo $WISH|sed -e 's%/bin/wish.*$%%'`
if test -f ${WISH_EXEC_PREFIX}/include/tk${TK_VERSION_FOUND}/tk.h; then
- TK_INCLUDES="-I${WISH_EXEC_PREFIX}/include/tk${TK_VERSION_FOUND} -I${WISH_EXEC_PREFIX}/include/tk${TK_VERSION_FOUND}/generic"
+ TK_INCLUDES="-I${WISH_EXEC_PREFIX}/include/tk${TK_VERSION_FOUND} -I${WISH_EXEC_PREFIX}/include/tk${TK_VERSION_FOUND}/generic -I${WISH_EXEC_PREFIX}/include/tk${TK_VERSION_FOUND}/unix"
else
if test "x${WISH_EXEC_PREFIX}" != "x/usr" -a -f ${WISH_EXEC_PREFIX}/include/tk.h; then
TK_INCLUDES=-I${WISH_EXEC_PREFIX}/include
@@ -34721,7 +34805,7 @@
# -----------------------------------
# tkInt.h
if test -f "$TK_SRC_DIR/generic/tkInt.h"; then
-TKINT_INCLUDES="-I$TK_SRC_DIR/generic"
+TKINT_INCLUDES="-I$TK_SRC_DIR/generic -I$TK_SRC_DIR/unix"
else
if test -f "/usr/include/tkInt.h"; then
TKINT_INCLUDES=""

View File

@ -3,13 +3,22 @@
Name: graphviz
Summary: Graph Visualization Tools
Version: 2.26.0
Release: 4%{?dist}
Version: 2.26.3
Release: 1%{?dist}
Group: Applications/Multimedia
License: CPL
URL: http://www.graphviz.org/
Source0: http://www.graphviz.org/pub/graphviz/ARCHIVE/%{name}-%{version}.tar.gz
# Fix for sparc64.
Patch0: graphviz-sparc64.patch
# Fix gtk plugin program-name (#640671).
Patch1: graphviz-2.26.0-gtk-progname.patch
# Fix broken links in doc index (#642536).
Patch2: graphviz-2.26.0-doc-index-fix.patch
# Fix SIGSEGVs on testsuite (#645703).
Patch3: graphviz-2.26.0-testsuite-sigsegv-fix.patch
# Testsuite now do diff check also in case of err output (#645703).
Patch4: graphviz-2.26.0-rtest-errout-fix.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: zlib-devel, libpng-devel, libjpeg-devel, expat-devel, freetype-devel >= 2
BuildRequires: /bin/ksh, bison, m4, flex, tk-devel, tcl-devel >= 8.3, swig
@ -20,7 +29,7 @@ BuildRequires: gd-devel, perl-devel, DevIL-devel, R-devel, swig >= 1.3.33
%ifnarch ppc64 s390 s390x sparc64 %{arm}
BuildRequires: mono-core, ocaml
%endif
Requires: urw-fonts
BuildRequires: urw-fonts
Requires(post): /sbin/ldconfig
Requires(postun): /sbin/ldconfig
@ -50,9 +59,9 @@ and edges, not as in barcharts). This package contains development files for
graphviz.
%package devil
Group: Applications/Multimedia
Summary: Graphviz plugin for renderers based on DevIL
Requires: %{name} = %{version}-%{release}
Group: Applications/Multimedia
Summary: Graphviz plugin for renderers based on DevIL
Requires: %{name} = %{version}-%{release}
%description devil
Graphviz plugin for renderers based on DevIL. (Unless you absolutely have
@ -196,7 +205,11 @@ Various tcl packages (extensions) for the graphviz tools.
%prep
%setup -q
%patch0 -p1
%patch0 -p1 -b .sparc64
%patch1 -p1 -b .gtk-progname
%patch2 -p1 -b .doc-index-fix
%patch3 -p1 -b .testsuite-sigsegv-fix
%patch4 -p1 -b .rtest-errout-fix
%build
# %%define NO_IO --disable-io
@ -217,14 +230,14 @@ sed -i 's|_MY_JAVA_INCLUDES_|-I%{java_home}/include/ -I%{java_home}/include/linu
--without-ming \
%endif
make %{?_smp_mflags}
make %{?_smp_mflags} CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
%install
rm -rf %{buildroot} __doc
make DESTDIR=%{buildroot} \
docdir=%{buildroot}%{_docdir}/%{name} \
pkgconfigdir=%{_libdir}/pkgconfig \
install
docdir=%{buildroot}%{_docdir}/%{name} \
pkgconfigdir=%{_libdir}/pkgconfig \
install
find %{buildroot} -type f -name "*.la" -exec rm -f {} ';'
chmod -x %{buildroot}%{_datadir}/%{name}/lefty/*
cp -a %{buildroot}%{_datadir}/%{name}/doc __doc
@ -238,11 +251,8 @@ extension=gv.so
__EOF__
%check
%ifnarch ppc64 ppc sparc64
# regression test, segfaults on ppc/ppc64/sparc64, possible endian issues?
cd rtest
make rtest
%endif
%clean
rm -rf %{buildroot}
@ -254,11 +264,11 @@ rm -rf %{buildroot}
# if there is no dot after everything else is done, then remove config
%postun
if [ $1 -eq 0 ]; then
rm -f %{_libdir}/graphviz/config || :
rm -f %{_libdir}/graphviz/config || :
fi
/sbin/ldconfig
# run "dot -c" to generate plugin config in %{_libdir}/graphviz/config
# run "dot -c" to generate plugin config in %%{_libdir}/graphviz/config
%post devil
%{_bindir}/dot -c
@ -274,7 +284,7 @@ fi
[ -x %{_bindir}/dot ] && %{_bindir}/dot -c || :
%if %{MING}
# run "dot -c" to generate plugin config in %{_libdir}/graphviz/config
# run "dot -c" to generate plugin config in %%{_libdir}/graphviz/config
%post ming
%{_bindir}/dot -c
@ -406,6 +416,19 @@ fi
%changelog
* Thu Jan 06 2011 Jaroslav Škarvada <jskarvad@redhat.com> - 2.26.3-1
- New version (#580017)
- Fixed gtk plugin program-name (#640671, gtk-progname patch)
- Fixed broken links in doc index (#642536, doc-index-fix patch)
- Fixed SIGSEGVs on testsuite (#645703, testsuite-sigsegv-fix patch)
- Testsuite now do diff check also in case of err output (#645703,
rtest-errout-fix patch)
- Testsuite enabled on all arches (#645703)
- Added urw-fonts to BuildRequires
- Compiled with -fno-strict-aliasing
- Fixed rpmlint warnings on spec file
- Removed unused patches
* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.26.0-4
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild

View File

@ -1 +1 @@
0609b42cb9ef913b7af13e43c4d716c9 graphviz-2.26.0.tar.gz
6f45946fa622770c45609778c0a982ee graphviz-2.26.3.tar.gz