New version

Resolves: rhbz#895027
- Dropped guile-detect, ocaml4 patches (not needed)
- Fixed bogus date in changelog (guessing)
This commit is contained in:
Jaroslav Škarvada 2013-01-14 13:29:06 +01:00
parent 3bacd1291a
commit 35ee1e135e
3 changed files with 10 additions and 62 deletions

View File

@ -1,31 +0,0 @@
diff -up ./graphviz-2.28.0/configure.xorig ./graphviz-2.28.0/configure
--- graphviz-2.28.0/configure.xorig 2011-05-07 05:27:36.000000000 +0200
+++ graphviz-2.28.0/configure 2011-05-19 13:45:26.026395747 +0200
@@ -20066,7 +20066,7 @@ fi
if test "x$GUILE" = "x"; then
use_guile="No (guile not available)"
else
- GUILE_VERSION=`$GUILE --version | head -1 | cut -d ' ' -f 2`
+ GUILE_VERSION=`$GUILE --version | sed -n '1 s/^.* \+\([0-9\.]\+\)$/\1/ p'`
GUILE_VERSION_MAJOR=`echo $GUILE_VERSION | cut -d '.' -f 1`
GUILE_VERSION_MINOR=`echo $GUILE_VERSION | cut -d '.' -f 2`
if test $GUILE_VERSION_MAJOR -lt 2; then
@@ -20081,9 +20081,16 @@ fi
if test "x$GUILE" = "x"; then
use_guile="No (guile is too old)"
else
- GUILE_INCLUDES=
- GUILE_LIBS=
+ GUILE_INCLUDES=`$PKG_CONFIG --cflags "guile-$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR" 2>/dev/null`
+ GUILE_LIBS=`$PKG_CONFIG --libs "guile-$GUILE_VERSION_MAJOR.$GUILE_VERSION_MINOR" 2>/dev/null`
+
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_CPPFLAGS="$CPPFLAGS"
+ CFLAGS="$CFLAGS $GUILE_INCLUDES"
+ CPPFLAGS="$CPPFLAGS $GUILE_INCLUDES"
ac_fn_c_check_header_mongrel "$LINENO" "libguile.h" "ac_cv_header_libguile_h" "$ac_includes_default"
+ CFLAGS="$ac_save_CFLAGS"
+ CPPFLAGS="$ac_save_CPPFLAGS"
if test "x$ac_cv_header_libguile_h" = x""yes; then :
else

View File

@ -1,22 +0,0 @@
--- graphviz-2.28.0.old/tclpkg/gv/Makefile.am 2011-03-28 19:15:56.000000000 +0100
+++ graphviz-2.28.0/tclpkg/gv/Makefile.am 2012-06-09 16:37:52.421455627 +0100
@@ -111,6 +111,8 @@
gv.ml gv.mli: gv_ocaml.cpp
gv_ocaml.cpp: gv.i
$(SWIG) -c++ -ocaml -o gv_ocaml.cpp $(srcdir)/gv.i
+ sed '/caml_array_length/d' < gv_ocaml.cpp > gv_ocaml.cpp.
+ mv gv_ocaml.cpp. gv_ocaml.cpp
swig.mli:
$(SWIG) -ocaml -co swig.mli
swig.ml:
--- graphviz-2.28.0.old/tclpkg/gv/Makefile.in 2011-05-07 04:27:54.000000000 +0100
+++ graphviz-2.28.0/tclpkg/gv/Makefile.in 2012-06-09 16:40:11.215092361 +0100
@@ -3362,6 +3362,8 @@
gv.ml gv.mli: gv_ocaml.cpp
gv_ocaml.cpp: gv.i
$(SWIG) -c++ -ocaml -o gv_ocaml.cpp $(srcdir)/gv.i
+ sed '/caml_array_length/d' < gv_ocaml.cpp > gv_ocaml.cpp.
+ mv gv_ocaml.cpp. gv_ocaml.cpp
swig.mli:
$(SWIG) -ocaml -co swig.mli
swig.ml:

View File

@ -47,20 +47,16 @@
Name: graphviz
Summary: Graph Visualization Tools
Version: 2.28.0
Release: 26%{?dist}
Version: 2.30.0
Release: 1%{?dist}
Group: Applications/Multimedia
License: EPL
URL: http://www.graphviz.org/
Source0: http://www.graphviz.org/pub/graphviz/ARCHIVE/%{name}-%{version}.tar.gz
# Fix detection of guile 2.x (#704529)
Patch2: graphviz-2.28.0-guile-detect.patch
# Fix SIGSEGVs on testsuite (#645703).
Patch3: graphviz-2.26.0-testsuite-sigsegv-fix.patch
# Testsuite now do diff check also in case of err output (#645703).
Patch4: graphviz-2.26.0-rtest-errout-fix.patch
# Actually SWIG is broken, but patch the output to work around it.
Patch5: graphviz-ocaml-4.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: zlib-devel, libpng-devel, libjpeg-devel, expat-devel, freetype-devel >= 2
BuildRequires: /bin/ksh, bison, m4, flex, tk-devel, tcl-devel >= 8.3, swig
@ -256,10 +252,8 @@ Various tcl packages (extensions) for the graphviz tools.
%prep
%setup -q
%patch2 -p1 -b .guile-detect
%patch3 -p1 -b .testsuite-sigsegv-fix
%patch4 -p1 -b .rtest-errout-fix
%patch5 -p1 -b .ocaml4
# Attempt to fix rpmlint warnings about executable sources
find -type f -regex '.*\.\(c\|h\)$' -exec chmod a-x {} ';'
@ -409,6 +403,7 @@ fi
%exclude %{_docdir}/%{name}-%{version}/pdf
%exclude %{_docdir}/%{name}-%{version}/demo
%{_datadir}/graphviz/lefty
%{_datadir}/graphviz/gvpr
%if %{QTAPPS}
%{_datadir}/graphviz/gvedit
@ -534,6 +529,12 @@ fi
%changelog
* Mon Jan 14 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.30.0-1
- New version
Resolves: rhbz#895027
- Dropped guile-detect, ocaml4 patches (not needed)
- Fixed bogus date in changelog (guessing)
* Wed Jan 9 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 2.28.0-26
- Rebuilt with -fno-strict-overflow to workaround the overflow problem
(upstream ticket: http://www.graphviz.org/mantisbt/view.php?id=2244)
@ -750,7 +751,7 @@ fi
* Wed Aug 15 2007 John Ellson <ellson@research.att.com>
- release 2.14.1 - see ChangeLog for details
* Wed Aug 2 2007 John Ellson <ellson@research.att.com>
* Thu Aug 2 2007 John Ellson <ellson@research.att.com>
- release 2.14 - see ChangeLog for details
* Fri Mar 16 2007 Stephen North <north@research.att.com>
- remove xorg-X11-devel from rhel >= 5