Update to go1.19rc2
- Remove tzdata patch - Remove go-srpm-macros dependency - Resolves: rhbz#2095927
This commit is contained in:
parent
d908c3bbe4
commit
f7794baf11
3
.gitignore
vendored
3
.gitignore
vendored
@ -116,3 +116,6 @@
|
|||||||
/go1.18.2.src.tar.gz
|
/go1.18.2.src.tar.gz
|
||||||
/go1.18.3.src.tar.gz
|
/go1.18.3.src.tar.gz
|
||||||
/go1.18.4.src.tar.gz
|
/go1.18.4.src.tar.gz
|
||||||
|
/go1.19beta1.src.tar.gz
|
||||||
|
/go1.19rc1.src.tar.gz
|
||||||
|
/go1.19rc2.src.tar.gz
|
||||||
|
@ -1,88 +0,0 @@
|
|||||||
From f3d446b60a082308ec5aaa2fdc36e31f566081bb Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Jakub=20=C4=8Cajka?= <jcajka@redhat.com>
|
|
||||||
Date: Thu, 22 Mar 2018 11:49:09 +0100
|
|
||||||
Subject: [PATCH 1/3] Don't use the bundled tzdata at runtime, except for the
|
|
||||||
internal test suite
|
|
||||||
|
|
||||||
---
|
|
||||||
src/time/internal_test.go | 7 +++++--
|
|
||||||
src/time/zoneinfo_test.go | 3 ++-
|
|
||||||
src/time/zoneinfo_unix.go | 2 --
|
|
||||||
3 files changed, 7 insertions(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/time/internal_test.go b/src/time/internal_test.go
|
|
||||||
index 35ce69b228..1cea04ed7e 100644
|
|
||||||
--- a/src/time/internal_test.go
|
|
||||||
+++ b/src/time/internal_test.go
|
|
||||||
@@ -4,13 +4,15 @@
|
|
||||||
|
|
||||||
package time
|
|
||||||
|
|
||||||
+import "runtime"
|
|
||||||
+
|
|
||||||
func init() {
|
|
||||||
// force US/Pacific for time zone tests
|
|
||||||
ForceUSPacificForTesting()
|
|
||||||
}
|
|
||||||
|
|
||||||
func initTestingZone() {
|
|
||||||
- z, err := loadLocation("America/Los_Angeles", zoneSources[len(zoneSources)-1:])
|
|
||||||
+ z, err := loadLocation("America/Los_Angeles", zoneSources)
|
|
||||||
if err != nil {
|
|
||||||
panic("cannot load America/Los_Angeles for testing: " + err.Error() + "; you may want to use -tags=timetzdata")
|
|
||||||
}
|
|
||||||
@@ -21,8 +23,9 @@ func initTestingZone() {
|
|
||||||
var OrigZoneSources = zoneSources
|
|
||||||
|
|
||||||
func forceZipFileForTesting(zipOnly bool) {
|
|
||||||
- zoneSources = make([]string, len(OrigZoneSources))
|
|
||||||
+ zoneSources = make([]string, len(OrigZoneSources)+1)
|
|
||||||
copy(zoneSources, OrigZoneSources)
|
|
||||||
+ zoneSources = append(zoneSources, runtime.GOROOT()+"/lib/time/zoneinfo.zip")
|
|
||||||
if zipOnly {
|
|
||||||
zoneSources = zoneSources[len(zoneSources)-1:]
|
|
||||||
}
|
|
||||||
diff --git a/src/time/zoneinfo_test.go b/src/time/zoneinfo_test.go
|
|
||||||
index 277b68f798..be2aa6c687 100644
|
|
||||||
--- a/src/time/zoneinfo_test.go
|
|
||||||
+++ b/src/time/zoneinfo_test.go
|
|
||||||
@@ -9,6 +9,7 @@ import (
|
|
||||||
"fmt"
|
|
||||||
"os"
|
|
||||||
"reflect"
|
|
||||||
+ "runtime"
|
|
||||||
"testing"
|
|
||||||
"time"
|
|
||||||
)
|
|
||||||
@@ -139,7 +140,7 @@ func TestLoadLocationFromTZData(t *testing.T) {
|
|
||||||
t.Fatal(err)
|
|
||||||
}
|
|
||||||
|
|
||||||
- tzinfo, err := time.LoadTzinfo(locationName, time.OrigZoneSources[len(time.OrigZoneSources)-1])
|
|
||||||
+ tzinfo, err := time.LoadTzinfo(locationName, runtime.GOROOT()+"/lib/time/zoneinfo.zip")
|
|
||||||
if err != nil {
|
|
||||||
t.Fatal(err)
|
|
||||||
}
|
|
||||||
diff --git a/src/time/zoneinfo_unix.go b/src/time/zoneinfo_unix.go
|
|
||||||
index d2465eef65..b8c934c9a9 100644
|
|
||||||
--- a/src/time/zoneinfo_unix.go
|
|
||||||
+++ b/src/time/zoneinfo_unix.go
|
|
||||||
@@ -12,7 +12,6 @@
|
|
||||||
package time
|
|
||||||
|
|
||||||
import (
|
|
||||||
- "runtime"
|
|
||||||
"syscall"
|
|
||||||
)
|
|
||||||
|
|
||||||
@@ -22,7 +21,6 @@ var zoneSources = []string{
|
|
||||||
"/usr/share/zoneinfo/",
|
|
||||||
"/usr/share/lib/zoneinfo/",
|
|
||||||
"/usr/lib/locale/TZ/",
|
|
||||||
- runtime.GOROOT() + "/lib/time/zoneinfo.zip",
|
|
||||||
}
|
|
||||||
|
|
||||||
func initLocal() {
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
37
golang.spec
37
golang.spec
@ -106,9 +106,9 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Comment out go_prerelease and go_patch as needed
|
# Comment out go_prerelease and go_patch as needed
|
||||||
%global go_api 1.18
|
%global go_api 1.19
|
||||||
#global go_prerelease rc1
|
%global go_prerelease rc2
|
||||||
%global go_patch 4
|
#global go_patch 1
|
||||||
|
|
||||||
%global go_version %{go_api}%{?go_patch:.%{go_patch}}%{?go_prerelease:~%{go_prerelease}}
|
%global go_version %{go_api}%{?go_patch:.%{go_patch}}%{?go_prerelease:~%{go_prerelease}}
|
||||||
%global go_source %{go_api}%{?go_patch:.%{go_patch}}%{?go_prerelease}
|
%global go_source %{go_api}%{?go_patch:.%{go_patch}}%{?go_prerelease}
|
||||||
@ -145,24 +145,21 @@ Provides: go = %{version}-%{release}
|
|||||||
|
|
||||||
# Bundled/Vendored provides generated by bundled-deps.sh based on the in tree module data
|
# Bundled/Vendored provides generated by bundled-deps.sh based on the in tree module data
|
||||||
# - in version filed substituted with . per versioning guidelines
|
# - in version filed substituted with . per versioning guidelines
|
||||||
Provides: bundled(golang(github.com/google/pprof)) = 0.0.0.20211104044539.f987b9c94b31
|
Provides: bundled(golang(github.com/google/pprof)) = 0.0.0.20220517023622.154dc81eb7b0
|
||||||
Provides: bundled(golang(github.com/ianlancetaylor/demangle)) = 0.0.0.20210905161508.09a460cdf81d
|
Provides: bundled(golang(github.com/ianlancetaylor/demangle)) = 0.0.0.20220319035150.800ac71e25c2
|
||||||
Provides: bundled(golang(golang.org/x/arch)) = 0.0.0.20210923205945.b76863e36670
|
Provides: bundled(golang(golang.org/x/arch)) = 0.0.0.20220412001346.fc48f9fe4c15
|
||||||
Provides: bundled(golang(golang.org/x/crypto)) = 0.0.0.20211215153901.e495a2d5b3d3
|
Provides: bundled(golang(golang.org/x/crypto)) = 0.0.0.20220516162934.403b01795ae8
|
||||||
Provides: bundled(golang(golang.org/x/mod)) = 0.6.0.dev.0.20211102181907.3a5865c02020
|
Provides: bundled(golang(golang.org/x/mod)) = 0.6.0.dev.0.20220419223038.86c51ed26bb4
|
||||||
Provides: bundled(golang(golang.org/x/net)) = 0.0.0.20211209124913.491a49abca63
|
Provides: bundled(golang(golang.org/x/net)) = 0.0.0.20220517181318.183a9ca12b87
|
||||||
Provides: bundled(golang(golang.org/x/sync)) = 0.0.0.20210220032951.036812b2e83c
|
Provides: bundled(golang(golang.org/x/sync)) = 0.0.0.20220513210516.0976fa681c29
|
||||||
Provides: bundled(golang(golang.org/x/sys)) = 0.0.0.20211205182925.97ca703d548d
|
Provides: bundled(golang(golang.org/x/sys)) = 0.0.0.20220614162138.6c1b26c55098
|
||||||
Provides: bundled(golang(golang.org/x/term)) = 0.0.0.20210927222741.03fcf44c2211
|
Provides: bundled(golang(golang.org/x/term)) = 0.0.0.20220411215600.e5f449aeb171
|
||||||
Provides: bundled(golang(golang.org/x/text)) = 0.3.8.0.20211105212822.18b340fc7af2
|
Provides: bundled(golang(golang.org/x/text)) = 0.3.8.0.20220509174342.b4bca84b0361
|
||||||
Provides: bundled(golang(golang.org/x/tools)) = 0.1.9.0.20220329150752.294080fd2f5a
|
Provides: bundled(golang(golang.org/x/tools)) = 0.1.11.0.20220516163903.1e55371df567
|
||||||
Provides: bundled(golang(golang.org/x/xerrors)) = 0.0.0.20200804184101.5ec99f83aff1
|
|
||||||
|
|
||||||
Requires: %{name}-bin = %{version}-%{release}
|
Requires: %{name}-bin = %{version}-%{release}
|
||||||
Requires: %{name}-src = %{version}-%{release}
|
Requires: %{name}-src = %{version}-%{release}
|
||||||
Requires: go-srpm-macros
|
|
||||||
|
|
||||||
Patch1: 0001-Don-t-use-the-bundled-tzdata-at-runtime-except-for-t.patch
|
|
||||||
Patch2: 0002-syscall-expose-IfInfomsg.X__ifi_pad-on-s390x.patch
|
Patch2: 0002-syscall-expose-IfInfomsg.X__ifi_pad-on-s390x.patch
|
||||||
Patch3: 0003-cmd-go-disable-Google-s-proxy-and-sumdb.patch
|
Patch3: 0003-cmd-go-disable-Google-s-proxy-and-sumdb.patch
|
||||||
|
|
||||||
@ -541,6 +538,12 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 18 2022 Mike Rochefort <mroche@redhat.com> - 1.19~rc2-1
|
||||||
|
- Update to go1.19rc2
|
||||||
|
- Remove tzdata patch
|
||||||
|
- Remove go-srpm-macros runtime requirement
|
||||||
|
- Resolves: rhbz#2095927
|
||||||
|
|
||||||
* Wed Jul 13 2022 Alejandro Sáez <asm@redhat.com> - 1.18.4-1
|
* Wed Jul 13 2022 Alejandro Sáez <asm@redhat.com> - 1.18.4-1
|
||||||
- Update to 1.18.4
|
- Update to 1.18.4
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (go1.18.4.src.tar.gz) = 4872956e31fa5d681021db12e876bc60a1815cf45203e75db83d6c54e9b7138766ae44bf1659db5333eba0b6097aea1990519795fffd2f124e7a78b78df1339b
|
SHA512 (go1.19rc2.src.tar.gz) = b4407bb4cb1abdff7d619876282beeab7a94ae7d0b050de78168083029933cac04a49107e2f7cd43adf2c25946959fa5545ea29c6238fbed39c980117fdcb2dc
|
||||||
|
Loading…
Reference in New Issue
Block a user