bump to go1.7.5
Resolves: BZ#1417002
This commit is contained in:
parent
0dbd49fdd7
commit
ae693342f0
1
.gitignore
vendored
1
.gitignore
vendored
@ -37,3 +37,4 @@
|
||||
/go1.7.1.src.tar.gz
|
||||
/go1.7.3.src.tar.gz
|
||||
/go1.7.4.src.tar.gz
|
||||
/go1.7.5.src.tar.gz
|
||||
|
15
golang.spec
15
golang.spec
@ -87,11 +87,11 @@
|
||||
%endif
|
||||
|
||||
%global go_api 1.7
|
||||
%global go_version 1.7.4
|
||||
%global go_version 1.7.5
|
||||
|
||||
Name: golang
|
||||
Version: 1.7.4
|
||||
Release: 2%{?dist}
|
||||
Version: 1.7.5
|
||||
Release: 1%{?dist}
|
||||
Summary: The Go Programming Language
|
||||
# source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
|
||||
License: BSD and Public Domain
|
||||
@ -134,9 +134,6 @@ Patch215: ./go1.5-zoneinfo_testing_only.patch
|
||||
Patch216: ppc64x-overflow-1.patch
|
||||
Patch217: ppc64x-overflow-2.patch
|
||||
|
||||
# Fix for https://github.com/golang/go/issues/17276
|
||||
Patch218: tzdata-fix.patch
|
||||
|
||||
# Proposed patch by mmunday https://golang.org/cl/35262
|
||||
Patch219: s390x-expose-IfInfomsg-X__ifi_pad.patch
|
||||
|
||||
@ -265,8 +262,6 @@ Summary: Golang shared object libraries
|
||||
%patch216 -p1
|
||||
%patch217 -p1
|
||||
|
||||
%patch218 -p1
|
||||
|
||||
%patch219 -p1
|
||||
|
||||
%build
|
||||
@ -485,6 +480,10 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Jan 27 2017 Jakub Čajka <jcajka@redhat.com> - 1.7.5-1
|
||||
- bump to go1.7.5
|
||||
- Resolves: BZ#1417002
|
||||
|
||||
* Fri Jan 20 2017 Jakub Čajka <jcajka@redhat.com> - 1.7.4-2
|
||||
- Resolves: BZ#1404679
|
||||
- expose IfInfomsg.X__ifi_pad on s390x
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
49c1076428a5d3b5ad7ac65233fcca2f go1.7.4.src.tar.gz
|
||||
SHA512 (go1.7.5.src.tar.gz) = 2dda0780a8b24d71fec4ddeb6858c58a42845f51d9afc171d924a7b763101878cc7f29ae1dd35f129b4ee45b84d45211093a1d20639745fed36b49fb7fe1ba07
|
||||
|
@ -1,34 +0,0 @@
|
||||
From c5434f2973a87acff76bac359236e690d632ce95 Mon Sep 17 00:00:00 2001
|
||||
From: Alberto Donizetti <alb.donizetti@gmail.com>
|
||||
Date: Thu, 29 Sep 2016 13:59:10 +0200
|
||||
Subject: [PATCH] time: update test for tzdata-2016g
|
||||
|
||||
Fixes #17276
|
||||
|
||||
Change-Id: I0188cf9bc5fdb48c71ad929cc54206d03e0b96e4
|
||||
Reviewed-on: https://go-review.googlesource.com/29995
|
||||
Reviewed-by: Brad Fitzpatrick <bradfitz@golang.org>
|
||||
Run-TryBot: Brad Fitzpatrick <bradfitz@golang.org>
|
||||
TryBot-Result: Gobot Gobot <gobot@golang.org>
|
||||
---
|
||||
src/time/time_test.go | 7 +++++--
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/time/time_test.go b/src/time/time_test.go
|
||||
index 68236fd..2e47d08 100644
|
||||
--- a/src/time/time_test.go
|
||||
+++ b/src/time/time_test.go
|
||||
@@ -943,8 +943,11 @@ func TestLoadFixed(t *testing.T) {
|
||||
// but Go and most other systems use "east is positive".
|
||||
// So GMT+1 corresponds to -3600 in the Go zone, not +3600.
|
||||
name, offset := Now().In(loc).Zone()
|
||||
- if name != "GMT+1" || offset != -1*60*60 {
|
||||
- t.Errorf("Now().In(loc).Zone() = %q, %d, want %q, %d", name, offset, "GMT+1", -1*60*60)
|
||||
+ // The zone abbreviation is "-01" since tzdata-2016g, and "GMT+1"
|
||||
+ // on earlier versions; we accept both. (Issue #17276).
|
||||
+ if !(name == "GMT+1" || name == "-01") || offset != -1*60*60 {
|
||||
+ t.Errorf("Now().In(loc).Zone() = %q, %d, want %q or %q, %d",
|
||||
+ name, offset, "GMT+1", "-01", -1*60*60)
|
||||
}
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user