Rebase to go1.15rc1
Related: BZ#1859241
This commit is contained in:
parent
a3e201c572
commit
132cf34fe6
1
.gitignore
vendored
1
.gitignore
vendored
@ -87,3 +87,4 @@
|
||||
/go1.14.4.src.tar.gz
|
||||
/go1.14.6.src.tar.gz
|
||||
/go1.15beta1.src.tar.gz
|
||||
/go1.15rc1.src.tar.gz
|
||||
|
15
golang.spec
15
golang.spec
@ -105,11 +105,11 @@
|
||||
%endif
|
||||
|
||||
%global go_api 1.15
|
||||
%global go_version 1.15beta1
|
||||
%global go_version 1.15rc1
|
||||
|
||||
Name: golang
|
||||
Version: 1.15
|
||||
Release: 0.beta1.0%{?dist}
|
||||
Release: 0.rc1.0%{?dist}
|
||||
Summary: The Go Programming Language
|
||||
# source tree includes several copies of Mark.Twain-Tom.Sawyer.txt under Public Domain
|
||||
License: BSD and Public Domain
|
||||
@ -220,7 +220,6 @@ Requires: go-srpm-macros
|
||||
Patch1: 0001-Don-t-use-the-bundled-tzdata-at-runtime-except-for-t.patch
|
||||
Patch2: 0002-syscall-expose-IfInfomsg.X__ifi_pad-on-s390x.patch
|
||||
Patch3: 0003-cmd-go-disable-Google-s-proxy-and-sumdb.patch
|
||||
Patch4: shared-fix.patch
|
||||
|
||||
# Having documentation separate was broken
|
||||
Obsoletes: %{name}-docs < 1.1-4
|
||||
@ -515,9 +514,9 @@ export CGO_ENABLED=0
|
||||
# workaround for https://github.com/golang/go/issues/39466 until it gests fixed
|
||||
# Commented until the patch is ready, this work around suggested in the link avobe
|
||||
# doesn't work properly
|
||||
#%ifarch aarch64
|
||||
#ifarch aarch64
|
||||
#export CGO_CFLAGS="-mno-outline-atomics"
|
||||
#%endif
|
||||
#endif
|
||||
|
||||
# make sure to not timeout
|
||||
export GO_TEST_TIMEOUT_SCALE=2
|
||||
@ -592,8 +591,12 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jul 27 2020 Jakub Čajka <jcajka@redhat.com> - 1.15-0.rc1.0
|
||||
- Rebase to go1.15rc1
|
||||
- Related: BZ#1859241
|
||||
|
||||
* Mon Jul 20 2020 Jakub Čajka <jcajka@redhat.com> - 1.15-0.beta1.0
|
||||
* Rebase to go1.15beta1
|
||||
- Rebase to go1.15beta1
|
||||
|
||||
* Mon Jul 20 2020 Jakub Čajka <jcajka@redhat.com> - 1.14.6-1
|
||||
- Rebase to go1.14.6
|
||||
|
@ -1,89 +0,0 @@
|
||||
From 9f33108dfa22946622a8a78b5cd3f64cd3e455dd Mon Sep 17 00:00:00 2001
|
||||
From: Cherry Zhang <cherryyz@google.com>
|
||||
Date: Tue, 23 Jun 2020 12:02:54 -0400
|
||||
Subject: [PATCH] cmd/link: skip zero values in fingerprint check
|
||||
|
||||
Normally, packages are loaded in dependency order, and if a
|
||||
Library object is not nil, it is already loaded with the actual
|
||||
fingerprint. In shared build mode, however, packages may be added
|
||||
not in dependency order (e.g. go install -buildmode=shared std
|
||||
adds all std packages before loading them), and it is possible
|
||||
that a Library's fingerprint is not yet loaded. Skip the check
|
||||
in this case (when the fingerprint is the zero value).
|
||||
|
||||
Fixes #39777.
|
||||
|
||||
Change-Id: I66208e92bf687c8778963ba8e33e9bd948f82f3a
|
||||
Reviewed-on: https://go-review.googlesource.com/c/go/+/239517
|
||||
Run-TryBot: Cherry Zhang <cherryyz@google.com>
|
||||
TryBot-Result: Gobot Gobot <gobot@golang.org>
|
||||
Reviewed-by: Than McIntosh <thanm@google.com>
|
||||
---
|
||||
misc/cgo/testshared/shared_test.go | 6 ++++++
|
||||
misc/cgo/testshared/testdata/issue39777/a/a.go | 9 +++++++++
|
||||
misc/cgo/testshared/testdata/issue39777/b/b.go | 7 +++++++
|
||||
src/cmd/link/internal/ld/ld.go | 7 ++++++-
|
||||
4 files changed, 28 insertions(+), 1 deletion(-)
|
||||
create mode 100644 misc/cgo/testshared/testdata/issue39777/a/a.go
|
||||
create mode 100644 misc/cgo/testshared/testdata/issue39777/b/b.go
|
||||
|
||||
diff --git a/misc/cgo/testshared/shared_test.go b/misc/cgo/testshared/shared_test.go
|
||||
index acae1b2c212c..fda3d2ce76fc 100644
|
||||
--- a/misc/cgo/testshared/shared_test.go
|
||||
+++ b/misc/cgo/testshared/shared_test.go
|
||||
@@ -1028,3 +1028,9 @@ func TestGeneratedHash(t *testing.T) {
|
||||
goCmd(nil, "install", "-buildmode=shared", "-linkshared", "./issue30768/issue30768lib")
|
||||
goCmd(nil, "test", "-linkshared", "./issue30768")
|
||||
}
|
||||
+
|
||||
+// Test that packages can be added not in dependency order (here a depends on b, and a adds
|
||||
+// before b). This could happen with e.g. go build -buildmode=shared std. See issue 39777.
|
||||
+func TestPackageOrder(t *testing.T) {
|
||||
+ goCmd(t, "install", "-buildmode=shared", "-linkshared", "./issue39777/a", "./issue39777/b")
|
||||
+}
|
||||
diff --git a/misc/cgo/testshared/testdata/issue39777/a/a.go b/misc/cgo/testshared/testdata/issue39777/a/a.go
|
||||
new file mode 100644
|
||||
index 000000000000..c7bf8359514a
|
||||
--- /dev/null
|
||||
+++ b/misc/cgo/testshared/testdata/issue39777/a/a.go
|
||||
@@ -0,0 +1,9 @@
|
||||
+// Copyright 2020 The Go Authors. All rights reserved.
|
||||
+// Use of this source code is governed by a BSD-style
|
||||
+// license that can be found in the LICENSE file.
|
||||
+
|
||||
+package a
|
||||
+
|
||||
+import "testshared/issue39777/b"
|
||||
+
|
||||
+func F() { b.F() }
|
||||
diff --git a/misc/cgo/testshared/testdata/issue39777/b/b.go b/misc/cgo/testshared/testdata/issue39777/b/b.go
|
||||
new file mode 100644
|
||||
index 000000000000..4e681965e68b
|
||||
--- /dev/null
|
||||
+++ b/misc/cgo/testshared/testdata/issue39777/b/b.go
|
||||
@@ -0,0 +1,7 @@
|
||||
+// Copyright 2020 The Go Authors. All rights reserved.
|
||||
+// Use of this source code is governed by a BSD-style
|
||||
+// license that can be found in the LICENSE file.
|
||||
+
|
||||
+package b
|
||||
+
|
||||
+func F() {}
|
||||
diff --git a/src/cmd/link/internal/ld/ld.go b/src/cmd/link/internal/ld/ld.go
|
||||
index 71f388b5a066..e56a6690fbcc 100644
|
||||
--- a/src/cmd/link/internal/ld/ld.go
|
||||
+++ b/src/cmd/link/internal/ld/ld.go
|
||||
@@ -160,7 +160,12 @@ func addlib(ctxt *Link, src, obj, lib string, fingerprint goobj2.FingerprintType
|
||||
pkg := pkgname(ctxt, lib)
|
||||
|
||||
// already loaded?
|
||||
- if l := ctxt.LibraryByPkg[pkg]; l != nil {
|
||||
+ if l := ctxt.LibraryByPkg[pkg]; l != nil && !l.Fingerprint.IsZero() {
|
||||
+ // Normally, packages are loaded in dependency order, and if l != nil
|
||||
+ // l is already loaded with the actual fingerprint. In shared build mode,
|
||||
+ // however, packages may be added not in dependency order, and it is
|
||||
+ // possible that l's fingerprint is not yet loaded -- exclude it in
|
||||
+ // checking.
|
||||
checkFingerprint(l, l.Fingerprint, src, fingerprint)
|
||||
return l
|
||||
}
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (go1.15beta1.src.tar.gz) = 5b894b0d22a7ecb8d056c6a8936d708f189ff12e77dd8547fe5144e7b37888fb30b0bec87f22453db5c976305826f3a1c86c20c40a525b004f743aa896d62ea1
|
||||
SHA512 (go1.15rc1.src.tar.gz) = 7f77b189f9c1605ac6df68059029eac5bd90ea1a184473eaf861fa45429389e0d6fde530fcd3991d5e3e27ddcaf7af960a1349344ffbda633388efcfc597d2bc
|
||||
|
Loading…
Reference in New Issue
Block a user