golang-x-vuln/golang-x-vuln.spec

62 lines
1.2 KiB
RPMSpec

# Generated by go2rpm 1.6.0
%bcond_without check
# https://github.com/golang/vuln
%global goipath golang.org/x/vuln
%global forgeurl https://github.com/golang/vuln
%global commit 348460952d62720df9244d4e7b81008a9195e109
%gometa
%global common_description %{expand:
The database client and tools for the Go vulnerability database.}
%global golicenses LICENSE PATENTS
%global godocs doc CONTRIBUTING.md README.md
Name: %{goname}
Version: 0
Release: %autorelease -p
Summary: Database client and tools for the Go vulnerability database
# Upstream license specification: BSD-3-Clause
License: BSD-3-Clause
URL: %{gourl}
Source0: %{gosource}
%description
%{common_description}
%gopkg
%prep
%goprep
%generate_buildrequires
%go_generate_buildrequires
%build
for cmd in cmd/* ; do
%gobuild -o %{gobuilddir}/bin/$(basename $cmd) %{goipath}/$cmd
done
%install
%gopkginstall
install -m 0755 -vd %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/
%if %{with check}
%check
%gocheck -t cmd
%endif
%files
%license LICENSE PATENTS
%doc doc CONTRIBUTING.md README.md
%{_bindir}/govulncheck
%gopkgfiles
%changelog
%autochangelog