golang-x-text/golang-x-text.spec

72 lines
1.5 KiB
RPMSpec

# Generated by go2rpm 1.8.1
%bcond_without check
%bcond_with bootstrap
%if %{with bootstrap}
%global debug_package %{nil}
%endif
# https://github.com/golang/text
%global goipath golang.org/x/text
%global forgeurl https://github.com/golang/text
Version: 0.7.0
%gometa
%global common_description %{expand:
Text is a repository of text-related packages related to internationalization
(i18n) and localization (l10n), such as character encodings, text
transformations, and locale-specific text handling.}
%global golicenses LICENSE PATENTS
%global godocs CONTRIBUTING.md README.md
Name: %{goname}
Release: %autorelease
Summary: Go text processing support
License: BSD-3-Clause
URL: %{gourl}
Source: %{gosource}
%description %{common_description}
%gopkg
%prep
%goprep
%if %{without bootstrap}
%generate_buildrequires
%go_generate_buildrequires
%endif
%if %{without bootstrap}
%build
%gobuild -o %{gobuilddir}/bin/gotext %{goipath}/cmd/gotext
%endif
%install
%gopkginstall
%if %{without bootstrap}
install -m 0755 -vd %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/gotext %{buildroot}%{_bindir}/
%endif
%if %{with check}
%check
%gocheck -t cmd %{?with_bootstrap:-t message/pipeline}
%endif
%if %{without bootstrap}
%files
%license LICENSE PATENTS
%doc CONTRIBUTING.md README.md
%{_bindir}/gotext
%endif
%gopkgfiles
%changelog
%autochangelog