golang-modernc-sqlite/golang-modernc-sqlite.spec

58 lines
1.1 KiB
RPMSpec

# Generated by go2rpm 1.9.0
%bcond_without check
%global debug_package %{nil}
# https://gitlab.com/cznic/sqlite
%global goipath modernc.org/sqlite
%global forgeurl https://gitlab.com/cznic/sqlite
Version: 1.27.0
%global tag v%{version}
%gometa -f
%global common_description %{expand:
A port of SQLite/SQLite3 to Go without cgo.
SQLite is an in-process implementation of a self-contained, serverless, zero-
configuration, transactional SQL database engine.}
%global golicenses LICENSE SQLITE-LICENSE
%global godocs examples AUTHORS CONTRIBUTORS README.md
Name: %{goname}
Release: %autorelease
Summary: A port of SQLite/SQLite3 to Go without cgo
License: BSD-3-Clause
URL: %{gourl}
Source: %{gosource}
%description %{common_description}
%gopkg
%prep
%goprep
%autopatch -p1
%generate_buildrequires
%go_generate_buildrequires
%install
%gopkginstall
%if %{with check}
%check
# panic: test timed out after 10m0s
%gocheck -d .
%endif
%files
%license LICENSE SQLITE-LICENSE
%doc examples AUTHORS CONTRIBUTORS README.md
%gopkgfiles
%changelog
%autochangelog