fix interaction with Chrome 45+ (master secret extension) (#1273102)

This commit is contained in:
Adam Williamson 2015-10-20 12:06:03 -07:00
parent b18da6e965
commit cd47026216
2 changed files with 36 additions and 1 deletions

View File

@ -0,0 +1,27 @@
From 1b93f45fbd144cdf7095102bf6927c97019cf2e7 Mon Sep 17 00:00:00 2001
From: Nikos Mavrogiannopoulos <nmav@redhat.com>
Date: Tue, 20 Oct 2015 09:03:25 +0200
Subject: [PATCH] ext master secret: extension is marked as mandatory
This forces the extension to be sent even where resuming sessions.
Resolves #45
---
lib/ext/ext_master_secret.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lib/ext/ext_master_secret.c b/lib/ext/ext_master_secret.c
index 9610f12..0d90347 100644
--- a/lib/ext/ext_master_secret.c
+++ b/lib/ext/ext_master_secret.c
@@ -38,7 +38,7 @@ static int _gnutls_ext_master_secret_send_params(gnutls_session_t session,
extension_entry_st ext_mod_ext_master_secret = {
.name = "EXT MASTER SECRET",
.type = GNUTLS_EXTENSION_EXT_MASTER_SECRET,
- .parse_type = GNUTLS_EXT_TLS,
+ .parse_type = GNUTLS_EXT_MANDATORY,
.recv_func = _gnutls_ext_master_secret_recv_params,
.send_func = _gnutls_ext_master_secret_send_params,
--
2.5.0

View File

@ -3,7 +3,7 @@
Summary: A TLS protocol implementation
Name: gnutls
Version: 3.4.5
Release: 1%{?dist}
Release: 2%{?dist}
# The libraries are LGPLv2.1+, utilities are GPLv3+
License: GPLv3+ and LGPLv2+
Group: System Environment/Libraries
@ -37,6 +37,10 @@ Patch1: gnutls-3.2.7-rpath.patch
Patch3: gnutls-3.1.11-nosrp.patch
Patch4: gnutls-3.4.1-default-policy.patch
Patch5: gnutls-3.4.2-no-now-guile.patch
# RHBZ #1273102
# https://gitlab.com/gnutls/gnutls/issues/45
# https://gitlab.com/gnutls/gnutls/commit/1b93f45fbd144cdf7095102bf6927c97019cf2e7
Patch6: 0001-ext-master-secret-extension-is-marked-as-mandatory.patch
# Wildcard bundling exception https://fedorahosted.org/fpc/ticket/174
Provides: bundled(gnulib) = 20130424
@ -140,6 +144,7 @@ This package contains Guile bindings for the library.
%patch3 -p1 -b .nosrp
%patch4 -p1 -b .default-policy
%patch5 -p1 -b .guile
%patch6 -p1 -b .master-secret
sed 's/gnutls_srp.c//g' -i lib/Makefile.in
sed 's/gnutls_srp.lo//g' -i lib/Makefile.in
@ -277,6 +282,9 @@ fi
%endif
%changelog
* Tue Oct 20 2015 Adam Williamson <awilliam@redhat.com> - 3.4.5-2
- fix interaction with Chrome 45+ (master secret extension) (#1273102)
* Mon Sep 14 2015 Nikos Mavrogiannopoulos <nmav@redhat.com> 3.4.5-1
- New upstream release (#1252192)
- Eliminates hard limits on CRL parsing of certtool.