Examples need to link with libgcrypt too.

This commit is contained in:
Tomáš Mráz 2010-05-12 19:25:56 +00:00
parent 5cdd3d4a10
commit 29abd66f75
2 changed files with 26 additions and 0 deletions

View File

@ -0,0 +1,24 @@
diff -up gnutls-2.8.6/doc/examples/Makefile.am.link gnutls-2.8.6/doc/examples/Makefile.am
--- gnutls-2.8.6/doc/examples/Makefile.am.link 2010-01-24 11:06:21.000000000 +0100
+++ gnutls-2.8.6/doc/examples/Makefile.am 2010-05-12 21:22:51.000000000 +0200
@@ -30,7 +30,7 @@ LDADD = libexamples.la \
../../lib/libgnutls.la \
../../libextra/libgnutls-extra.la \
../../gl/libgnu.la \
- $(LIBSOCKET) $(INET_NTOP_LIB) $(INET_PTON_LIB)
+ $(LTLIBGCRYPT) $(LIBSOCKET) $(INET_NTOP_LIB) $(INET_PTON_LIB)
CXX_LDADD = $(LDADD) \
../../lib/libgnutlsxx.la
diff -up gnutls-2.8.6/doc/examples/Makefile.in.link gnutls-2.8.6/doc/examples/Makefile.in
--- gnutls-2.8.6/doc/examples/Makefile.in.link 2010-03-15 11:29:19.000000000 +0100
+++ gnutls-2.8.6/doc/examples/Makefile.in 2010-05-12 21:23:25.000000000 +0200
@@ -827,7 +827,7 @@ LDADD = libexamples.la \
../../lib/libgnutls.la \
../../libextra/libgnutls-extra.la \
../../gl/libgnu.la \
- $(LIBSOCKET) $(INET_NTOP_LIB) $(INET_PTON_LIB)
+ $(LTLIBGCRYPT) $(LIBSOCKET) $(INET_NTOP_LIB) $(INET_PTON_LIB)
CXX_LDADD = $(LDADD) \
../../lib/libgnutlsxx.la

View File

@ -16,6 +16,7 @@ URL: http://www.gnutls.org/
Source0: %{name}-%{version}-nosrp.tar.bz2
Source1: libgnutls-config
Patch1: gnutls-2.8.5-rpath.patch
Patch2: gnutls-2.8.6-link-libgcrypt.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: libgcrypt >= 1.2.2
@ -69,6 +70,7 @@ This package contains Guile bindings for the library.
%prep
%setup -q
%patch1 -p1 -b .rpath
%patch2 -p1 -b .link
for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
touch lib/$i