fixed sigsegv
This commit is contained in:
Peter Schiffer 2012-10-10 13:50:01 +02:00
parent 8c478a2af0
commit 2784edc475
2 changed files with 39 additions and 0 deletions

View File

@ -0,0 +1,33 @@
diff -upr gnuplot.orig/src/gplt_x11.c gnuplot/src/gplt_x11.c
--- gnuplot.orig/src/gplt_x11.c 2012-03-18 18:30:43.000000000 +0100
+++ gnuplot/src/gplt_x11.c 2012-08-17 15:11:31.888654269 +0200
@@ -2231,7 +2231,8 @@ exec_cmd(plot_struct *plot, char *comman
/* Load selected pattern or fill into a separate gc */
if (!fill_gc)
fill_gc = XCreateGC(dpy, plot->window, 0, 0);
- XCopyGC(dpy, *current_gc, ~0, fill_gc);
+ if (current_gc)
+ XCopyGC(dpy, *current_gc, ~0, fill_gc);
x11_setfill(&fill_gc, style);
/* gnuplot has origin at bottom left, but X uses top left
@@ -2560,7 +2561,8 @@ exec_cmd(plot_struct *plot, char *comman
/* Load selected pattern or fill into a separate gc */
if (!fill_gc)
fill_gc = XCreateGC(dpy, plot->window, 0, 0);
- XCopyGC(dpy, *current_gc, ~0, fill_gc);
+ if (current_gc)
+ XCopyGC(dpy, *current_gc, ~0, fill_gc);
x11_setfill(&fill_gc, style);
@@ -2668,7 +2670,8 @@ exec_cmd(plot_struct *plot, char *comman
/* Load selected pattern or fill into a separate gc */
if (!fill_gc)
fill_gc = XCreateGC(dpy, plot->window, 0, 0);
- XCopyGC(dpy, *current_gc, ~0, fill_gc);
+ if (current_gc)
+ XCopyGC(dpy, *current_gc, ~0, fill_gc);
x11_setfill(&fill_gc, style);

View File

@ -17,6 +17,9 @@ Source1: gnuplot-init.el
Patch0: gnuplot-4.2.0-refers_to.patch
Patch1: gnuplot-4.2.0-fonts.patch
# resolves: #759964
# submitted upstream: http://sourceforge.net/tracker/?func=detail&aid=3558970&group_id=2055&atid=302055
Patch2: gnuplot-4.6.1-xcopygc-sigsegv.patch
Requires: %{name}-common = %{version}-%{release}
Requires: dejavu-sans-fonts
@ -120,6 +123,7 @@ plotting tool.
%setup -q
%patch0 -p1 -b .refto
%patch1 -p1 -b .font
%patch2 -p1 -b .xcopygc
sed -i -e 's:"/usr/lib/X11/app-defaults":"%{x11_app_defaults_dir}":' src/gplt_x11.c
iconv -f windows-1252 -t utf-8 ChangeLog > ChangeLog.aux
mv ChangeLog.aux ChangeLog
@ -262,6 +266,8 @@ fi
- resolves: #861849
updated to 4.6.1
- cleaned .spec file
- resolves: #759964
fixed sigsegv
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild