90e6999a07
- Update to the stuff in master to fix the issue at: https://bodhi.fedoraproject.org/updates/FEDORA-2020-050993b283#comment-1208958 - Update to 3.0.11 (via patches generated from git) - Plus newer upstream fixes (also via patches generated from git) - Fix shell exit failures in make - Fix .reloc section generation - Fix CHAR8 definition - Fix "make DESTDIR=..." - Change the installed .a/.o layout - Provide makefiles for consumers to use. - Make the -devel noarch since it's just headers. - Add a bunch of compatibility symlinks for our older packages. These will go away once we've migrated everything using them in fedora to use the newer make system... Signed-off-by: Peter Jones <pjones@redhat.com>
37 lines
1.1 KiB
Diff
37 lines
1.1 KiB
Diff
From 230c36c6aa4fcb1db61ce177264e224c26314da1 Mon Sep 17 00:00:00 2001
|
|
From: Nigel Croxon <ncroxon@redhat.com>
|
|
Date: Tue, 2 Apr 2019 09:47:24 -0400
|
|
Subject: [PATCH 08/46] gnuefi/Makefile uses a strange rule to create
|
|
libgnuefi.a, which only works because of a "make" builtin rule. This breaks
|
|
make -r, and it is an inefficient way to build, at least for multiple files.
|
|
|
|
I have made a git tree which includes a patch for this problem,
|
|
and also forces -r by adding it to MAKEFLAGS:
|
|
|
|
git://git.zytor.com/users/hpa/gnu-efi.git make-r-fixes
|
|
|
|
Signed-off-by: H. Peter Anvin <hpa@users.sourceforge.net>
|
|
Signed-off-by: Nigel Croxon <ncroxon@redhat.com>
|
|
---
|
|
gnuefi/Makefile | 4 +++-
|
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/gnuefi/Makefile b/gnuefi/Makefile
|
|
index 2a61699ac25..10d4e7addd0 100644
|
|
--- a/gnuefi/Makefile
|
|
+++ b/gnuefi/Makefile
|
|
@@ -54,7 +54,9 @@ TARGETS = crt0-efi-$(ARCH).o libgnuefi.a
|
|
|
|
all: $(TARGETS)
|
|
|
|
-libgnuefi.a: $(patsubst %,libgnuefi.a(%),$(OBJS))
|
|
+libgnuefi.a: $(OBJS)
|
|
+ $(AR) $(ARFLAGS) $@ $^
|
|
+
|
|
|
|
clean:
|
|
rm -f $(TARGETS) *~ *.o $(OBJS)
|
|
--
|
|
2.24.1
|
|
|