gnu-efi/0034-Make-make-TOPDIR-actua...

104 lines
2.3 KiB
Diff

From ecf4e093f27902ef42d56b48db3fd583e9a0c62a Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@redhat.com>
Date: Fri, 25 Oct 2019 15:36:18 -0400
Subject: [PATCH 34/45] Make: make TOPDIR actually work and get rid of unused
CDIR
Signed-off-by: Peter Jones <pjones@redhat.com>
---
Make.defaults | 2 +-
apps/Makefile | 4 +---
gnuefi/Makefile | 4 +---
inc/Makefile | 5 +----
lib/Makefile | 2 +-
5 files changed, 5 insertions(+), 12 deletions(-)
diff --git a/Make.defaults b/Make.defaults
index b8a3e07b681..696028dd6c2 100755
--- a/Make.defaults
+++ b/Make.defaults
@@ -34,7 +34,7 @@
# SUCH DAMAGE.
#
-TOPDIR := $(shell if [ "$$PWD" != "" ]; then echo $$PWD; else pwd; fi)
+TOPDIR ?= $(shell if [ "$$PWD" != "" ]; then echo $$PWD; else pwd; fi)
ARCHES=aa64 arm ia32 ia64 mips64el x64
diff --git a/apps/Makefile b/apps/Makefile
index 04cf251cb2f..3b96f153a23 100644
--- a/apps/Makefile
+++ b/apps/Makefile
@@ -37,12 +37,10 @@
SRCDIR = .
VPATH = $(SRCDIR)
+TOPDIR = $(SRCDIR)/..
include $(SRCDIR)/../Make.defaults
-TOPDIR = $(SRCDIR)/..
-
-CDIR=$(TOPDIR)/..
LINUX_HEADERS = /usr/src/sys/build
CPPFLAGS += -D__KERNEL__ -I$(LINUX_HEADERS)/include
CRTOBJS = $(TOPDIR)/$(ARCH)/gnuefi/crt0-efi-$(ARCH).o
diff --git a/gnuefi/Makefile b/gnuefi/Makefile
index 09b40cc421e..bea629b0b29 100644
--- a/gnuefi/Makefile
+++ b/gnuefi/Makefile
@@ -37,12 +37,10 @@
SRCDIR = .
VPATH = $(SRCDIR)
+TOPDIR = $(SRCDIR)/..
include $(SRCDIR)/../Make.defaults
-TOPDIR = $(SRCDIR)/..
-
-CDIR=$(TOPDIR)/..
FILES = reloc_$(ARCH)
OBJS = $(FILES:%=%.o)
diff --git a/inc/Makefile b/inc/Makefile
index dd36bb0103d..13022fd6ae1 100644
--- a/inc/Makefile
+++ b/inc/Makefile
@@ -1,12 +1,9 @@
SRCDIR = .
VPATH = $(SRCDIR)
-
-include $(SRCDIR)/../Make.defaults
-
TOPDIR = $(SRCDIR)/..
-CDIR=$(TOPDIR)/..
+include $(SRCDIR)/../Make.defaults
all:
diff --git a/lib/Makefile b/lib/Makefile
index 0e950db9c0c..9a2b611cab7 100644
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -37,12 +37,12 @@
SRCDIR = .
VPATH = $(SRCDIR)
+TOPDIR = $(SRCDIR)/..
include $(SRCDIR)/../Make.defaults
TOPDIR = $(SRCDIR)/..
-CDIR = $(TOPDIR)/..
FILES = boxdraw smbios console crc data debug dpath \
entry error event exit guid hand hw init lock \
misc print sread str cmdline \
--
2.24.1