2b933aacc1
some content.
171 lines
5.6 KiB
Diff
171 lines
5.6 KiB
Diff
diff -urpN gnu-efi-3.0d/gnuefi/Makefile.setjmp gnu-efi-3.0d/gnuefi/Makefile
|
|
--- gnu-efi-3.0d/gnuefi/Makefile.setjmp 2008-04-29 13:18:19.000000000 -0400
|
|
+++ gnu-efi-3.0d/gnuefi/Makefile 2008-04-29 13:18:43.000000000 -0400
|
|
@@ -23,7 +23,7 @@
|
|
|
|
include ../Make.defaults
|
|
CDIR=$(TOPDIR)/..
|
|
-FILES = reloc_$(ARCH)
|
|
+FILES = reloc_$(ARCH) setjmp_$(ARCH)
|
|
|
|
OBJS = $(FILES:%=%.o)
|
|
|
|
diff -urpN gnu-efi-3.0d/gnuefi/setjmp_ia32.S.setjmp gnu-efi-3.0d/gnuefi/setjmp_ia32.S
|
|
--- gnu-efi-3.0d/gnuefi/setjmp_ia32.S.setjmp 2008-04-29 13:13:05.000000000 -0400
|
|
+++ gnu-efi-3.0d/gnuefi/setjmp_ia32.S 2008-04-29 13:22:04.000000000 -0400
|
|
@@ -0,0 +1,87 @@
|
|
+/*
|
|
+ * GRUB -- GRand Unified Bootloader
|
|
+ * Copyright (C) 2000 Free Software Foundation, Inc.
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or modify
|
|
+ * it under the terms of the GNU General Public License as published by
|
|
+ * the Free Software Foundation; either version 2 of the License, or
|
|
+ * (at your option) any later version.
|
|
+ *
|
|
+ * This program is distributed in the hope that it will be useful,
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+ * GNU General Public License for more details.
|
|
+ *
|
|
+ * You should have received a copy of the GNU General Public License
|
|
+ * along with this program; if not, see <http://www.gnu.org/licenses/>.
|
|
+ */
|
|
+
|
|
+/* This is stolen from libc/x86/setjmp.S in the OSKit */
|
|
+/*
|
|
+ * Mach Operating System
|
|
+ * Copyright (c) 1991,1990,1989 Carnegie Mellon University
|
|
+ * All Rights Reserved.
|
|
+ *
|
|
+ * Permission to use, copy, modify and distribute this software and its
|
|
+ * documentation is hereby granted, provided that both the copyright
|
|
+ * notice and this permission notice appear in all copies of the
|
|
+ * software, derivative works or modified versions, and any portions
|
|
+ * thereof, and that both notices appear in supporting documentation.
|
|
+ *
|
|
+ * CARNEGIE MELLON ALLOWS FREE USE OF THIS SOFTWARE IN ITS "AS IS"
|
|
+ * CONDITION. CARNEGIE MELLON DISCLAIMS ANY LIABILITY OF ANY KIND FOR
|
|
+ * ANY DAMAGES WHATSOEVER RESULTING FROM THE USE OF THIS SOFTWARE.
|
|
+ *
|
|
+ * Carnegie Mellon requests users of this software to return to
|
|
+ *
|
|
+ * Software Distribution Coordinator or Software.Distribution@CS.CMU.EDU
|
|
+ * School of Computer Science
|
|
+ * Carnegie Mellon University
|
|
+ * Pittsburgh PA 15213-3890
|
|
+ *
|
|
+ * any improvements or extensions that they make and grant Carnegie Mellon
|
|
+ * the rights to redistribute these changes.
|
|
+ */
|
|
+/*
|
|
+ * C library -- _setjmp, _longjmp
|
|
+ *
|
|
+ * _longjmp(a,v)
|
|
+ * will generate a "return(v)" from
|
|
+ * the last call to
|
|
+ * _setjmp(a)
|
|
+ * by restoring registers from the stack,
|
|
+ * The previous signal state is NOT restored.
|
|
+ *
|
|
+ */
|
|
+
|
|
+#define EXT_C(sym) sym
|
|
+#define FUNCTION(x) .globl EXT_C(x) ; .type EXT_C(x), "function" ; EXT_C(x):
|
|
+
|
|
+ .file "setjmp.S"
|
|
+
|
|
+ .text
|
|
+
|
|
+FUNCTION(setjmp)
|
|
+ movl 4(%esp), %ecx /* fetch buffer */
|
|
+ movl %ebx, 0(%ecx)
|
|
+ movl %esi, 4(%ecx)
|
|
+ movl %edi, 8(%ecx)
|
|
+ movl %ebp, 12(%ecx) /* save frame pointer of caller */
|
|
+ popl %edx
|
|
+ movl %esp, 16(%ecx) /* save stack pointer of caller */
|
|
+ movl %edx, 20(%ecx) /* save pc of caller */
|
|
+ xorl %eax, %eax
|
|
+ jmp *%edx
|
|
+
|
|
+FUNCTION(longjmp)
|
|
+ movl 8(%esp), %eax /* return(v) */
|
|
+ movl 4(%esp), %ecx /* fetch buffer */
|
|
+ movl 0(%ecx), %ebx
|
|
+ movl 4(%ecx), %esi
|
|
+ movl 8(%ecx), %edi
|
|
+ movl 12(%ecx), %ebp
|
|
+ movl 16(%ecx), %esp
|
|
+ orl %eax, %eax
|
|
+ jnz 0f
|
|
+ incl %eax
|
|
+0: jmp *20(%ecx) /* done, return.... */
|
|
diff -urpN gnu-efi-3.0d/gnuefi/setjmp_ia64.S.setjmp gnu-efi-3.0d/gnuefi/setjmp_ia64.S
|
|
--- gnu-efi-3.0d/gnuefi/setjmp_ia64.S.setjmp 2008-04-29 13:19:34.000000000 -0400
|
|
+++ gnu-efi-3.0d/gnuefi/setjmp_ia64.S 2008-04-29 13:19:44.000000000 -0400
|
|
@@ -0,0 +1,2 @@
|
|
+
|
|
+#warning not implemented
|
|
diff -urpN gnu-efi-3.0d/gnuefi/setjmp_x86_64.S.setjmp gnu-efi-3.0d/gnuefi/setjmp_x86_64.S
|
|
--- gnu-efi-3.0d/gnuefi/setjmp_x86_64.S.setjmp 2008-04-29 13:18:12.000000000 -0400
|
|
+++ gnu-efi-3.0d/gnuefi/setjmp_x86_64.S 2008-04-29 13:22:04.000000000 -0400
|
|
@@ -0,0 +1,56 @@
|
|
+/*
|
|
+ * GRUB -- GRand Unified Bootloader
|
|
+ * Copyright (C) 2003 Free Software Foundation, Inc.
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or modify
|
|
+ * it under the terms of the GNU General Public License as published by
|
|
+ * the Free Software Foundation; either version 2 of the License, or
|
|
+ * (at your option) any later version.
|
|
+ *
|
|
+ * This program is distributed in the hope that it will be useful,
|
|
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+ * GNU General Public License for more details.
|
|
+ *
|
|
+ * You should have received a copy of the GNU General Public License
|
|
+ * along with this program; if not, see <http://www.gnu.org/licenses/>.
|
|
+ */
|
|
+
|
|
+#define EXT_C(sym) sym
|
|
+#define FUNCTION(x) .globl EXT_C(x) ; .type EXT_C(x), "function" ; EXT_C(x):
|
|
+
|
|
+ .file "setjmp.S"
|
|
+
|
|
+ .text
|
|
+
|
|
+/*
|
|
+ * int setjmp (jmp_buf env)
|
|
+ */
|
|
+FUNCTION(setjmp)
|
|
+ pop %rsi /* Return address, and adjust the stack */
|
|
+ xor %rax, %rax
|
|
+ movq %rbx, 0(%rdi) /* RBX */
|
|
+ movq %rsp, 8(%rdi) /* RSP */
|
|
+ push %rsi
|
|
+ movq %rbp, 16(%rdi) /* RBP */
|
|
+ movq %r12, 24(%rdi) /* R12 */
|
|
+ movq %r13, 32(%rdi) /* R13 */
|
|
+ movq %r14, 40(%rdi) /* R14 */
|
|
+ movq %r15, 48(%rdi) /* R15 */
|
|
+ movq %rsi, 56(%rdi) /* RSI */
|
|
+ ret
|
|
+
|
|
+/*
|
|
+ * int longjmp (jmp_buf env, int val)
|
|
+ */
|
|
+FUNCTION(longjmp)
|
|
+ movl %esi, %eax
|
|
+ movq (%rdi), %rbx
|
|
+ movq 8(%rdi), %rsp
|
|
+ movq 16(%rdi), %rbp
|
|
+ movq 24(%rdi), %r12
|
|
+ movq 32(%rdi), %r13
|
|
+ movq 40(%rdi), %r14
|
|
+ movq 48(%rdi), %r15
|
|
+ jmp *56(%rdi)
|
|
+
|
|
diff -urpN gnu-efi-3.0d/Make.rules.setjmp gnu-efi-3.0d/Make.rules
|