- Add x86_64 support.
This commit is contained in:
parent
85ed649028
commit
f0da5acf3c
204
gnu-efi-3.0c-pragma.patch
Normal file
204
gnu-efi-3.0c-pragma.patch
Normal file
@ -0,0 +1,204 @@
|
|||||||
|
diff -up gnu-efi-3.0c/lib/runtime/rtdata.c.pragma gnu-efi-3.0c/lib/runtime/rtdata.c
|
||||||
|
--- gnu-efi-3.0c/lib/runtime/rtdata.c.pragma 2007-12-19 13:29:42.000000000 -0500
|
||||||
|
+++ gnu-efi-3.0c/lib/runtime/rtdata.c 2007-12-19 13:29:59.000000000 -0500
|
||||||
|
@@ -26,7 +26,9 @@ Revision History
|
||||||
|
// right data section if it is explicitly initialized..
|
||||||
|
//
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma BEGIN_RUNTIME_DATA()
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
//
|
||||||
|
// RT - pointer to the runtime table
|
||||||
|
diff -up gnu-efi-3.0c/lib/runtime/vm.c.pragma gnu-efi-3.0c/lib/runtime/vm.c
|
||||||
|
--- gnu-efi-3.0c/lib/runtime/vm.c.pragma 2007-12-19 13:28:58.000000000 -0500
|
||||||
|
+++ gnu-efi-3.0c/lib/runtime/vm.c 2007-12-19 13:29:10.000000000 -0500
|
||||||
|
@@ -24,7 +24,9 @@ Revision History
|
||||||
|
|
||||||
|
#include "lib.h"
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(RtLibEnableVirtualMappings)
|
||||||
|
+#endif
|
||||||
|
VOID
|
||||||
|
RUNTIMEFUNCTION
|
||||||
|
RtLibEnableVirtualMappings (
|
||||||
|
@@ -64,7 +66,9 @@ RtLibEnableVirtualMappings (
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(RtConvertList)
|
||||||
|
+#endif
|
||||||
|
VOID
|
||||||
|
RUNTIMEFUNCTION
|
||||||
|
RtConvertList (
|
||||||
|
diff -up gnu-efi-3.0c/lib/runtime/efirtlib.c.pragma gnu-efi-3.0c/lib/runtime/efirtlib.c
|
||||||
|
--- gnu-efi-3.0c/lib/runtime/efirtlib.c.pragma 2007-12-19 13:27:39.000000000 -0500
|
||||||
|
+++ gnu-efi-3.0c/lib/runtime/efirtlib.c 2007-12-19 13:28:02.000000000 -0500
|
||||||
|
@@ -20,7 +20,9 @@ Revision History
|
||||||
|
#include "efilib.h"
|
||||||
|
#include "efirtlib.h"
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(RtZeroMem)
|
||||||
|
+#endif
|
||||||
|
VOID
|
||||||
|
RUNTIMEFUNCTION
|
||||||
|
RtZeroMem (
|
||||||
|
@@ -36,7 +38,9 @@ RtZeroMem (
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(RtSetMem)
|
||||||
|
+#endif
|
||||||
|
VOID
|
||||||
|
RUNTIMEFUNCTION
|
||||||
|
RtSetMem (
|
||||||
|
@@ -53,7 +57,9 @@ RtSetMem (
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(RtCopyMem)
|
||||||
|
+#endif
|
||||||
|
VOID
|
||||||
|
RUNTIMEFUNCTION
|
||||||
|
RtCopyMem (
|
||||||
|
@@ -71,7 +77,9 @@ RtCopyMem (
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(RtCompareMem)
|
||||||
|
+#endif
|
||||||
|
INTN
|
||||||
|
RUNTIMEFUNCTION
|
||||||
|
RtCompareMem (
|
||||||
|
@@ -96,7 +104,9 @@ RtCompareMem (
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(RtCompareGuid)
|
||||||
|
+#endif
|
||||||
|
INTN
|
||||||
|
RUNTIMEFUNCTION
|
||||||
|
RtCompareGuid (
|
||||||
|
diff -up gnu-efi-3.0c/lib/runtime/rtlock.c.pragma gnu-efi-3.0c/lib/runtime/rtlock.c
|
||||||
|
--- gnu-efi-3.0c/lib/runtime/rtlock.c.pragma 2007-12-19 13:26:56.000000000 -0500
|
||||||
|
+++ gnu-efi-3.0c/lib/runtime/rtlock.c 2007-12-19 13:27:18.000000000 -0500
|
||||||
|
@@ -21,7 +21,9 @@ Revision History
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(RtAcquireLock)
|
||||||
|
+#endif
|
||||||
|
VOID
|
||||||
|
RtAcquireLock (
|
||||||
|
IN FLOCK *Lock
|
||||||
|
@@ -58,7 +60,9 @@ Returns:
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(RtAcquireLock)
|
||||||
|
+#endif
|
||||||
|
VOID
|
||||||
|
RtReleaseLock (
|
||||||
|
IN FLOCK *Lock
|
||||||
|
diff -up gnu-efi-3.0c/lib/runtime/rtstr.c.pragma gnu-efi-3.0c/lib/runtime/rtstr.c
|
||||||
|
--- gnu-efi-3.0c/lib/runtime/rtstr.c.pragma 2007-12-19 13:28:15.000000000 -0500
|
||||||
|
+++ gnu-efi-3.0c/lib/runtime/rtstr.c 2007-12-19 13:28:48.000000000 -0500
|
||||||
|
@@ -17,7 +17,9 @@ Revision History
|
||||||
|
|
||||||
|
#include "lib.h"
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(RtAcquireLock)
|
||||||
|
+#endif
|
||||||
|
INTN
|
||||||
|
RUNTIMEFUNCTION
|
||||||
|
RtStrCmp (
|
||||||
|
@@ -38,7 +40,9 @@ RtStrCmp (
|
||||||
|
return *s1 - *s2;
|
||||||
|
}
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(RtStrCpy)
|
||||||
|
+#endif
|
||||||
|
VOID
|
||||||
|
RUNTIMEFUNCTION
|
||||||
|
RtStrCpy (
|
||||||
|
@@ -53,7 +57,9 @@ RtStrCpy (
|
||||||
|
*Dest = 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(RtStrCat)
|
||||||
|
+#endif
|
||||||
|
VOID
|
||||||
|
RUNTIMEFUNCTION
|
||||||
|
RtStrCat (
|
||||||
|
@@ -64,7 +70,9 @@ RtStrCat (
|
||||||
|
RtStrCpy(Dest+StrLen(Dest), Src);
|
||||||
|
}
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(RtStrLen)
|
||||||
|
+#endif
|
||||||
|
UINTN
|
||||||
|
RUNTIMEFUNCTION
|
||||||
|
RtStrLen (
|
||||||
|
@@ -78,7 +86,9 @@ RtStrLen (
|
||||||
|
return len;
|
||||||
|
}
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(RtStrSize)
|
||||||
|
+#endif
|
||||||
|
UINTN
|
||||||
|
RUNTIMEFUNCTION
|
||||||
|
RtStrSize (
|
||||||
|
@@ -92,7 +102,9 @@ RtStrSize (
|
||||||
|
return (len + 1) * sizeof(CHAR16);
|
||||||
|
}
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(RtBCDtoDecimal)
|
||||||
|
+#endif
|
||||||
|
UINT8
|
||||||
|
RUNTIMEFUNCTION
|
||||||
|
RtBCDtoDecimal(
|
||||||
|
@@ -108,7 +120,9 @@ RtBCDtoDecimal(
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(RtDecimaltoBCD)
|
||||||
|
+#endif
|
||||||
|
UINT8
|
||||||
|
RUNTIMEFUNCTION
|
||||||
|
RtDecimaltoBCD (
|
||||||
|
diff -up gnu-efi-3.0c/lib/print.c.pragma gnu-efi-3.0c/lib/print.c
|
||||||
|
--- gnu-efi-3.0c/lib/print.c.pragma 2007-12-19 13:25:51.000000000 -0500
|
||||||
|
+++ gnu-efi-3.0c/lib/print.c 2007-12-19 13:26:18.000000000 -0500
|
||||||
|
@@ -23,6 +23,7 @@ Revision History
|
||||||
|
//
|
||||||
|
|
||||||
|
#ifdef RUNTIME_CODE
|
||||||
|
+#ifndef __GNUC__
|
||||||
|
#pragma RUNTIME_CODE(DbgPrint)
|
||||||
|
|
||||||
|
// For debugging..
|
||||||
|
@@ -39,6 +40,7 @@ Revision History
|
||||||
|
#pragma RUNTIME_CODE(TimeToString)
|
||||||
|
*/
|
||||||
|
|
||||||
|
+#endif /* !defined(__GNUC__) */
|
||||||
|
#endif
|
||||||
|
|
||||||
|
//
|
1453
gnu-efi-3.0c-x64.patch
Normal file
1453
gnu-efi-3.0c-x64.patch
Normal file
File diff suppressed because it is too large
Load Diff
11
gnu-efi.spec
11
gnu-efi.spec
@ -1,13 +1,15 @@
|
|||||||
Summary: Development Libraries and headers for EFI
|
Summary: Development Libraries and headers for EFI
|
||||||
Name: gnu-efi
|
Name: gnu-efi
|
||||||
Version: 3.0c
|
Version: 3.0c
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Group: Development/System
|
Group: Development/System
|
||||||
License: GPL
|
License: GPL
|
||||||
URL: ftp://ftp.hpl.hp.com/pub/linux-ia64
|
URL: ftp://ftp.hpl.hp.com/pub/linux-ia64
|
||||||
Source: ftp://ftp.hpl.hp.com/pub/linux-ia64/gnu-efi-%{version}.tar.gz
|
Source: ftp://ftp.hpl.hp.com/pub/linux-ia64/gnu-efi-%{version}.tar.gz
|
||||||
|
Patch0: gnu-efi-3.0c-pragma.patch
|
||||||
|
Patch1: gnu-efi-3.0c-x64.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
ExclusiveArch: ia64 i386
|
ExclusiveArch: ia64 i386 x86_64
|
||||||
|
|
||||||
%description
|
%description
|
||||||
This package contains development headers and libraries for developing
|
This package contains development headers and libraries for developing
|
||||||
@ -15,6 +17,8 @@ applications that run under EFI (Extensible Firmware Interface).
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .pragma
|
||||||
|
%patch1 -p1 -b .x64
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# Package cannot build with %{?_smp_mflags}.
|
# Package cannot build with %{?_smp_mflags}.
|
||||||
@ -42,6 +46,9 @@ rm -rf %{buildroot}
|
|||||||
%{_libdir}/*
|
%{_libdir}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 19 2007 Peter Jones <pjones@redhat.com> - 3.0c-3
|
||||||
|
- Add support for x86_64 .
|
||||||
|
|
||||||
* Tue Jun 12 2007 Chris Lumens <clumens@redhat.com> - 3.0c-2
|
* Tue Jun 12 2007 Chris Lumens <clumens@redhat.com> - 3.0c-2
|
||||||
- Fixes for package review (#225846).
|
- Fixes for package review (#225846).
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user