Fix the paths in the patches.

God, I hate that gnu-efi-3.0/ is in the git repo.

Signed-off-by: Peter Jones <pjones@redhat.com>
This commit is contained in:
Peter Jones 2014-11-20 15:02:59 -05:00
parent 631ab97578
commit ac3f311f01
5 changed files with 28 additions and 28 deletions

View File

@ -11,14 +11,14 @@ stuff on the fly.
Signed-off-by: Peter Jones <pjones@redhat.com> Signed-off-by: Peter Jones <pjones@redhat.com>
--- ---
gnu-efi-3.0/gnuefi/Makefile | 34 ++++++++++++---------------------- gnuefi/Makefile | 34 ++++++++++++----------------------
gnu-efi-3.0/inc/Makefile | 36 +++++++++++------------------------- inc/Makefile | 36 +++++++++++-------------------------
2 files changed, 23 insertions(+), 47 deletions(-) 2 files changed, 23 insertions(+), 47 deletions(-)
diff --git a/gnu-efi-3.0/gnuefi/Makefile b/gnu-efi-3.0/gnuefi/Makefile diff --git a/gnuefi/Makefile b/gnuefi/Makefile
index 4717227..d234ac0 100644 index 4717227..d234ac0 100644
--- a/gnu-efi-3.0/gnuefi/Makefile --- a/gnuefi/Makefile
+++ b/gnu-efi-3.0/gnuefi/Makefile +++ b/gnuefi/Makefile
@@ -52,19 +52,6 @@ reloc_aarch64.o: CFLAGS += -fno-jump-tables @@ -52,19 +52,6 @@ reloc_aarch64.o: CFLAGS += -fno-jump-tables
TARGETS = crt0-efi-$(ARCH).o libgnuefi.a TARGETS = crt0-efi-$(ARCH).o libgnuefi.a
@ -66,10 +66,10 @@ index 4717227..d234ac0 100644
+endif +endif
include $(SRCDIR)/../Make.rules include $(SRCDIR)/../Make.rules
diff --git a/gnu-efi-3.0/inc/Makefile b/gnu-efi-3.0/inc/Makefile diff --git a/inc/Makefile b/inc/Makefile
index 526af22..71fded5 100644 index 526af22..71fded5 100644
--- a/gnu-efi-3.0/inc/Makefile --- a/inc/Makefile
+++ b/gnu-efi-3.0/inc/Makefile +++ b/inc/Makefile
@@ -8,34 +8,20 @@ TOPDIR = $(SRCDIR)/.. @@ -8,34 +8,20 @@ TOPDIR = $(SRCDIR)/..
CDIR=$(TOPDIR)/.. CDIR=$(TOPDIR)/..

View File

@ -9,14 +9,14 @@ include non-globbed versions of .rel/.rela individually.
Signed-off-by: Peter Jones <pjones@redhat.com> Signed-off-by: Peter Jones <pjones@redhat.com>
Signed-Off-By: Bill Paul <wpaul@windriver.com> Signed-Off-By: Bill Paul <wpaul@windriver.com>
--- ---
gnu-efi-3.0/Make.defaults | 7 +++++++ Make.defaults | 7 +++++++
gnu-efi-3.0/Make.rules | 5 +++-- Make.rules | 5 +++--
2 files changed, 10 insertions(+), 2 deletions(-) 2 files changed, 10 insertions(+), 2 deletions(-)
diff --git a/gnu-efi-3.0/Make.defaults b/gnu-efi-3.0/Make.defaults diff --git a/Make.defaults b/Make.defaults
index 807205d..169273d 100644 index 807205d..169273d 100644
--- a/gnu-efi-3.0/Make.defaults --- a/Make.defaults
+++ b/gnu-efi-3.0/Make.defaults +++ b/Make.defaults
@@ -133,8 +133,15 @@ endif @@ -133,8 +133,15 @@ endif
# Generic compilation flags # Generic compilation flags
INCDIR += -I$(SRCDIR) -I$(TOPDIR)/inc -I$(TOPDIR)/inc/$(ARCH) \ INCDIR += -I$(SRCDIR) -I$(TOPDIR)/inc -I$(TOPDIR)/inc/$(ARCH) \
@ -33,10 +33,10 @@ index 807205d..169273d 100644
+ +
ASFLAGS += $(ARCH3264) ASFLAGS += $(ARCH3264)
LDFLAGS += -nostdlib --warn-common --no-undefined --fatal-warnings LDFLAGS += -nostdlib --warn-common --no-undefined --fatal-warnings
diff --git a/gnu-efi-3.0/Make.rules b/gnu-efi-3.0/Make.rules diff --git a/Make.rules b/Make.rules
index 7113b3e..02c7088 100644 index 7113b3e..02c7088 100644
--- a/gnu-efi-3.0/Make.rules --- a/Make.rules
+++ b/gnu-efi-3.0/Make.rules +++ b/Make.rules
@@ -35,8 +35,9 @@ @@ -35,8 +35,9 @@
# #

View File

@ -5,13 +5,13 @@ Subject: [PATCH 3/5] Add the capsule API
Signed-off-by: Peter Jones <pjones@redhat.com> Signed-off-by: Peter Jones <pjones@redhat.com>
--- ---
gnu-efi-3.0/inc/efiapi.h | 38 ++++++++++++++++++++++++++++++++++++++ inc/efiapi.h | 38 ++++++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+) 1 file changed, 38 insertions(+)
diff --git a/gnu-efi-3.0/inc/efiapi.h b/gnu-efi-3.0/inc/efiapi.h diff --git a/inc/efiapi.h b/inc/efiapi.h
index 2ab9f1f..a3e3fd9 100644 index 2ab9f1f..a3e3fd9 100644
--- a/gnu-efi-3.0/inc/efiapi.h --- a/inc/efiapi.h
+++ b/gnu-efi-3.0/inc/efiapi.h +++ b/inc/efiapi.h
@@ -585,6 +585,42 @@ EFI_STATUS @@ -585,6 +585,42 @@ EFI_STATUS
OUT UINT32 *HighCount OUT UINT32 *HighCount
); );

View File

@ -5,13 +5,13 @@ Subject: [PATCH 4/5] Add the QueryVariableInfo() API.
Signed-off-by: Peter Jones <pjones@redhat.com> Signed-off-by: Peter Jones <pjones@redhat.com>
--- ---
gnu-efi-3.0/inc/efiapi.h | 10 ++++++++++ inc/efiapi.h | 10 ++++++++++
1 file changed, 10 insertions(+) 1 file changed, 10 insertions(+)
diff --git a/gnu-efi-3.0/inc/efiapi.h b/gnu-efi-3.0/inc/efiapi.h diff --git a/inc/efiapi.h b/inc/efiapi.h
index a3e3fd9..708c67f 100644 index a3e3fd9..708c67f 100644
--- a/gnu-efi-3.0/inc/efiapi.h --- a/inc/efiapi.h
+++ b/gnu-efi-3.0/inc/efiapi.h +++ b/inc/efiapi.h
@@ -621,6 +621,15 @@ EFI_STATUS @@ -621,6 +621,15 @@ EFI_STATUS
OUT EFI_RESET_TYPE *ResetType OUT EFI_RESET_TYPE *ResetType
); );

View File

@ -5,13 +5,13 @@ Subject: [PATCH 5/5] Add current OsIndications values.
Signed-off-by: Peter Jones <pjones@redhat.com> Signed-off-by: Peter Jones <pjones@redhat.com>
--- ---
gnu-efi-3.0/inc/efidef.h | 9 +++++++++ inc/efidef.h | 9 +++++++++
1 file changed, 9 insertions(+) 1 file changed, 9 insertions(+)
diff --git a/gnu-efi-3.0/inc/efidef.h b/gnu-efi-3.0/inc/efidef.h diff --git a/inc/efidef.h b/inc/efidef.h
index 666b193..8b70051 100644 index 666b193..8b70051 100644
--- a/gnu-efi-3.0/inc/efidef.h --- a/inc/efidef.h
+++ b/gnu-efi-3.0/inc/efidef.h +++ b/inc/efidef.h
@@ -208,4 +208,13 @@ typedef UINT8 ISO_639_2; @@ -208,4 +208,13 @@ typedef UINT8 ISO_639_2;
#define EFI_SIZE_TO_PAGES(a) \ #define EFI_SIZE_TO_PAGES(a) \
( ((a) >> EFI_PAGE_SHIFT) + ((a) & EFI_PAGE_MASK ? 1 : 0) ) ( ((a) >> EFI_PAGE_SHIFT) + ((a) & EFI_PAGE_MASK ? 1 : 0) )