Merge branch 'master' of ssh://pkgs.fedoraproject.org/gnu-efi
Conflicts: gnu-efi.spec
This commit is contained in:
commit
77ce7d7d71
57
gnu-efi-3.0e-handle-uninitialized-gop.patch
Normal file
57
gnu-efi-3.0e-handle-uninitialized-gop.patch
Normal file
@ -0,0 +1,57 @@
|
||||
From c261b8de0504fd37af99c61cdda248f312124034 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jones <pjones@redhat.com>
|
||||
Date: Thu, 16 Jun 2011 16:10:27 -0400
|
||||
Subject: [PATCH] Handle un-initialized GOP.
|
||||
|
||||
---
|
||||
apps/modelist.c | 27 +++++++++++++++++++++++++++
|
||||
1 files changed, 27 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/apps/modelist.c b/apps/modelist.c
|
||||
index c4a4b1a..8d816d1 100644
|
||||
--- a/apps/modelist.c
|
||||
+++ b/apps/modelist.c
|
||||
@@ -3,6 +3,26 @@
|
||||
|
||||
extern EFI_GUID GraphicsOutputProtocol;
|
||||
|
||||
+static int memcmp(const void *s1, const void *s2, UINTN n)
|
||||
+{
|
||||
+ const unsigned char *c1 = s1, *c2 = s2;
|
||||
+ int d = 0;
|
||||
+
|
||||
+ if (!s1 && !s2)
|
||||
+ return 0;
|
||||
+ if (s1 && !s2)
|
||||
+ return 1;
|
||||
+ if (!s1 && s2)
|
||||
+ return -1;
|
||||
+
|
||||
+ while (n--) {
|
||||
+ d = (int)*c1++ - (int)*c2++;
|
||||
+ if (d)
|
||||
+ break;
|
||||
+ }
|
||||
+ return d;
|
||||
+}
|
||||
+
|
||||
static void
|
||||
print_modes(EFI_GRAPHICS_OUTPUT_PROTOCOL *gop)
|
||||
{
|
||||
@@ -17,6 +37,13 @@ print_modes(EFI_GRAPHICS_OUTPUT_PROTOCOL *gop)
|
||||
UINTN SizeOfInfo;
|
||||
rc = uefi_call_wrapper(gop->QueryMode, 4, gop, i, &SizeOfInfo,
|
||||
&info);
|
||||
+ if (EFI_ERROR(rc) && rc == EFI_NOT_STARTED) {
|
||||
+ rc = uefi_call_wrapper(gop->SetMode, 2, gop,
|
||||
+ gop->Mode->Mode);
|
||||
+ rc = uefi_call_wrapper(gop->QueryMode, 4, gop, i,
|
||||
+ &SizeOfInfo, &info);
|
||||
+ }
|
||||
+
|
||||
if (EFI_ERROR(rc)) {
|
||||
CHAR16 Buffer[64];
|
||||
StatusToString(Buffer, rc);
|
||||
--
|
||||
1.7.4.4
|
||||
|
14
gnu-efi.spec
14
gnu-efi.spec
@ -15,10 +15,11 @@ Patch5: gnu-efi-3.0e-route80h.patch
|
||||
Patch6: gnu-efi-3.0e-modelist.patch
|
||||
Patch7: gnu-efi-3.0e-route80h-add-cougarpoint.patch
|
||||
Patch8: gnu-efi-3.0e-machine-types.patch
|
||||
Patch9: gnu-efi-3.0e-Add-.S-and-.E-rules.patch
|
||||
Patch10: gnu-efi-3.0e-Guarantee-16-byte-stack-alignment-on-x86_64-efi_call.patch
|
||||
Patch11: gnu-efi-3.0e-Add-the-routines-to-make-callbacks-work.patch
|
||||
Patch12: gnu-efi-3.0e-Add-tcc.efi-to-test-our-calling-convention-shananaga.patch
|
||||
Patch9: gnu-efi-3.0e-handle-uninitialized-gop.patch
|
||||
Patch10: gnu-efi-3.0e-Add-.S-and-.E-rules.patch
|
||||
Patch11: gnu-efi-3.0e-Guarantee-16-byte-stack-alignment-on-x86_64-efi_call.patch
|
||||
Patch12: gnu-efi-3.0e-Add-the-routines-to-make-callbacks-work.patch
|
||||
Patch13: gnu-efi-3.0e-Add-tcc.efi-to-test-our-calling-convention-shananaga.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
ExclusiveArch: i686 x86_64 ia64
|
||||
BuildRequires: git
|
||||
@ -68,11 +69,16 @@ rm -rf %{buildroot}
|
||||
%attr(0644,root,root) /boot/efi/EFI/redhat/*.efi
|
||||
|
||||
%changelog
|
||||
<<<<<<< HEAD
|
||||
* Thu Aug 11 2011 Peter Jones <pjones@redhat.com> - 3.0e-14
|
||||
- Correctly pad the stack when doing uefi calls
|
||||
Related: rhbz#677468
|
||||
- Add ability to write UEFI callbacks and drivers
|
||||
- Add test harness for ABI Calling Conventions
|
||||
=======
|
||||
* Thu Jun 16 2011 Peter Jones <pjones@redhat.com> - 3.0e-14
|
||||
- Handle uninitialized GOP driver gracefully.
|
||||
>>>>>>> b38a657b7181bc66628b4814d2643f8a4da8192b
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0e-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
Loading…
Reference in New Issue
Block a user