- Fix install paths on x86_64.

This commit is contained in:
Peter Jones 2008-10-03 18:46:33 +00:00
parent ec9b7d6265
commit 64e8d4f93c
2 changed files with 77 additions and 6 deletions

View File

@ -0,0 +1,66 @@
From 364351b4448ff20730250e89ad09088d6aeafc72 Mon Sep 17 00:00:00 2001
From: Peter Jones <pjones@cutlet.install.bos.redhat.com>
Date: Fri, 3 Oct 2008 14:40:56 -0400
Subject: [PATCH] Fix usage of INSTALLROOT, PREFIX, and LIBDIR.
I screwed it up last time.
---
Make.defaults | 6 +++---
inc/Makefile | 16 ++++++++--------
2 files changed, 11 insertions(+), 11 deletions(-)
diff --git a/Make.defaults b/Make.defaults
index 4ad6480..de72d9b 100644
--- a/Make.defaults
+++ b/Make.defaults
@@ -25,8 +25,9 @@
# Where to install the package. GNU-EFI will create and access
# lib and include under the root
#
-INSTALLROOT=/usr/local
-LIBDIR=lib
+INSTALLROOT:= /
+PREFIX := /usr/local
+LIBDIR := ${PREFIX}/lib
TOPDIR := $(shell if [ "$$PWD" != "" ]; then echo $$PWD; else pwd; fi)
@@ -59,7 +60,6 @@ endif
ifeq ($(ARCH), x86_64)
CFLAGS += -DEFI_FUNCTION_WRAPPER -mno-red-zone
- LIBDIR = lib
ifeq ($(HOSTARCH), ia32)
ARCH3264 = -m64
endif
diff --git a/inc/Makefile b/inc/Makefile
index 9683be5..71fded5 100644
--- a/inc/Makefile
+++ b/inc/Makefile
@@ -13,15 +13,15 @@ all:
clean:
install:
- mkdir -p $(INSTALLROOT)/include/efi
- mkdir -p $(INSTALLROOT)/include/efi/protocol
- mkdir -p $(INSTALLROOT)/include/efi/$(ARCH)
- $(INSTALL) -m 644 *.h $(INSTALLROOT)/include/efi
- $(INSTALL) -m 644 protocol/*.h $(INSTALLROOT)/include/efi/protocol
- $(INSTALL) -m 644 $(ARCH)/*.h $(INSTALLROOT)/include/efi/$(ARCH)
+ mkdir -p $(INSTALLROOT)$(PREFIX)/include/efi
+ mkdir -p $(INSTALLROOT)$(PREFIX)/include/efi/protocol
+ mkdir -p $(INSTALLROOT)$(PREFIX)/include/efi/$(ARCH)
+ $(INSTALL) -m 644 *.h $(INSTALLROOT)$(PREFIX)/include/efi
+ $(INSTALL) -m 644 protocol/*.h $(INSTALLROOT)$(PREFIX)/include/efi/protocol
+ $(INSTALL) -m 644 $(ARCH)/*.h $(INSTALLROOT)$(PREFIX)/include/efi/$(ARCH)
ifeq ($(ARCH),ia64)
- mkdir -p $(INSTALLROOT)/include/efi/protocol/ia64
- $(INSTALL) -m 644 protocol/ia64/*.h $(INSTALLROOT)/include/efi/protocol/ia64
+ mkdir -p $(INSTALLROOT)$(PREFIX)/include/efi/protocol/ia64
+ $(INSTALL) -m 644 protocol/ia64/*.h $(INSTALLROOT)$(PREFIX)/include/efi/protocol/ia64
endif
include $(SRCDIR)/../Make.rules
--
1.5.4.5

View File

@ -1,15 +1,16 @@
Summary: Development Libraries and headers for EFI
Name: gnu-efi
Version: 3.0e
Release: 1%{?dist}
Release: 2%{?dist}
Group: Development/System
License: GPLv2+
URL: ftp://ftp.hpl.hp.com/pub/linux-ia64
Source: ftp://ftp.hpl.hp.com/pub/linux-ia64/gnu-efi-%{version}.tar.bz2
Patch0: gnu-efi-3.0e-no-relocations.patch
Patch1: gnu-efi-3.0d-unwrap.patch
Patch2: gnu-efi-3.0d-uefi_wrap.patch
Patch3: gnu-efi-3.0d-uefi_wrap_call10.patch
Patch1: gnu-efi-3.0e-Fix-usage-of-INSTALLROOT-PREFIX-and-LIBDIR.patch
Patch2: gnu-efi-3.0d-unwrap.patch
Patch3: gnu-efi-3.0d-uefi_wrap.patch
Patch4: gnu-efi-3.0d-uefi_wrap_call10.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
ExclusiveArch: i386 x86_64
@ -20,12 +21,13 @@ applications that run under EFI (Extensible Firmware Interface).
%prep
%setup -q
%patch0 -p1
%patch1 -p1
# these are currently disabled as we don't need them per se, and they
# haven't gone upstream yet either. Also #2 and #3 haven't been updated
# to work with gnu-efi-3.0e yet.
#%%patch1 -p1
#%%patch2 -p1
#%%patch3 -p1
#%%patch4 -p1
%build
# Package cannot build with %{?_smp_mflags}.
@ -36,7 +38,7 @@ rm -rf %{buildroot}
mkdir -p %{buildroot}/%{_libdir}
make INSTALLROOT=%{buildroot}/%{_prefix} install
make PREFIX=%{_prefix} LIBDIR=%{_libdir} INSTALLROOT=%{buildroot} install
mkdir -p %{buildroot}/%{_libdir}/gnuefi
mv %{buildroot}/%{_libdir}/*.lds %{buildroot}/%{_libdir}/*.o %{buildroot}/%{_libdir}/gnuefi
@ -53,6 +55,9 @@ rm -rf %{buildroot}
%{_libdir}/*
%changelog
* Fri Oct 03 2008 Peter Jones <pjones@redhat.com> - 3.0e-2
- Fix install paths on x86_64.
* Thu Oct 02 2008 Peter Jones <pjones@redhat.com> - 3.0e-1
- Update to 3.0e
- Fix relocation bug in 3.0e