Update to 3.27.90

- Switch to meson build system
This commit is contained in:
Kalev Lember 2018-02-06 11:48:56 +01:00
parent 5c2c43e552
commit f27b0c5378
4 changed files with 44 additions and 90 deletions

View File

@ -0,0 +1,28 @@
From 94a5cc2c77a77ebc19d0de1a3b44d21809d7c34e Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Tue, 6 Feb 2018 11:41:31 +0100
Subject: [PATCH] build: Fix error when doing non-debug builds
compiler_flags needs to be defined both when doing debug builds (as it
was) and non-debug builds to avoid an error.
Spotted by Kalev Lember <klember@redhat.com>
---
meson.build | 1 +
1 file changed, 1 insertion(+)
diff --git a/meson.build b/meson.build
index 1fc2782f1917..51fd03cbad34 100644
--- a/meson.build
+++ b/meson.build
@@ -69,6 +69,7 @@ if get_option('buildtype').contains('debug')
compiler_flags = cc.get_supported_arguments(test_cflags)
else
common_flags += ['-DG_DISABLE_CHECKS']
+ compiler_flags = []
endif
# Workaround for meson's bug
--
2.14.3

View File

@ -1,64 +0,0 @@
From bc732cd6c7c7e22b0f8df7c6a4046b5303eff5eb Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Wed, 10 Jan 2018 17:57:47 +0100
Subject: [PATCH] power: Don't react to light changes if not at console
As iio-sensor-proxy isn't yet clever enough to only send property
changes signals to clients that have claimed a sensor, disconnect
the properties-changed signal so we don't attempt to make brightness
changes when we're not on the active seat.
See https://github.com/hadess/iio-sensor-proxy/issues/210
See https://bugzilla.gnome.org/show_bug.cgi?id=756539
See https://bugzilla.gnome.org/show_bug.cgi?id=773685
See https://bugzilla.gnome.org/show_bug.cgi?id=764896
See https://bugzilla.redhat.com/show_bug.cgi?id=1322588
https://bugzilla.gnome.org/show_bug.cgi?id=792409
---
plugins/power/gsd-power-manager.c | 15 +++++++++++++--
1 file changed, 13 insertions(+), 2 deletions(-)
diff --git a/plugins/power/gsd-power-manager.c b/plugins/power/gsd-power-manager.c
index e411e124..19fa3214 100644
--- a/plugins/power/gsd-power-manager.c
+++ b/plugins/power/gsd-power-manager.c
@@ -219,6 +219,7 @@ static gboolean idle_is_session_inhibited (GsdPowerManager *manager, guint mask
static void idle_triggered_idle_cb (GnomeIdleMonitor *monitor, guint watch_id, gpointer user_data);
static void idle_became_active_cb (GnomeIdleMonitor *monitor, guint watch_id, gpointer user_data);
static void iio_proxy_changed (GsdPowerManager *manager);
+static void iio_proxy_changed_cb (GDBusProxy *proxy, GVariant *changed_properties, GStrv invalidated_properties, gpointer user_data);
G_DEFINE_TYPE (GsdPowerManager, gsd_power_manager, G_TYPE_OBJECT)
@@ -996,6 +997,18 @@ iio_proxy_claim_light (GsdPowerManager *manager, gboolean active)
if (active && !manager->priv->session_is_active)
return;
+ /* FIXME:
+ * Remove when iio-sensor-proxy sends events only to clients instead
+ * of all listeners:
+ * https://github.com/hadess/iio-sensor-proxy/issues/210 */
+ if (active)
+ g_signal_connect (manager->priv->iio_proxy, "g-properties-changed",
+ G_CALLBACK (iio_proxy_changed_cb), manager);
+ else
+ g_signal_handlers_disconnect_by_func (manager->priv->iio_proxy,
+ G_CALLBACK (iio_proxy_changed_cb),
+ manager);
+
if (!g_dbus_proxy_call_sync (manager->priv->iio_proxy,
active ? "ClaimLight" : "ReleaseLight",
NULL,
@@ -2613,8 +2626,6 @@ iio_proxy_appeared_cb (GDBusConnection *connection,
"net.hadess.SensorProxy",
NULL,
NULL);
- g_signal_connect (manager->priv->iio_proxy, "g-properties-changed",
- G_CALLBACK (iio_proxy_changed_cb), manager);
iio_proxy_claim_light (manager, TRUE);
}
--
2.14.3

View File

@ -7,18 +7,19 @@
%global geoclue_version 2.3.1
Name: gnome-settings-daemon
Version: 3.26.2
Release: 5%{?dist}
Version: 3.27.90
Release: 1%{?dist}
Summary: The daemon sharing settings from GNOME to GTK+/KDE applications
License: GPLv2+
URL: https://download.gnome.org/sources/%{name}
Source0: https://download.gnome.org/sources/%{name}/3.26/%{name}-%{version}.tar.xz
# https://bugzilla.redhat.com/show_bug.cgi?id=1322588
# https://bugzilla.gnome.org/show_bug.cgi?id=792409
Patch0: 0001-power-Don-t-react-to-light-changes-if-not-at-console.patch
Source0: https://download.gnome.org/sources/%{name}/3.27/%{name}-%{version}.tar.xz
# Backported from upstream
Patch0: 0001-build-Fix-error-when-doing-non-debug-builds.patch
BuildRequires: cups-devel
BuildRequires: gettext
BuildRequires: meson
BuildRequires: pkgconfig(alsa)
BuildRequires: pkgconfig(colord) >= 1.0.2
BuildRequires: pkgconfig(fontconfig)
@ -44,13 +45,7 @@ BuildRequires: pkgconfig(upower-glib)
BuildRequires: pkgconfig(x11)
BuildRequires: pkgconfig(xi)
BuildRequires: pkgconfig(xtst)
BuildRequires: gettext intltool
BuildRequires: cups-devel
%if 0%{?fedora}
BuildRequires: pkgconfig(wayland-client)
%endif
BuildRequires: libxslt
BuildRequires: docbook-style-xsl
%ifnarch s390 s390x
BuildRequires: pkgconfig(libwacom) >= 0.7
BuildRequires: pkgconfig(xorg-wacom)
@ -93,17 +88,11 @@ developing applications that use %{name}.
%autosetup -p1
%build
%configure --disable-static \
%if 0%{?rhel}
--disable-wayland \
%endif
--enable-profiling
make %{?_smp_mflags}
%meson
%meson_build
%install
%make_install
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%meson_install
%find_lang %{name} --with-gnome
@ -115,9 +104,6 @@ mkdir $RPM_BUILD_ROOT%{_libdir}/gnome-settings-daemon-3.0/gtk-modules
# list daemons explicitly, so we notice if one goes missing
# some of these don't have a separate gschema
%{_libexecdir}/gsd-a11y-keyboard
%{_sysconfdir}/xdg/autostart/org.gnome.SettingsDaemon.A11yKeyboard.desktop
%{_libexecdir}/gsd-clipboard
%{_sysconfdir}/xdg/autostart/org.gnome.SettingsDaemon.Clipboard.desktop
@ -204,6 +190,10 @@ mkdir $RPM_BUILD_ROOT%{_libdir}/gnome-settings-daemon-3.0/gtk-modules
%{_libexecdir}/gsd-test-input-helper
%changelog
* Tue Feb 06 2018 Kalev Lember <klember@redhat.com> - 3.27.90-1
- Update to 3.27.90
- Switch to meson build system
* Mon Feb 05 2018 Kalev Lember <klember@redhat.com> - 3.26.2-5
- Rebuilt for libgweather soname bump

View File

@ -1 +1 @@
SHA512 (gnome-settings-daemon-3.26.2.tar.xz) = 7785ebcb7df466c50557b75a3092f568e375adcf5a40f73e31d5cc69fa63bc556a4447a96e6e612c3bf523735e67168afae0b9c1fab32912d41014436d33b7ff
SHA512 (gnome-settings-daemon-3.27.90.tar.xz) = e371ccbaf3429242cf6447d1166c9e6be512189d25275eeb1017c511a3c187028fd582cd68cf858460ad5d251cb14338b20a24cd29ea92aa4119e58ee66c337d