Fix missing libcommon.so library

Turn libcommon into a static library, similar to how it was with the
autotools build.

This makes gnome-settings-daemon installable again, and makes it
possible for other programs that BR gnome-settings-daemon-devel to
build again.
This commit is contained in:
Kalev Lember 2018-02-07 08:00:51 +01:00
parent 0aee1bbaca
commit d070bdaf18
2 changed files with 19 additions and 1 deletions

View File

@ -8,7 +8,7 @@
Name: gnome-settings-daemon
Version: 3.27.90
Release: 1%{?dist}
Release: 2%{?dist}
Summary: The daemon sharing settings from GNOME to GTK+/KDE applications
License: GPLv2+
@ -16,6 +16,8 @@ URL: https://download.gnome.org/sources/%{name}
Source0: https://download.gnome.org/sources/%{name}/3.27/%{name}-%{version}.tar.xz
# Backported from upstream
Patch0: 0001-build-Fix-error-when-doing-non-debug-builds.patch
# Fix missing libcommon.so library
Patch1: libcommon-static-library.patch
BuildRequires: cups-devel
BuildRequires: gettext
@ -191,6 +193,9 @@ mkdir $RPM_BUILD_ROOT%{_libdir}/gnome-settings-daemon-3.0/gtk-modules
%{_libexecdir}/gsd-test-input-helper
%changelog
* Wed Feb 07 2018 Kalev Lember <klember@redhat.com> - 3.27.90-2
- Fix missing libcommon.so library
* Tue Feb 06 2018 Kalev Lember <klember@redhat.com> - 3.27.90-1
- Update to 3.27.90
- Switch to meson build system

View File

@ -0,0 +1,13 @@
diff --git a/plugins/common/meson.build b/plugins/common/meson.build
index ec54cc1a3d65..f62d5a94a028 100644
--- a/plugins/common/meson.build
+++ b/plugins/common/meson.build
@@ -52,7 +52,7 @@ if enable_wacom
deps += libwacom_dep
endif
-libcommon = shared_module(
+libcommon = static_library(
plugin_name,
sources: sources,
include_directories: [top_inc, data_inc],