- Update to 2.91.4

This commit is contained in:
Bastien Nocera 2010-11-25 13:00:13 +00:00
parent addbdee55b
commit 866ce9cb6a
9 changed files with 6 additions and 137 deletions

1
.gitignore vendored
View File

@ -6,3 +6,4 @@ gnome-settings-daemon-2.31.6.tar.bz2
/gnome-settings-daemon-2.91.2-20101102.tar.bz2
/gnome-settings-daemon-2.91.2.1.tar.bz2
/gnome-settings-daemon-2.91.3.tar.bz2
/gnome-settings-daemon-2.91.4.tar.bz2

View File

@ -1,30 +0,0 @@
From 83ac6c9a151e77dcccfc2582e5a0760f459504e4 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Mon, 22 Mar 2010 15:47:07 +0000
Subject: [PATCH] Disable font plugin by default
The cursor theme for new apps is already loaded by the XSettings
plugin, and the X core fonts are obsoleted by fontconfig. Handling
of new fonts is done in the xsettings plugin as well.
https://bugzilla.gnome.org/show_bug.cgi?id=613604
---
data/gnome-settings-daemon.schemas.in | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/data/gnome-settings-daemon.schemas.in b/data/gnome-settings-daemon.schemas.in
index 16bb71f..139919b 100644
--- a/data/gnome-settings-daemon.schemas.in
+++ b/data/gnome-settings-daemon.schemas.in
@@ -76,7 +76,7 @@
<applyto>/apps/gnome_settings_daemon/plugins/font/active</applyto>
<owner>gnome-settings-daemon</owner>
<type>bool</type>
- <default>TRUE</default>
+ <default>FALSE</default>
<locale name="C">
<short>Enable font plugin</short>
<long>Set to True to enable the plugin to manage font settings.</long>
--
1.7.0.1

View File

@ -1,57 +0,0 @@
--- gnome-settings-daemon-2.31.6/plugins/xrandr/gsd-xrandr-manager.c 2010-08-02 17:54:13.000000000 -0400
+++ foo/plugins/xrandr/gsd-xrandr-manager.c 2010-08-27 14:48:39.506158001 -0400
@@ -684,6 +684,7 @@
/* Turn on the laptop, disable everything else */
GnomeRRConfig *result = gnome_rr_config_new_current (screen);
int i;
+ gboolean all_off = TRUE;
for (i = 0; result->outputs[i] != NULL; ++i) {
GnomeOutputInfo *info = result->outputs[i];
@@ -694,12 +695,18 @@
result = NULL;
break;
}
+ all_off = FALSE;
}
else {
info->on = FALSE;
}
}
+ if (all_off) {
+ gnome_rr_config_free (result);
+ result = NULL;
+ }
+
print_configuration (result, "Laptop setup");
/* FIXME - Maybe we should return NULL if there is more than
@@ -751,6 +758,7 @@
static GnomeRRConfig *
make_other_setup (GnomeRRScreen *screen)
{
+ gboolean all_off = TRUE;
/* Turn off all laptops, and make all external monitors clone
* from (0, 0)
*/
@@ -765,11 +773,18 @@
info->on = FALSE;
}
else {
- if (info->connected)
+ if (info->connected) {
turn_on (screen, info, 0, 0);
+ all_off = FALSE;
+ }
}
}
+ if (all_off) {
+ gnome_rr_config_free (result);
+ result = NULL;
+ }
+
print_configuration (result, "other setup");
return result;

View File

@ -1,12 +0,0 @@
diff -up gnome-settings-daemon-2.31.91/plugins/xrandr/gsd-xrandr-manager.c.capplet gnome-settings-daemon-2.31.91/plugins/xrandr/gsd-xrandr-manager.c
--- gnome-settings-daemon-2.31.91/plugins/xrandr/gsd-xrandr-manager.c.capplet 2010-09-01 14:25:51.121940001 -0400
+++ gnome-settings-daemon-2.31.91/plugins/xrandr/gsd-xrandr-manager.c 2010-09-01 14:26:06.346940001 -0400
@@ -76,7 +76,7 @@
#define GSD_XRANDR_ICON_NAME "gsd-xrandr"
/* executable of the control center's display configuration capplet */
-#define GSD_XRANDR_DISPLAY_CAPPLET "gnome-control-center display"
+#define GSD_XRANDR_DISPLAY_CAPPLET "gnome-display-properties"
#define GSD_DBUS_PATH "/org/gnome/SettingsDaemon"
#define GSD_DBUS_NAME "org.gnome.SettingsDaemon"

View File

@ -1,5 +1,5 @@
Name: gnome-settings-daemon
Version: 2.91.3
Version: 2.91.4
Release: 1%{?dist}
Summary: The daemon sharing settings from GNOME to GTK+/KDE applications
@ -112,6 +112,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
%{_libdir}/pkgconfig/gnome-settings-daemon.pc
%changelog
* Thu Nov 25 2010 Bastien Nocera <bnocera@redhat.com> 2.91.4-1
- Update to 2.91.4
* Wed Nov 17 2010 Richard Hughes <richard@hughsie.com> 2.91.3-1
- Update to 2.91.3

View File

@ -1,12 +0,0 @@
diff -up gnome-settings-daemon-2.31.3/plugins/xrandr/gsd-xrandr-manager.c.display-panel gnome-settings-daemon-2.31.3/plugins/xrandr/gsd-xrandr-manager.c
--- gnome-settings-daemon-2.31.3/plugins/xrandr/gsd-xrandr-manager.c.display-panel 2010-06-16 08:12:53.017980209 -0400
+++ gnome-settings-daemon-2.31.3/plugins/xrandr/gsd-xrandr-manager.c 2010-06-16 08:13:45.060956325 -0400
@@ -76,7 +76,7 @@
#define GSD_XRANDR_ICON_NAME "gsd-xrandr"
/* executable of the control center's display configuration capplet */
-#define GSD_XRANDR_DISPLAY_CAPPLET "gnome-display-properties"
+#define GSD_XRANDR_DISPLAY_CAPPLET "gnome-control-center display"
#define GSD_DBUS_PATH "/org/gnome/SettingsDaemon"
#define GSD_DBUS_NAME "org.gnome.SettingsDaemon"

View File

@ -1,11 +0,0 @@
diff -up gnome-settings-daemon-2.30.1/plugins/keyboard/gsd-keyboard-xkb.c.keyboard-icon gnome-settings-daemon-2.30.1/plugins/keyboard/gsd-keyboard-xkb.c
--- gnome-settings-daemon-2.30.1/plugins/keyboard/gsd-keyboard-xkb.c.keyboard-icon 2010-04-26 08:18:50.000000000 -0400
+++ gnome-settings-daemon-2.30.1/plugins/keyboard/gsd-keyboard-xkb.c 2010-04-26 20:00:30.655778596 -0400
@@ -462,6 +462,7 @@ show_hide_icon ()
xkl_debug (150, "Creating new icon\n");
icon = gkbd_status_new ();
+ gtk_status_icon_set_name (icon, "keyboard");
g_signal_connect (icon, "popup-menu",
G_CALLBACK
(status_icon_popup_menu_cb),

View File

@ -1,13 +0,0 @@
diff -up gnome-settings-daemon-2.31.2/plugins/smartcard/Makefile.am.not-smart gnome-settings-daemon-2.31.2/plugins/smartcard/Makefile.am
--- gnome-settings-daemon-2.31.2/plugins/smartcard/Makefile.am.not-smart 2010-05-06 07:19:56.000000000 -0400
+++ gnome-settings-daemon-2.31.2/plugins/smartcard/Makefile.am 2010-05-27 19:27:18.619425527 -0400
@@ -37,7 +37,9 @@ endif
plugin_in_files = \
smartcard.gnome-settings-plugin.in
+if SMARTCARD_SUPPORT
plugin_DATA = $(plugin_in_files:.gnome-settings-plugin.in=.gnome-settings-plugin)
+endif
EXTRA_DIST = \
$(plugin_in_files)

View File

@ -1 +1 @@
d09334b216e0ad2623026ad8fc52d35c gnome-settings-daemon-2.91.3.tar.bz2
17c6150e5df1eea28612b99d7a16245f gnome-settings-daemon-2.91.4.tar.bz2