Update to 2.91.91

This commit is contained in:
Bastien Nocera 2011-03-08 08:40:48 +00:00
parent 2063955cdc
commit 303468f336
5 changed files with 7 additions and 42 deletions

1
.gitignore vendored
View File

@ -14,3 +14,4 @@ gnome-settings-daemon-2.31.6.tar.bz2
/gnome-settings-daemon-2.91.8.tar.bz2
/gnome-settings-daemon-2.91.9.tar.bz2
/gnome-settings-daemon-2.91.90.tar.bz2
/gnome-settings-daemon-2.91.91.tar.bz2

View File

@ -1,27 +0,0 @@
commit 90c0f8676b06041c599fd941514e09ba8704f0ef
Author: Martin Pitt <martin.pitt@ubuntu.com>
Date: Tue Feb 22 08:35:37 2011 +0100
automount: Fix crash when unlocking screen saver
Fix commit 71deedf: We _do_ expect that some volumes have queued up in
check_volume_queue() once the screen saver got inactive, so don't crash with an
assertion failure in this case.
Just check whether the screen saver is active, and don't mount anything if so.
diff --git a/plugins/automount/gsd-automount-manager.c b/plugins/automount/gsd-automount-manager.c
index 788a5fe..5988f2b 100644
--- a/plugins/automount/gsd-automount-manager.c
+++ b/plugins/automount/gsd-automount-manager.c
@@ -184,8 +184,8 @@ check_volume_queue (GsdAutomountManager *manager)
l = manager->priv->volume_queue;
- if (!manager->priv->screensaver_active) {
- g_assert (l == NULL);
+ if (manager->priv->screensaver_active) {
+ return;
}
while (l != NULL) {

View File

@ -1,12 +0,0 @@
diff -up gnome-settings-daemon-2.91.90/configure.ac.undefined gnome-settings-daemon-2.91.90/configure.ac
--- gnome-settings-daemon-2.91.90/configure.ac.undefined 2011-02-25 22:33:12.551043059 -0500
+++ gnome-settings-daemon-2.91.90/configure.ac 2011-02-25 22:34:05.670378974 -0500
@@ -281,7 +281,7 @@ AC_ARG_ENABLE(packagekit,
if test x$WANT_PACKAGEKIT = xyes ; then
PK_REQUIRED_VERSION=0.6.4
- PKG_CHECK_MODULES(PACKAGEKIT, glib-2.0 packagekit-glib2 >= $PK_REQUIRED_VERSION upower-glib >= 0.9.1,
+ PKG_CHECK_MODULES(PACKAGEKIT, glib-2.0 packagekit-glib2 >= $PK_REQUIRED_VERSION upower-glib >= 0.9.1 gudev-1.0 libnotify >= $LIBNOTIFY_REQUIRED_VERSION,
[have_packagekit=true
AC_DEFINE(HAVE_PACKAGEKIT, 1, [Define if PackageKit should be used])],
[have_packagekit=false])

View File

@ -1,6 +1,6 @@
Name: gnome-settings-daemon
Version: 2.91.90
Release: 4%{?dist}
Version: 2.91.91
Release: 1%{?dist}
Summary: The daemon sharing settings from GNOME to GTK+/KDE applications
Group: System Environment/Daemons
@ -192,6 +192,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
%{_libdir}/pkgconfig/gnome-settings-daemon.pc
%changelog
* Tue Mar 08 2011 Bastien Nocera <bnocera@redhat.com> 2.91.91-1
- Update to 2.91.91
* Fri Feb 25 2011 Matthias Clasen <mclasen@redhat.com> - 2.91.90-4
- Fix undefined symbols in the updates plugin

View File

@ -1 +1 @@
57a65d00ed96a42b2abaa6c21defdfe7 gnome-settings-daemon-2.91.90.tar.bz2
e5aab6a08f57f9336464be8fc39a7f15 gnome-settings-daemon-2.91.91.tar.bz2