Add a patch handling org.gnome.media-handling gsettings schema rename

This commit is contained in:
Owen W. Taylor 2010-11-30 22:30:02 -05:00
parent 1f3db5133b
commit 0de820a1cc
2 changed files with 73 additions and 2 deletions

View File

@ -0,0 +1,65 @@
From cb9a3a0e4144d4fc550877fea8c4c0518fa6c46b Mon Sep 17 00:00:00 2001
From: Owen W. Taylor <otaylor@fishsoup.net>
Date: Tue, 30 Nov 2010 22:22:28 -0500
Subject: [PATCH] autorun: Handle rename of org.gnome.media-handling
When the org.gnome.media-handling schemas was moved to
gsettings-desktop-schemas, it was renamed to
org.gnome.desktop.media-handling.
---
configure.ac | 2 +-
plugins/automount/gsd-automount-manager.c | 2 +-
plugins/automount/nautilus-autorun.c | 4 ++--
3 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/configure.ac b/configure.ac
index 8b3d004..787714a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,7 +66,7 @@ PKG_CHECK_MODULES(SETTINGS_DAEMON,
gmodule-2.0
gthread-2.0
dbus-glib-1 >= $DBUS_GLIB_REQUIRED_VERSION
- gsettings-desktop-schemas >= 0.1.1
+ gsettings-desktop-schemas >= 0.1.2
)
PKG_CHECK_MODULES(SETTINGS_PLUGIN,
diff --git a/plugins/automount/gsd-automount-manager.c b/plugins/automount/gsd-automount-manager.c
index d3a7e93..9836dff 100644
--- a/plugins/automount/gsd-automount-manager.c
+++ b/plugins/automount/gsd-automount-manager.c
@@ -217,7 +217,7 @@ gsd_automount_manager_start (GsdAutomountManager *manager,
g_debug ("Starting automounting manager");
gnome_settings_profile_start (NULL);
- manager->priv->settings = g_settings_new ("org.gnome.media-handling");
+ manager->priv->settings = g_settings_new ("org.gnome.desktop.media-handling");
setup_automounter (manager);
gnome_settings_profile_end (NULL);
diff --git a/plugins/automount/nautilus-autorun.c b/plugins/automount/nautilus-autorun.c
index eed336d..9d44c53 100644
--- a/plugins/automount/nautilus-autorun.c
+++ b/plugins/automount/nautilus-autorun.c
@@ -196,7 +196,7 @@ nautilus_autorun_get_preferences (const char *x_content_type,
g_return_if_fail (pref_ignore != NULL);
g_return_if_fail (pref_open_folder != NULL);
- settings = g_settings_new ("org.gnome.media-handling");
+ settings = g_settings_new ("org.gnome.desktop.media-handling");
*pref_start_app = FALSE;
*pref_ignore = FALSE;
@@ -277,7 +277,7 @@ nautilus_autorun_set_preferences (const char *x_content_type,
g_assert (x_content_type != NULL);
- settings = g_settings_new ("org.gnome.media-handling");
+ settings = g_settings_new ("org.gnome.desktop.media-handling");
x_content_start_app = g_settings_get_strv (settings, "autorun-x-content-start-app");
x_content_ignore = g_settings_get_strv (settings, "autorun-x-content-ignore");
--
1.7.3.2

View File

@ -1,6 +1,6 @@
Name: gnome-settings-daemon
Version: 2.91.5
Release: 1%{?dist}
Release: 2%{?dist}
Summary: The daemon sharing settings from GNOME to GTK+/KDE applications
Group: System Environment/Daemons
@ -30,10 +30,11 @@ BuildRequires: libcanberra-devel
BuildRequires: polkit-devel
BuildRequires: autoconf automake libtool
BuildRequires: libxklavier-devel
BuildRequires: gsettings-desktop-schemas-devel >= 0.0.2
BuildRequires: gsettings-desktop-schemas-devel >= 0.1.2
# change font rendering
#Patch3: slight-hinting.patch
Patch4: autorun-Handle-rename-of-org.gnome.media-handling.patch
%description
A daemon to share settings from GNOME to other applications. It also
@ -52,6 +53,8 @@ developing applications that use %{name}.
%prep
%setup -q
#%patch3 -p1 -b .slight-hinting
# Upstream commit cb9a3a0e4144d
%patch4 -p1 -b .media-handling
%build
# https://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking
@ -112,6 +115,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
%{_libdir}/pkgconfig/gnome-settings-daemon.pc
%changelog
* Tue Nov 30 2010 Owen Taylor <otaylor@redhat.com> - 2.91.5-2
- Add a patch handling org.gnome.media-handling gsettings schema rename
* Tue Nov 30 2010 Tomas Bzatek <tbzatek@redhat.com> 2.91.5-1
- Update to 2.91.5