add upstream patch that disables wacom support on s390(x)
This commit is contained in:
parent
0de3cf0e42
commit
00884d54fa
@ -1,6 +1,6 @@
|
|||||||
Name: gnome-settings-daemon
|
Name: gnome-settings-daemon
|
||||||
Version: 3.4.1
|
Version: 3.4.1
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: The daemon sharing settings from GNOME to GTK+/KDE applications
|
Summary: The daemon sharing settings from GNOME to GTK+/KDE applications
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
@ -11,6 +11,8 @@ Source: http://download.gnome.org/sources/%{name}/3.4/%{name}-%{version}
|
|||||||
|
|
||||||
# Fedora specific patch
|
# Fedora specific patch
|
||||||
Patch0: gsd-calculator.patch
|
Patch0: gsd-calculator.patch
|
||||||
|
# http://git.gnome.org/browse/gnome-settings-daemon/commit/?id=fedb2be311b69c9dd12ada94047c82a28e73df47
|
||||||
|
Patch1: gsd-wacom.patch
|
||||||
|
|
||||||
Requires: control-center-filesystem
|
Requires: control-center-filesystem
|
||||||
|
|
||||||
@ -63,6 +65,7 @@ developing applications that use %{name}.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .calc
|
%patch0 -p1 -b .calc
|
||||||
|
%patch1 -p1 -b .wacom
|
||||||
|
|
||||||
autoreconf -i -f
|
autoreconf -i -f
|
||||||
|
|
||||||
@ -153,10 +156,11 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
|||||||
%{_libdir}/gnome-settings-daemon-3.0/libupdates.so
|
%{_libdir}/gnome-settings-daemon-3.0/libupdates.so
|
||||||
%{_datadir}/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.xml
|
%{_datadir}/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.xml
|
||||||
|
|
||||||
|
%{_datadir}/glib-2.0/schemas/org.gnome.settings-daemon.peripherals.gschema.xml
|
||||||
|
|
||||||
%ifnarch s390 s390x %{?rhel:ppc ppc64}
|
%ifnarch s390 s390x %{?rhel:ppc ppc64}
|
||||||
%{_libdir}/gnome-settings-daemon-3.0/wacom.gnome-settings-plugin
|
%{_libdir}/gnome-settings-daemon-3.0/wacom.gnome-settings-plugin
|
||||||
%{_libdir}/gnome-settings-daemon-3.0/libgsdwacom.so
|
%{_libdir}/gnome-settings-daemon-3.0/libgsdwacom.so
|
||||||
%{_datadir}/glib-2.0/schemas/org.gnome.settings-daemon.peripherals.gschema.xml
|
|
||||||
%{_datadir}/glib-2.0/schemas/org.gnome.settings-daemon.peripherals.wacom.gschema.xml
|
%{_datadir}/glib-2.0/schemas/org.gnome.settings-daemon.peripherals.wacom.gschema.xml
|
||||||
%{_libexecdir}/gsd-wacom-led-helper
|
%{_libexecdir}/gsd-wacom-led-helper
|
||||||
%{_datadir}/polkit-1/actions/org.gnome.settings-daemon.plugins.wacom.policy
|
%{_datadir}/polkit-1/actions/org.gnome.settings-daemon.plugins.wacom.policy
|
||||||
@ -211,6 +215,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
|||||||
%{_datadir}/gnome-settings-daemon-3.0/input-device-example.sh
|
%{_datadir}/gnome-settings-daemon-3.0/input-device-example.sh
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 24 2012 Dan Horák <dan[at]danny.cz> - 3.4.1-3
|
||||||
|
- add upstream patch that disables wacom support on s390(x)
|
||||||
|
|
||||||
* Thu Apr 19 2012 Matthias Clasen <mclasen@redhat.com> - 3.4.1-2
|
* Thu Apr 19 2012 Matthias Clasen <mclasen@redhat.com> - 3.4.1-2
|
||||||
- Fix build on s390 (patch by Bill Nottingham)
|
- Fix build on s390 (patch by Bill Nottingham)
|
||||||
|
|
||||||
|
89
gsd-wacom.patch
Normal file
89
gsd-wacom.patch
Normal file
@ -0,0 +1,89 @@
|
|||||||
|
commit fedb2be311b69c9dd12ada94047c82a28e73df47
|
||||||
|
Author: Dan Horák <dan@danny.cz>
|
||||||
|
Date: Wed Mar 21 18:40:06 2012 +0100
|
||||||
|
|
||||||
|
disable wacom support on s390/s390x
|
||||||
|
|
||||||
|
https://bugzilla.gnome.org/show_bug.cgi?id=672576
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index d6d1cb8..f73583e 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -197,10 +197,16 @@ dnl ---------------------------------------------------------------------------
|
||||||
|
PKG_CHECK_MODULES(COLOR, [colord >= 0.1.9 gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION libcanberra-gtk3])
|
||||||
|
|
||||||
|
dnl ---------------------------------------------------------------------------
|
||||||
|
-dnl - wacom
|
||||||
|
+dnl - wacom (disabled for s390/s390x)
|
||||||
|
dnl ---------------------------------------------------------------------------
|
||||||
|
|
||||||
|
-PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst $GUDEV_PKG gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION xorg-wacom])
|
||||||
|
+if test "$host_cpu" = s390 -o "$host_cpu" = s390x; then
|
||||||
|
+ have_wacom=no
|
||||||
|
+else
|
||||||
|
+ PKG_CHECK_MODULES(WACOM, [libwacom >= $LIBWACOM_REQUIRED_VERSION x11 xi xtst $GUDEV_PKG gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION xorg-wacom])
|
||||||
|
+ have_wacom=yes
|
||||||
|
+fi
|
||||||
|
+AM_CONDITIONAL(HAVE_WACOM, test x$have_wacom = xyes)
|
||||||
|
|
||||||
|
dnl ==============================================
|
||||||
|
dnl PackageKit section
|
||||||
|
@@ -508,6 +514,7 @@ echo "
|
||||||
|
PackageKit support: ${have_packagekit}
|
||||||
|
Smartcard support: ${have_smartcard_support}
|
||||||
|
Cups support: ${have_cups}
|
||||||
|
+ Wacom support: ${have_wacom}
|
||||||
|
${NSS_DATABASE:+\
|
||||||
|
System nssdb: ${NSS_DATABASE}
|
||||||
|
}\
|
||||||
|
diff --git a/data/Makefile.am b/data/Makefile.am
|
||||||
|
index 19decc2..5af5170 100644
|
||||||
|
--- a/data/Makefile.am
|
||||||
|
+++ b/data/Makefile.am
|
||||||
|
@@ -16,7 +16,6 @@ gsettings_SCHEMAS = \
|
||||||
|
org.gnome.settings-daemon.plugins.xsettings.gschema.xml \
|
||||||
|
org.gnome.settings-daemon.plugins.housekeeping.gschema.xml \
|
||||||
|
org.gnome.settings-daemon.plugins.print-notifications.gschema.xml \
|
||||||
|
- org.gnome.settings-daemon.peripherals.wacom.gschema.xml \
|
||||||
|
org.gnome.settings-daemon.plugins.xrandr.gschema.xml
|
||||||
|
|
||||||
|
all_schemas = $(gsettings_SCHEMAS)
|
||||||
|
@@ -33,6 +32,12 @@ else
|
||||||
|
all_schemas += org.gnome.settings-daemon.plugins.orientation.gschema.xml
|
||||||
|
endif
|
||||||
|
|
||||||
|
+if HAVE_WACOM
|
||||||
|
+gsettings_SCHEMAS += org.gnome.settings-daemon.peripherals.wacom.gschema.xml
|
||||||
|
+else
|
||||||
|
+all_schemas += org.gnome.settings-daemon.peripherals.wacom.gschema.xml
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
@INTLTOOL_XML_NOMERGE_RULE@
|
||||||
|
|
||||||
|
@GSETTINGS_RULES@
|
||||||
|
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
|
||||||
|
index 2b7566a..a4aa666 100644
|
||||||
|
--- a/plugins/Makefile.am
|
||||||
|
+++ b/plugins/Makefile.am
|
||||||
|
@@ -15,7 +15,6 @@ enabled_plugins = \
|
||||||
|
media-keys \
|
||||||
|
mouse \
|
||||||
|
sound \
|
||||||
|
- wacom \
|
||||||
|
xrandr \
|
||||||
|
xsettings \
|
||||||
|
$(NULL)
|
||||||
|
@@ -40,6 +39,12 @@ else
|
||||||
|
disabled_plugins += orientation
|
||||||
|
endif
|
||||||
|
|
||||||
|
+if HAVE_WACOM
|
||||||
|
+enabled_plugins += wacom
|
||||||
|
+else
|
||||||
|
+disabled_plugins += wacom
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
if BUILD_PRINT_NOTIFICATIONS
|
||||||
|
enabled_plugins += print-notifications
|
||||||
|
else
|
Loading…
Reference in New Issue
Block a user