try again

This commit is contained in:
Matthias Clasen 2007-07-27 20:27:16 +00:00
parent 120d0bbbd3
commit 7ade5c3e4d
2 changed files with 29 additions and 11 deletions

View File

@ -56,7 +56,7 @@ and start the keyring daemon.
%build
autoreconf
%configure --disable-gtk-doc
%configure --disable-gtk-doc --with-pam-dir=/lib/security
make %{?_smp_mflags}
%install

View File

@ -1,6 +1,6 @@
diff -up gnome-keyring-2.19.6/pam/Makefile.am.pam gnome-keyring-2.19.6/pam/Makefile.am
--- gnome-keyring-2.19.6/pam/Makefile.am.pam 2007-07-21 22:01:42.000000000 -0400
+++ gnome-keyring-2.19.6/pam/Makefile.am 2007-07-27 15:53:39.000000000 -0400
+++ gnome-keyring-2.19.6/pam/Makefile.am 2007-07-27 15:55:41.000000000 -0400
@@ -17,9 +17,10 @@ pam_gnome_keyring_la_LIBADD = \
pam_gnome_keyring_la_LDFLAGS = -module -avoid-version
@ -17,14 +17,32 @@ diff -up gnome-keyring-2.19.6/pam/Makefile.am.pam gnome-keyring-2.19.6/pam/Makef
rm -f $(PAM_DEST_DIR)/pam_gnome_keyring.so
diff -up gnome-keyring-2.19.6/configure.in.pam gnome-keyring-2.19.6/configure.in
--- gnome-keyring-2.19.6/configure.in.pam 2007-07-24 23:05:32.000000000 -0400
+++ gnome-keyring-2.19.6/configure.in 2007-07-27 15:50:47.000000000 -0400
@@ -238,6 +238,9 @@ if test "$enable_pam" != "no"; then
+++ gnome-keyring-2.19.6/configure.in 2007-07-27 16:22:55.000000000 -0400
@@ -236,18 +236,15 @@ if test "$enable_pam" != "no"; then
if test "$enable_pam" = "yes" -a "$have_pam" = "no"; then
AC_MSG_ERROR(The PAM headers are missing)
fi
-
- case "$host" in
- *-*-linux*)
- # See also <configure-flags> in pam_mount.xml.
- PAM_DEST_DIR="\$(prefix)/../lib/security"
- ;;
- *)
- PAM_DEST_DIR="/usr/lib"
- ;;
- esac
- AC_SUBST(PAM_DEST_DIR)
-fi
+fi
+
+AC_ARG_WITH ([pam-dir],
+ AC_HELP_STRING([--with-pam-dir=DIR],
+ [directory to install pam modules in]),,
+ [with_pam_dir=/usr/lib])
+PAM_DEST_DIR="$with_pam_dir"
+AC_SUBST(PAM_DEST_DIR)
+
case "$host" in
+ *-redhat-linux-gnu)
+ PAM_DEST_DIR="/lib/security"
+ ;;
*-*-linux*)
# See also <configure-flags> in pam_mount.xml.
PAM_DEST_DIR="\$(prefix)/../lib/security"
AM_CONDITIONAL(WITH_PAM, test "$have_pam" = "yes")