Avoid undefined symbols

This commit is contained in:
Matthias Clasen 2007-10-09 16:19:37 +00:00
parent 648313fd03
commit 5bca71ed63
2 changed files with 36 additions and 1 deletions

View File

@ -0,0 +1,30 @@
diff -up gnome-keyring-2.20/configure.in.link-against-pam gnome-keyring-2.20/configure.in
--- gnome-keyring-2.20/configure.in.link-against-pam 2007-10-09 12:14:32.000000000 -0400
+++ gnome-keyring-2.20/configure.in 2007-10-09 12:15:15.000000000 -0400
@@ -243,6 +243,13 @@ if test "$enable_pam" != "no"; then
AC_CHECK_HEADER(security/pam_modules.h, have_pam=yes, have_pam=no)
if test "$enable_pam" = "yes" -a "$have_pam" = "no"; then
AC_MSG_ERROR(The PAM headers are missing)
+ elif test "$have_pam" = "yes"; then
+ old_LIBS=$LIBS
+ AC_CHECK_LIB(pam, pam_start, have_pam=yes, have_pam=no)
+ if test "$enable_pam" = "yes" -a "$have_pam" = "no"; then
+ AC_MSG_ERROR(The PAM library is missing)
+ fi
+ LIBS=$old_LIBS
fi
fi
diff -up gnome-keyring-2.20/pam/Makefile.am.link-against-pam gnome-keyring-2.20/pam/Makefile.am
--- gnome-keyring-2.20/pam/Makefile.am.link-against-pam 2007-10-09 12:14:45.000000000 -0400
+++ gnome-keyring-2.20/pam/Makefile.am 2007-10-09 12:14:56.000000000 -0400
@@ -12,7 +12,8 @@ pam_gnome_keyring_la_SOURCES = \
gkr-pam-stubs.c
pam_gnome_keyring_la_LIBADD = \
- $(top_builddir)/common/libgkr-module-common.la
+ $(top_builddir)/common/libgkr-module-common.la \
+ -lpam
pam_gnome_keyring_la_LDFLAGS = \
-module -avoid-version \

View File

@ -3,7 +3,7 @@
Summary: A framework for managing user passwords and other secrets
Name: gnome-keyring
Version: 2.20
Release: 5%{?dist}
Release: 6%{?dist}
License: GPLv2+ and LGPLv2+
Group: System Environment/Libraries
Source: http://download.gnome.org/sources/gnome-keyring/2.20/gnome-keyring-%{version}.tar.bz2
@ -24,6 +24,7 @@ Patch1: gnome-keyring-2.20-add_new_keyrings.patch
Patch2: gnome-keyring-2.20-no-unset-default.patch
Patch3: gnome-keyring-2.20-no_match.patch
Patch4: gnome-keyring-2.20-selinux-pam.patch
Patch5: gnome-keyring-2.20-link-against-pam.patch
%description
gnome-keyring manages passwords and other types of secrets
@ -67,6 +68,7 @@ and start the keyring daemon.
%patch2 -p1 -b .no_unset_default
%patch3 -p0 -b .no_match
%patch4 -p1 -b .selinux_pam
%patch5 -p1 -b .link-against-pam
%build
aclocal
@ -113,6 +115,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Tue Oct 9 2007 Matthias Clasen <mclasen@redhat.com> - 2.20-6
- Avoid undefined symbols in the pam module
* Mon Oct 8 2007 Alexander Larsson <alexl@redhat.com> - 2.20-5
- Fixed minor issue with pam-selinux issue pointed out by stef