This commit is contained in:
Matthias Clasen 2010-08-31 19:41:36 -04:00
parent 10af894a41
commit 2c91fc77d8
2 changed files with 23 additions and 10 deletions

View File

@ -15,6 +15,8 @@ Group: System Environment/Libraries
Source: http://download.gnome.org/sources/gnome-keyring/2.31/gnome-keyring-%{version}.tar.bz2
URL: http://www.gnome.org
# https://bugzilla.gnome.org/show_bug.cgi?id=628457
Patch0: pam-headers.patch
BuildRequires: glib2-devel >= %{glib2_version}
BuildRequires: gtk2-devel >= %{gtk2_version}
@ -67,6 +69,8 @@ automatically unlock the "login" keyring when the user logs in.
%prep
%setup -q -n gnome-keyring-%{version}
%patch0 -p1 -b .pam-headers
# Enable daemon autostart in XFCE
for i in daemon/*.desktop.in.in; do
@ -75,13 +79,12 @@ done
%build
libtoolize --force || :
aclocal || :
autoheader || :
automake || :
autoconf || :
autoreconf -i -f
%configure --disable-gtk-doc --with-pam-dir=/%{_lib}/security --disable-acl-prompts
%configure --disable-gtk-doc \
--with-pam-dir=/%{_lib}/security \
--disable-acl-prompts \
--enable-pam
# avoid unneeded direct dependencies
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' libtool
@ -90,7 +93,7 @@ make %{?_smp_mflags}
%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make install install-pam DESTDIR=$RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
rm $RPM_BUILD_ROOT/%{_lib}/security/*.la
@ -103,10 +106,9 @@ rm $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/standalone/*.la
%post
/sbin/ldconfig
%gconf_schema_upgrade gnome-keyring
%pre
%gconf_schema_prepare gnome-keyring
%gconf_schema_obsolete gnome-keyring
%preun
%gconf_schema_remove gnome-keyring
@ -128,7 +130,6 @@ rm $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/standalone/*.la
%{_datadir}/dbus-1/services/*.service
%{_datadir}/gcr
%{_datadir}/gnome-keyring
%{_sysconfdir}/gconf/schemas/gnome-keyring.schemas
%{_sysconfdir}/xdg/autostart/*
%files devel

12
pam-headers.patch Normal file
View File

@ -0,0 +1,12 @@
diff -up gnome-keyring-2.31.91/configure.in.pam-headers gnome-keyring-2.31.91/configure.in
--- gnome-keyring-2.31.91/configure.in.pam-headers 2010-08-31 19:23:16.091743002 -0400
+++ gnome-keyring-2.31.91/configure.in 2010-08-31 19:23:44.418743001 -0400
@@ -251,7 +251,7 @@ AC_ARG_ENABLE(pam,
pam_status="no"
if test "$enable_pam" != "no"; then
- AC_CHECK_HEADERS(security/pam_modules.h pam/pam_modules.h, have_pam=yes, have_pam=no)
+ AC_CHECK_HEADERS(security/pam_modules.h pam/pam_modules.h, [have_pam=yes; break], have_pam=no)
if test "$enable_pam" = "yes" -a "$have_pam" = "no"; then
AC_MSG_ERROR(The PAM headers are missing)
elif test "$have_pam" = "yes"; then