Initial import (#1565671)
This commit is contained in:
parent
81863f32ef
commit
257f539bcf
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
/gnome-control-center-3.28.1.tar.xz
|
99
distro-logo.patch
Normal file
99
distro-logo.patch
Normal file
@ -0,0 +1,99 @@
|
||||
From 73be5fcb0764cb8e7bdcbcf3ee06b833078d576a Mon Sep 17 00:00:00 2001
|
||||
From: Matthias Clasen <mclasen@redhat.com>
|
||||
Date: Sun, 31 Mar 2013 20:28:19 -0400
|
||||
Subject: [PATCH] info: Switch around GNOME and distro information
|
||||
|
||||
This makes the distribution logo prominent, and puts GNOME version
|
||||
information in the small print.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=695691
|
||||
---
|
||||
panels/info/cc-info-overview-panel.c | 7 ++-----
|
||||
panels/info/info-overview.ui | 14 ++++++++------
|
||||
2 files changed, 10 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/panels/info/cc-info-overview-panel.c b/panels/info/cc-info-overview-panel.c
|
||||
index 7a5879c6b..ce15e92d0 100644
|
||||
--- a/panels/info/cc-info-overview-panel.c
|
||||
+++ b/panels/info/cc-info-overview-panel.c
|
||||
@@ -446,7 +446,7 @@ static char *
|
||||
get_os_name (void)
|
||||
{
|
||||
GHashTable *os_info;
|
||||
- gchar *name, *version_id, *pretty_name, *build_id;
|
||||
+ gchar *name, *version_id, *build_id;
|
||||
gchar *result = NULL;
|
||||
g_autofree gchar *name_version = NULL;
|
||||
|
||||
@@ -457,12 +457,9 @@ get_os_name (void)
|
||||
|
||||
name = g_hash_table_lookup (os_info, "NAME");
|
||||
version_id = g_hash_table_lookup (os_info, "VERSION_ID");
|
||||
- pretty_name = g_hash_table_lookup (os_info, "PRETTY_NAME");
|
||||
build_id = g_hash_table_lookup (os_info, "BUILD_ID");
|
||||
|
||||
- if (pretty_name)
|
||||
- name_version = g_strdup (pretty_name);
|
||||
- else if (name && version_id)
|
||||
+ if (name && version_id)
|
||||
name_version = g_strdup_printf ("%s %s", name, version_id);
|
||||
else
|
||||
name_version = g_strdup (_("Unknown"));
|
||||
diff --git a/panels/info/info-overview.ui b/panels/info/info-overview.ui
|
||||
index 219a83c4c..aa87fbec2 100644
|
||||
--- a/panels/info/info-overview.ui
|
||||
+++ b/panels/info/info-overview.ui
|
||||
@@ -12,13 +12,14 @@
|
||||
<object class="GtkBox">
|
||||
<property name="visible">True</property>
|
||||
<property name="can_focus">False</property>
|
||||
- <property name="spacing">18</property>
|
||||
+ <property name="spacing">6</property>
|
||||
<property name="orientation">vertical</property>
|
||||
<child>
|
||||
<object class="GtkImage" id="system_image">
|
||||
<property name="visible">True</property>
|
||||
<property name="can_focus">False</property>
|
||||
- <property name="resource">/org/gnome/control-center/info/GnomeLogoVerticalMedium.svg</property>
|
||||
+ <property name="pixel_size">128</property>
|
||||
+ <property name="icon_name">fedora-logo-icon</property>
|
||||
</object>
|
||||
<packing>
|
||||
<property name="expand">False</property>
|
||||
@@ -27,11 +28,12 @@
|
||||
</packing>
|
||||
</child>
|
||||
<child>
|
||||
- <object class="GtkLabel" id="version_label">
|
||||
+ <object class="GtkLabel" id="os_name_label">
|
||||
<property name="visible">True</property>
|
||||
<property name="can_focus">False</property>
|
||||
<property name="label">Version 3.0</property>
|
||||
<property name="selectable">True</property>
|
||||
+ <property name="margin-bottom">24</property>
|
||||
<attributes>
|
||||
<attribute name="scale" value="1.25"/>
|
||||
</attributes>
|
||||
@@ -118,8 +120,8 @@
|
||||
<property name="visible">True</property>
|
||||
<property name="can_focus">False</property>
|
||||
<property name="xalign">1</property>
|
||||
- <property name="label" translatable="yes" comments="To translators: this field contains the distro name and version">OS name</property>
|
||||
- <property name="mnemonic_widget">os_name_label</property>
|
||||
+ <property name="label">GNOME</property>
|
||||
+ <property name="mnemonic_widget">version_label</property>
|
||||
<style>
|
||||
<class name="dim-label"/>
|
||||
</style>
|
||||
@@ -228,7 +230,7 @@
|
||||
</packing>
|
||||
</child>
|
||||
<child>
|
||||
- <object class="GtkLabel" id="os_name_label">
|
||||
+ <object class="GtkLabel" id="version_label">
|
||||
<property name="visible">True</property>
|
||||
<property name="can_focus">False</property>
|
||||
<property name="xalign">0</property>
|
||||
--
|
||||
2.13.0
|
||||
|
186
gnome-control-center.spec
Normal file
186
gnome-control-center.spec
Normal file
@ -0,0 +1,186 @@
|
||||
%define gnome_online_accounts_version 3.25.3
|
||||
%define glib2_version 2.53.0
|
||||
%define gnome_desktop_version 3.27.90
|
||||
%define gsd_version 3.25.90
|
||||
%define gsettings_desktop_schemas_version 3.27.2
|
||||
%define gtk3_version 3.22.20
|
||||
%define gnome_bluetooth_version 3.18.2
|
||||
|
||||
Name: gnome-control-center
|
||||
Version: 3.28.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Utilities to configure the GNOME desktop
|
||||
|
||||
License: GPLv2+ and CC-BY-SA
|
||||
URL: http://www.gnome.org
|
||||
Source0: https://download.gnome.org/sources/gnome-control-center/3.28/gnome-control-center-%{version}.tar.xz
|
||||
|
||||
# https://bugzilla.gnome.org/show_bug.cgi?id=695691
|
||||
Patch0: distro-logo.patch
|
||||
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: cups-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: docbook-style-xsl libxslt
|
||||
BuildRequires: gettext
|
||||
BuildRequires: libXxf86misc-devel
|
||||
BuildRequires: meson
|
||||
BuildRequires: pkgconfig(accountsservice)
|
||||
BuildRequires: pkgconfig(cheese-gtk)
|
||||
BuildRequires: pkgconfig(clutter-gtk-1.0)
|
||||
BuildRequires: pkgconfig(colord)
|
||||
BuildRequires: pkgconfig(colord-gtk)
|
||||
BuildRequires: pkgconfig(gdk-pixbuf-2.0)
|
||||
BuildRequires: pkgconfig(gdk-wayland-3.0)
|
||||
BuildRequires: pkgconfig(gio-2.0) >= %{glib2_version}
|
||||
BuildRequires: pkgconfig(gnome-desktop-3.0) >= %{gnome_desktop_version}
|
||||
BuildRequires: pkgconfig(gnome-settings-daemon) >= %{gsd_version}
|
||||
BuildRequires: pkgconfig(goa-1.0) >= %{gnome_online_accounts_version}
|
||||
BuildRequires: pkgconfig(goa-backend-1.0)
|
||||
BuildRequires: pkgconfig(grilo-0.3)
|
||||
BuildRequires: pkgconfig(gsettings-desktop-schemas) >= %{gsettings_desktop_schemas_version}
|
||||
BuildRequires: pkgconfig(gtk+-3.0) >= %{gtk3_version}
|
||||
BuildRequires: pkgconfig(gudev-1.0)
|
||||
BuildRequires: pkgconfig(ibus-1.0)
|
||||
BuildRequires: pkgconfig(libcanberra-gtk3)
|
||||
BuildRequires: pkgconfig(libgtop-2.0)
|
||||
BuildRequires: pkgconfig(libnm)
|
||||
BuildRequires: pkgconfig(libnma)
|
||||
BuildRequires: pkgconfig(libpulse)
|
||||
BuildRequires: pkgconfig(libpulse-mainloop-glib)
|
||||
BuildRequires: pkgconfig(libsoup-2.4)
|
||||
BuildRequires: pkgconfig(libxml-2.0)
|
||||
BuildRequires: pkgconfig(mm-glib)
|
||||
BuildRequires: pkgconfig(NetworkManager)
|
||||
BuildRequires: pkgconfig(polkit-gobject-1)
|
||||
BuildRequires: pkgconfig(pwquality)
|
||||
BuildRequires: pkgconfig(smbclient)
|
||||
BuildRequires: pkgconfig(upower-glib)
|
||||
BuildRequires: pkgconfig(x11)
|
||||
BuildRequires: pkgconfig(xi)
|
||||
%ifnarch s390 s390x
|
||||
BuildRequires: pkgconfig(gnome-bluetooth-1.0) >= %{gnome_bluetooth_version}
|
||||
BuildRequires: pkgconfig(libwacom)
|
||||
%endif
|
||||
|
||||
# Versioned library deps
|
||||
Requires: glib2%{?_isa} >= %{glib2_version}
|
||||
Requires: gnome-desktop3%{?_isa} >= %{gnome_desktop_version}
|
||||
Requires: gnome-online-accounts%{?_isa} >= %{gnome_online_accounts_version}
|
||||
Requires: gnome-settings-daemon%{?_isa} >= %{gsd_version}
|
||||
Requires: gsettings-desktop-schemas%{?_isa} >= %{gsettings_desktop_schemas_version}
|
||||
Requires: gtk3%{?_isa} >= %{gtk3_version}
|
||||
%ifnarch s390 s390x
|
||||
Requires: gnome-bluetooth%{?_isa} >= 1:%{gnome_bluetooth_version}
|
||||
%endif
|
||||
|
||||
Requires: %{name}-filesystem = %{version}-%{release}
|
||||
# For user accounts
|
||||
Requires: accountsservice
|
||||
Requires: alsa-lib
|
||||
# For the color panel
|
||||
Requires: colord
|
||||
# For the printers panel
|
||||
Requires: cups-pk-helper
|
||||
Requires: dbus-x11
|
||||
# For the info/details panel
|
||||
Requires: glx-utils
|
||||
# For the user languages
|
||||
Requires: iso-codes
|
||||
# For the network panel
|
||||
Requires: nm-connection-editor
|
||||
Requires: NetworkManager-wifi
|
||||
%if 0%{?fedora}
|
||||
# For the sharing panel
|
||||
Requires: rygel
|
||||
%endif
|
||||
# For the info/details panel
|
||||
Requires: switcheroo-control
|
||||
Requires: vino
|
||||
# For the keyboard panel
|
||||
Requires: /usr/bin/gkbd-keyboard-display
|
||||
|
||||
# Renamed in F28
|
||||
Provides: control-center = 1:%{version}-%{release}
|
||||
Provides: control-center%{?_isa} = 1:%{version}-%{release}
|
||||
Obsoletes: control-center < 1:%{version}-%{release}
|
||||
|
||||
%description
|
||||
This package contains configuration utilities for the GNOME desktop, which
|
||||
allow to configure accessibility options, desktop fonts, keyboard and mouse
|
||||
properties, sound setup, desktop theme and background, user interface
|
||||
properties, screen resolution, and other settings.
|
||||
|
||||
%package filesystem
|
||||
Summary: GNOME Control Center directories
|
||||
# NOTE: this is an "inverse dep" subpackage. It gets pulled in
|
||||
# NOTE: by the main package and MUST not depend on the main package
|
||||
BuildArch: noarch
|
||||
# Renamed in F28
|
||||
Provides: control-center-filesystem = 1:%{version}-%{release}
|
||||
Provides: control-center-filesystem%{?_isa} = 1:%{version}-%{release}
|
||||
Obsoletes: control-center-filesystem < 1:%{version}-%{release}
|
||||
|
||||
%description filesystem
|
||||
The GNOME control-center provides a number of extension points
|
||||
for applications. This package contains directories where applications
|
||||
can install configuration files that are picked up by the control-center
|
||||
utilities.
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
%meson -Ddocumentation=true
|
||||
%meson_build
|
||||
|
||||
%install
|
||||
%meson_install
|
||||
|
||||
# We do want this
|
||||
mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome/wm-properties
|
||||
|
||||
# We don't want these
|
||||
rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/autostart
|
||||
rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/cursor-fonts
|
||||
|
||||
# Remove rpath
|
||||
chrpath --delete $RPM_BUILD_ROOT%{_bindir}/gnome-control-center
|
||||
|
||||
%find_lang %{name} --all-name --with-gnome
|
||||
|
||||
%files -f %{name}.lang
|
||||
%license COPYING
|
||||
%doc AUTHORS NEWS README
|
||||
%{_bindir}/gnome-control-center
|
||||
%{_datadir}/applications/*.desktop
|
||||
%{_datadir}/bash-completion/completions/gnome-control-center
|
||||
%{_datadir}/dbus-1/services/org.gnome.ControlCenter.SearchProvider.service
|
||||
%{_datadir}/dbus-1/services/org.gnome.ControlCenter.service
|
||||
%{_datadir}/gettext/
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.ControlCenter.gschema.xml
|
||||
%{_datadir}/gnome-control-center/icons/
|
||||
%{_datadir}/gnome-control-center/keybindings/*.xml
|
||||
%{_datadir}/gnome-control-center/pixmaps
|
||||
%{_datadir}/gnome-control-center/sounds/gnome-sounds-default.xml
|
||||
%{_datadir}/gnome-shell/search-providers/gnome-control-center-search-provider.ini
|
||||
%{_datadir}/icons/hicolor/*/*/*
|
||||
%{_datadir}/man/man1/gnome-control-center.1*
|
||||
%{_datadir}/metainfo/gnome-control-center.appdata.xml
|
||||
%{_datadir}/pixmaps/faces
|
||||
%{_datadir}/pkgconfig/gnome-keybindings.pc
|
||||
%{_datadir}/polkit-1/actions/org.gnome.controlcenter.*.policy
|
||||
%{_datadir}/polkit-1/rules.d/gnome-control-center.rules
|
||||
%{_datadir}/sounds/gnome/default/*/*.ogg
|
||||
%{_libexecdir}/cc-remote-login-helper
|
||||
%{_libexecdir}/gnome-control-center-search-provider
|
||||
|
||||
%files filesystem
|
||||
%dir %{_datadir}/gnome-control-center
|
||||
%dir %{_datadir}/gnome-control-center/keybindings
|
||||
%dir %{_datadir}/gnome-control-center/sounds
|
||||
%dir %{_datadir}/gnome/wm-properties
|
||||
|
||||
%changelog
|
||||
* Tue Apr 10 2018 Pete Walter <pwalter@fedoraproject.org> - 3.28.1-1
|
||||
- Rename control-center to gnome-control-center
|
Loading…
Reference in New Issue
Block a user