Remove gn-5e19d2fb166f-stdint.patch since it is now upstream
This commit is contained in:
parent
b9b44a8680
commit
f46b4d6427
@ -1,24 +0,0 @@
|
|||||||
From 36e55bde4e6def641d7ecbdc483c3bc0b4d5047d Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
|
|
||||||
Date: Thu, 19 Jan 2023 09:16:51 -0500
|
|
||||||
Subject: [PATCH] Add missing #include <stdint.h> for uint8_t
|
|
||||||
|
|
||||||
---
|
|
||||||
src/base/containers/span.h | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/src/base/containers/span.h b/src/base/containers/span.h
|
|
||||||
index 4af83b44..19b9503e 100644
|
|
||||||
--- a/src/base/containers/span.h
|
|
||||||
+++ b/src/base/containers/span.h
|
|
||||||
@@ -6,6 +6,7 @@
|
|
||||||
#define BASE_CONTAINERS_SPAN_H_
|
|
||||||
|
|
||||||
#include <stddef.h>
|
|
||||||
+#include <stdint.h>
|
|
||||||
|
|
||||||
#include <algorithm>
|
|
||||||
#include <array>
|
|
||||||
--
|
|
||||||
2.39.0
|
|
||||||
|
|
3
gn.spec
3
gn.spec
@ -54,9 +54,6 @@ Source2: update-version
|
|||||||
# Stop overriding optimization flags; not sent upstream because this is
|
# Stop overriding optimization flags; not sent upstream because this is
|
||||||
# intentional on their part
|
# intentional on their part
|
||||||
Patch: gn-0153d369-no-O3.patch
|
Patch: gn-0153d369-no-O3.patch
|
||||||
# Missing #include <stdint.h> for uint8_t (GCC 13)
|
|
||||||
# https://bugs.chromium.org/p/gn/issues/detail?id=319
|
|
||||||
Patch: gn-5e19d2fb166f-stdint.patch
|
|
||||||
# Error: redundant move in return statement (GCC 13)
|
# Error: redundant move in return statement (GCC 13)
|
||||||
# https://bugs.chromium.org/p/gn/issues/detail?id=318
|
# https://bugs.chromium.org/p/gn/issues/detail?id=318
|
||||||
# Apparently, removing the std::move causes an error (error: use of deleted
|
# Apparently, removing the std::move causes an error (error: use of deleted
|
||||||
|
Loading…
Reference in New Issue
Block a user