patch against opencv 4.1.2
This commit is contained in:
parent
f4f3a23b92
commit
f0e0acfd3b
10
gmic.spec
10
gmic.spec
@ -10,7 +10,7 @@
|
||||
Summary: GREYC's Magic for Image Computing
|
||||
Name: gmic
|
||||
Version: 2.7.4
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Source0: https://gmic.eu/files/source/%{name}_%{version}.tar.gz
|
||||
# GIT archive snapshot of https://github.com/c-koi/zart
|
||||
Source1: zart-%{zart_version}.tar.gz
|
||||
@ -41,7 +41,9 @@ BuildRequires: libcurl-devel
|
||||
BuildRequires: gcc-c++
|
||||
# The C library binding was mistakenly put in a -static
|
||||
# package despite being a shared library
|
||||
Obsoletes: gmic-static <= 2.1.8
|
||||
Obsoletes: gmic-static <= 2.1.8
|
||||
|
||||
Patch1: gmic_opencv.patch
|
||||
|
||||
%description
|
||||
G'MIC is an open and full-featured framework for image processing, providing
|
||||
@ -75,6 +77,7 @@ Provides a plugin for using G'MIC from GIMP
|
||||
|
||||
%prep
|
||||
%setup -q -a 1 -a 2 -a 3
|
||||
%patch1 -p1 -b.opencv
|
||||
|
||||
%build
|
||||
export CCACHE_DISABLE=1
|
||||
@ -156,6 +159,9 @@ chmod -x $RPM_BUILD_ROOT/%{_sysconfdir}/bash_completion.d/gmic
|
||||
%{gimpplugindir}/gmic_cluts.gmz
|
||||
|
||||
%changelog
|
||||
* Fri Oct 18 2019 josef radinger <cheese@nosuchhost.net> - 2.7.4-3
|
||||
- add patch for building against opencv 4.1.2
|
||||
|
||||
* Fri Oct 18 2019 josef radinger <cheese@nosuchhost.net> - 2.7.4-2
|
||||
- rebuild against opencv 4.1.2
|
||||
|
||||
|
20
gmic_opencv.patch
Normal file
20
gmic_opencv.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- gmic-2.7.4/zart/src/ImageConverter.cpp.orig 2019-10-15 22:17:36.043062873 +0200
|
||||
+++ gmic-2.7.4/zart/src/ImageConverter.cpp 2019-10-15 22:19:36.252242400 +0200
|
||||
@@ -70,7 +70,7 @@
|
||||
|
||||
cv::Mat tmp(in->cols, in->rows, in->depth());
|
||||
|
||||
- cvtColor(*in, tmp, (in->channels() == 1) ? CV_GRAY2RGB : CV_BGR2RGB);
|
||||
+ cvtColor(*in, tmp, (in->channels() == 1) ? cv::COLOR_GRAY2RGB : cv::COLOR_BGR2RGB);
|
||||
|
||||
const unsigned int w3 = 3 * tmp.cols;
|
||||
unsigned char * src = reinterpret_cast<unsigned char *>(tmp.ptr());
|
||||
@@ -106,7 +106,7 @@
|
||||
dst += step;
|
||||
}
|
||||
}
|
||||
- cvtColor(**out, **out, CV_BGR2RGB);
|
||||
+ cvtColor(**out, **out, cv::COLOR_BGR2RGB);
|
||||
}
|
||||
|
||||
void ImageConverter::convert(const cimg_library::CImg<float> & in, QImage * out)
|
Loading…
Reference in New Issue
Block a user