fix gmic-openexr3.patch

This commit is contained in:
josef radinger 2021-12-11 15:41:22 +01:00
parent e575d1d964
commit c0eb560b8f

View File

@ -16,16 +16,16 @@ Index: gmic-2.9.7/cmake/FindCImg.cmake
list(APPEND CLI_COMPILE_FLAGS "cimg_use_openexr") list(APPEND CLI_COMPILE_FLAGS "cimg_use_openexr")
Index: gmic-2.9.7/src/Makefile Index: gmic-2.9.7/src/Makefile
=================================================================== ===================================================================
--- gmic-2.9.7.orig/src/Makefile --- gmic-3.0.0.orig/src/Makefile
+++ gmic-2.9.7/src/Makefile +++ gmic-3.0.0/src/Makefile
@@ -308,8 +308,8 @@ MAGICK_LIBS = $(shell pkg-config --libs @@ -307,8 +307,8 @@
# Enable native support of EXR image files, using the OpenEXR library. # Enable native support of EXR image files, using the OpenEXR library.
# (http://www.openexr.com/) # (http://www.openexr.com/)
-OPENEXR_CFLAGS = -Dcimg_use_openexr -I$(USR)/$(INCLUDE)/OpenEXR -OPENEXR_CFLAGS = -Dcimg_use_openexr $(shell pkg-config --cflags OpenEXR || echo -I$(USR)/$(INCLUDE)/OpenEXR)
-OPENEXR_LIBS = -lIlmImf -lHalf -OPENEXR_LIBS = $(shell pkg-config --libs OpenEXR || echo -lIlmImf -lHalf)
+OPENEXR_CFLAGS = -Dcimg_use_openexr -I$(USR)/$(INCLUDE)/OpenEXR -I$(USR)/$(INCLUDE)/Imath +OPENEXR_CFLAGS = -Dcimg_use_openexr $(shell pkg-config --cflags OpenEXR || echo -I$(USR)/$(INCLUDE)/OpenEXR -I$(USR)/$(INCLUDE)/Imath)
+OPENEXR_LIBS = -lOpenEXR -lImath +OPENEXR_LIBS = $(shell pkg-config --libs OpenEXR || echo -lOpenEXR -lImath)
# Enable Fast Fourier Transforms, using the FFTW3 library. # Enable Fast Fourier Transforms, using the FFTW3 library.
# (http://www.fftw.org/) # (http://www.fftw.org/)