First build

This commit is contained in:
leigh123linux 2018-01-02 17:14:43 +00:00
parent 7845dd08bc
commit cb6936631b
5 changed files with 102 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
/glslang-*.tar.gz

View File

@ -0,0 +1,9 @@
--- a/StandAlone/CMakeLists.txt
+++ b/StandAlone/CMakeLists.txt
@@ -1,4 +1,4 @@
-add_library(glslang-default-resource-limits
+add_library(glslang-default-resource-limits STATIC
${CMAKE_CURRENT_SOURCE_DIR}/ResourceLimits.cpp)
set_property(TARGET glslang-default-resource-limits PROPERTY FOLDER glslang)
set_property(TARGET glslang-default-resource-limits PROPERTY POSITION_INDEPENDENT_CODE ON)

71
glslang.spec Normal file
View File

@ -0,0 +1,71 @@
%global commit 715c353a15836e5ae192a64a4cf54e2ce7e8d66a
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global commit_date 20171028
%global gitrel .%{commit_date}.git%{shortcommit}
Name: glslang
Version: 3.1
Release: 0.1%{?gitrel}%{?dist}
Summary: OpenGL and OpenGL ES shader front end and validator
License: BSD and GPLv3+ and ASL 2.0
URL: https://github.com/KhronosGroup
Source0: %url/%{name}/archive/%{commit}.tar.gz#/%{name}-%{commit}.tar.gz
Patch0: nodate.patch
Patch1: glslang-default-resource-limits_staticlib.patch
BuildRequires: cmake3
BuildRequires: gcc-c++
%description
%{name} is the official reference compiler front end for the OpenGL
ES and OpenGL shading languages. It implements a strict
interpretation of the specifications for these languages.
%package devel
Summary: Development files for %{name}
%description devel
%{name} is the official reference compiler front end for the OpenGL
ES and OpenGL shading languages. It implements a strict
interpretation of the specifications for these languages.
%prep
%autosetup -p1 -n %{name}-%{commit}
# Fix rpmlint warning on debuginfo
find . -name '*.h' -or -name '*.cpp' -or -name '*.hpp'| xargs chmod a-x
%build
%__mkdir_p %_target_platform
pushd %_target_platform
%cmake3 -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_LIBDIR=%{_libdir} \
-DCMAKE_SKIP_RPATH:BOOL=yes ..
%{make_build}
popd
%install
%{make_install} -C %_target_platform
# Install .so file
install -pm 0644 %_target_platform/StandAlone/libglslang-default-resource-limits.a %{buildroot}%{_libdir}/
%files devel
%doc README.md README-spirv-remap.txt
%{_bindir}/glslangValidator
%{_bindir}/spirv-remap
%{_includedir}/SPIRV/
%{_includedir}/glslang/
%{_libdir}/libHLSL.a
%{_libdir}/libOGLCompiler.a
%{_libdir}/libOSDependent.a
%{_libdir}/libSPIRV.a
%{_libdir}/libSPVRemapper.a
%{_libdir}/libglslang.a
%{_libdir}/libglslang-default-resource-limits.a
%changelog
* Thu Jul 13 2017 Leigh Scott <leigh123linux@googlemail.com> - 3.1-0.1.20171028.git715c353
- First build

20
nodate.patch Normal file
View File

@ -0,0 +1,20 @@
From: Jan Engelhardt <jengelh@inai.de>
Date: 2017-08-07 20:22:29.456870387 +0200
---
StandAlone/spirv-remap.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Index: glslang/StandAlone/spirv-remap.cpp
===================================================================
--- a/StandAlone/spirv-remap.cpp
+++ b/StandAlone/spirv-remap.cpp
@@ -227,7 +227,7 @@ namespace {
}
}
else if (arg == "--version" || arg == "-V") {
- std::cout << basename(argv[0]) << " version 0.97 " << __DATE__ << " " << __TIME__ << std::endl;
+ std::cout << basename(argv[0]) << " version 0.97 " << std::endl;
exit(0);
} else if (arg == "--input" || arg == "-i") {
// Collect input files

1
sources Normal file
View File

@ -0,0 +1 @@
SHA512 (glslang-715c353a15836e5ae192a64a4cf54e2ce7e8d66a.tar.gz) = 9c46249cf2addb31833fcf3b1ce47458b8d339f86e6a5896ed8511d8b8e48dfcf65d2e4b7291593d47161f1c23a82e5f42fc2bbcf33e2383e9b0bd951f092924