0e17ea22c1
The following commit removes the requirement for patches to be placed in 1000, 2000, or 3000 ID blocks depending on their upstream status. Instead upstream status is documented in the header of the patch with some semi-standard notation as described in template.patch. The patches are re-numbered and defined and applied in the same order. Verified that before and after the patch that the source tree does not change. The patch definition is resorted to match the patch application order.
22 lines
883 B
Diff
22 lines
883 B
Diff
Short description: Fedora-specific glibc install locale changes.
|
|
Author(s): Fedora glibc team <glibc@lists.fedoraproject.org>
|
|
Origin: PATCH
|
|
Upstream status: not-needed
|
|
|
|
The Fedora glibc build and install does not need the normal install
|
|
behaviour which updates the locale archive. The Fedora install phase
|
|
in the spec file of the rpm will handle this manually.
|
|
|
|
diff --git a/localedata/Makefile b/localedata/Makefile
|
|
index a5f3c92d58954dfc..56719c7c714aa0f1 100644
|
|
--- a/localedata/Makefile
|
|
+++ b/localedata/Makefile
|
|
@@ -218,6 +218,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-locales-dir
|
|
echo -n '...'; \
|
|
input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
|
|
$(LOCALEDEF) $$flags --alias-file=../intl/locale.alias \
|
|
+ --no-archive \
|
|
-i locales/$$input -f charmaps/$$charset \
|
|
$(addprefix --prefix=,$(install_root)) $$locale \
|
|
&& echo ' done'; \
|