glibc/glibc-arm-hardfloat-2.patch
2012-05-31 22:53:39 -06:00

332 lines
11 KiB
Diff

diff --git a/sysdeps/arm/configure.in b/sysdeps/arm/configure.in
index 706add2..f00b798 100644
--- a/sysdeps/arm/configure.in
+++ b/sysdeps/arm/configure.in
@@ -49,3 +49,20 @@ EOF
if test $libc_cv_asm_cfi_directive_sections != yes; then
AC_MSG_ERROR([need .cfi_sections in this configuration])
fi
+
+# We check to see if the compiler and flags are
+# selecting the hard-float ABI and if they are then
+# we set libc_cv_arm_pcs_vfp to yes which causes
+# HAVE_ARM_PCS_VFP to be defined in config.h and
+# in include/libc-symbols.h and thus available to
+# shlib-versions to select the appropriate name for
+# the dynamic linker via %ifdef.
+AC_CACHE_CHECK([whether the compiler is using the ARM hard-float ABI],
+ [libc_cv_arm_pcs_vfp],
+ [AC_EGREP_CPP(yes,[#ifdef __ARM_PCS_VFP
+ yes
+ #endif
+ ], libc_cv_arm_pcs_vfp=yes, libc_cv_arm_pcs_vfp=no)])
+if test $libc_cv_arm_pcs_vfp = yes; then
+ AC_DEFINE(HAVE_ARM_PCS_VFP)
+fi
diff -rup c/sysdeps/arm/shlib-versions d/sysdeps/arm/shlib-versions
--- c/sysdeps/arm/shlib-versions 2012-01-08 22:47:04.000000000 -0700
+++ d/sysdeps/arm/shlib-versions 2012-05-07 11:57:07.739567660 -0600
@@ -1,4 +1,10 @@
arm.*-.*-linux-gnueabi.* DEFAULT GLIBC_2.4
-arm.*-.*-linux-gnueabi.* ld=ld-linux.so.3
+%ifdef HAVE_ARM_PCS_VFP
+# The EABI-derived hard-float ABI uses a new dynamic linker.
+arm.*-.*-linux-gnueabi.* ld=ld-linux-armhf.so.3
+%else
+# The EABI-derived soft-float ABI continues to use ld-linux.so.3.
+arm.*-.*-linux-gnueabi.* ld=ld-linux.so.3
+%endif
arm.*-.*-linux.* ld=ld-linux.so.2
*** a/sysdeps/arm/configure Sun Jan 8 22:47:04 2012
--- b/sysdeps/arm/configure Tue May 8 12:37:21 2012
***************
*** 1 ****
--- 1,100 ----
+
+ # as_fn_set_status STATUS
+ # -----------------------
+ # Set $? to STATUS, without forking.
+ as_fn_set_status ()
+ {
+ return $1
+ } # as_fn_set_status
+
+ # as_fn_exit STATUS
+ # -----------------
+ # Exit the shell with STATUS, even in a "trap 0" or "set -e" context.
+ as_fn_exit ()
+ {
+ set +e
+ as_fn_set_status $1
+ exit $1
+ } # as_fn_exit
+ # as_fn_arith ARG...
+ # ------------------
+ # Perform arithmetic evaluation on the ARGs, and store the result in the
+ # global $as_val. Take advantage of shells that can avoid forks. The arguments
+ # must be portable across $(()) and expr.
+ if (eval "test \$(( 1 + 1 )) = 2") 2>/dev/null; then :
+ eval 'as_fn_arith ()
+ {
+ as_val=$(( $* ))
+ }'
+ else
+ as_fn_arith ()
+ {
+ as_val=`expr "$@" || test $? -eq 1`
+ }
+ fi # as_fn_arith
+
+ if expr a : '\(a\)' >/dev/null 2>&1 &&
+ test "X`expr 00001 : '.*\(...\)'`" = X001; then
+ as_expr=expr
+ else
+ as_expr=false
+ fi
+
+ if (basename -- /) >/dev/null 2>&1 && test "X`basename -- / 2>&1`" = "X/"; then
+ as_basename=basename
+ else
+ as_basename=false
+ fi
+
+ as_me=`$as_basename -- "$0" ||
+ $as_expr X/"$0" : '.*/\([^/][^/]*\)/*$' \| \
+ X"$0" : 'X\(//\)$' \| \
+ X"$0" : 'X\(/\)' \| . 2>/dev/null ||
+ $as_echo X/"$0" |
+ sed '/^.*\/\([^/][^/]*\)\/*$/{
+ s//\1/
+ q
+ }
+ /^X\/\(\/\/\)$/{
+ s//\1/
+ q
+ }
+ /^X\/\(\/\).*/{
+ s//\1/
+ q
+ }
+ s/.*/./; q'`
+
+
+ as_lineno_1=$LINENO as_lineno_1a=$LINENO
+ as_lineno_2=$LINENO as_lineno_2a=$LINENO
+ eval 'test "x$as_lineno_1'$as_run'" != "x$as_lineno_2'$as_run'" &&
+ test "x`expr $as_lineno_1'$as_run' + 1`" = "x$as_lineno_2'$as_run'"' || {
+ # Blame Lee E. McMahon (1931-1989) for sed's syntax. :-)
+ sed -n '
+ p
+ /[$]LINENO/=
+ ' <$as_myself |
+ sed '
+ s/[$]LINENO.*/&-/
+ t lineno
+ b
+ :lineno
+ N
+ :loop
+ s/[$]LINENO\([^'$as_cr_alnum'_].*\n\)\(.*\)/\2\1\2/
+ t loop
+ s/-\n.*//
+ ' >$as_me.lineno &&
+ chmod +x "$as_me.lineno" ||
+ { $as_echo "$as_me: error: cannot create $as_me.lineno; rerun with a POSIX shell" >&2; as_fn_exit 1; }
+
+ # Don't try to exec as it changes $[0], causing all sort of problems
+ # (the dirname of $[0] is not the place where we might find the
+ # original and so on. Autoconf is especially sensitive to this).
+ . "./$as_me.lineno"
+ # Exit status is that of the last command.
+ exit
+ }
+
# This file is generated from configure.in by Autoconf. DO NOT EDIT!
***************
*** 26,33 ****
fi
! { $as_echo "$as_me:$LINENO: result: $libc_cv_asm_cfi_directive_sections" >&5
$as_echo "$libc_cv_asm_cfi_directive_sections" >&6; }
if test $libc_cv_asm_cfi_directive_sections != yes; then
! { { $as_echo "$as_me:$LINENO: error: need .cfi_sections in this configuration" >&5
! $as_echo "$as_me: error: need .cfi_sections in this configuration" >&2;}
! { (exit 1); exit 1; }; }
fi
--- 163,335 ----
fi
! { $as_echo "$as_me:${as_lineno-$LINENO}: result: $libc_cv_asm_cfi_directive_sections" >&5
$as_echo "$libc_cv_asm_cfi_directive_sections" >&6; }
if test $libc_cv_asm_cfi_directive_sections != yes; then
! as_fn_error $? "need .cfi_sections in this configuration" "$LINENO" 5
! fi
!
! # We check to see if the compiler and flags are
! # selecting the hard-float ABI and if they are then
! # we set libc_cv_arm_pcs_vfp to yes which causes
! # HAVE_ARM_PCS_VFP to be defined in config.h and
! # in include/libc-symbols.h and thus available to
! # shlib-versions to select the appropriate name for
! # the dynamic linker via %ifdef.
!
!
! { $as_echo "$as_me:${as_lineno-$LINENO}: checking for grep that handles long lines and -e" >&5
! $as_echo_n "checking for grep that handles long lines and -e... " >&6; }
! if ${ac_cv_path_GREP+:} false; then :
! $as_echo_n "(cached) " >&6
! else
! if test -z "$GREP"; then
! ac_path_GREP_found=false
! # Loop through the user's path and test for each of PROGNAME-LIST
! as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
! for as_dir in $PATH$PATH_SEPARATOR/usr/xpg4/bin
! do
! IFS=$as_save_IFS
! test -z "$as_dir" && as_dir=.
! for ac_prog in grep ggrep; do
! for ac_exec_ext in '' $ac_executable_extensions; do
! ac_path_GREP="$as_dir/$ac_prog$ac_exec_ext"
! { test -f "$ac_path_GREP" && $as_test_x "$ac_path_GREP"; } || continue
! # Check for GNU ac_path_GREP and select it if it is found.
! # Check for GNU $ac_path_GREP
! case `"$ac_path_GREP" --version 2>&1` in
! *GNU*)
! ac_cv_path_GREP="$ac_path_GREP" ac_path_GREP_found=:;;
! *)
! ac_count=0
! $as_echo_n 0123456789 >"conftest.in"
! while :
! do
! cat "conftest.in" "conftest.in" >"conftest.tmp"
! mv "conftest.tmp" "conftest.in"
! cp "conftest.in" "conftest.nl"
! $as_echo 'GREP' >> "conftest.nl"
! "$ac_path_GREP" -e 'GREP$' -e '-(cannot match)-' < "conftest.nl" >"conftest.out" 2>/dev/null || break
! diff "conftest.out" "conftest.nl" >/dev/null 2>&1 || break
! as_fn_arith $ac_count + 1 && ac_count=$as_val
! if test $ac_count -gt ${ac_path_GREP_max-0}; then
! # Best one so far, save it but keep looking for a better one
! ac_cv_path_GREP="$ac_path_GREP"
! ac_path_GREP_max=$ac_count
! fi
! # 10*(2^10) chars as input seems more than enough
! test $ac_count -gt 10 && break
! done
! rm -f conftest.in conftest.tmp conftest.nl conftest.out;;
! esac
!
! $ac_path_GREP_found && break 3
! done
! done
! done
! IFS=$as_save_IFS
! if test -z "$ac_cv_path_GREP"; then
! as_fn_error $? "no acceptable grep could be found in $PATH$PATH_SEPARATOR/usr/xpg4/bin" "$LINENO" 5
! fi
! else
! ac_cv_path_GREP=$GREP
! fi
!
! fi
! { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_path_GREP" >&5
! $as_echo "$ac_cv_path_GREP" >&6; }
! GREP="$ac_cv_path_GREP"
!
!
! { $as_echo "$as_me:${as_lineno-$LINENO}: checking for egrep" >&5
! $as_echo_n "checking for egrep... " >&6; }
! if ${ac_cv_path_EGREP+:} false; then :
! $as_echo_n "(cached) " >&6
! else
! if echo a | $GREP -E '(a|b)' >/dev/null 2>&1
! then ac_cv_path_EGREP="$GREP -E"
! else
! if test -z "$EGREP"; then
! ac_path_EGREP_found=false
! # Loop through the user's path and test for each of PROGNAME-LIST
! as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
! for as_dir in $PATH$PATH_SEPARATOR/usr/xpg4/bin
! do
! IFS=$as_save_IFS
! test -z "$as_dir" && as_dir=.
! for ac_prog in egrep; do
! for ac_exec_ext in '' $ac_executable_extensions; do
! ac_path_EGREP="$as_dir/$ac_prog$ac_exec_ext"
! { test -f "$ac_path_EGREP" && $as_test_x "$ac_path_EGREP"; } || continue
! # Check for GNU ac_path_EGREP and select it if it is found.
! # Check for GNU $ac_path_EGREP
! case `"$ac_path_EGREP" --version 2>&1` in
! *GNU*)
! ac_cv_path_EGREP="$ac_path_EGREP" ac_path_EGREP_found=:;;
! *)
! ac_count=0
! $as_echo_n 0123456789 >"conftest.in"
! while :
! do
! cat "conftest.in" "conftest.in" >"conftest.tmp"
! mv "conftest.tmp" "conftest.in"
! cp "conftest.in" "conftest.nl"
! $as_echo 'EGREP' >> "conftest.nl"
! "$ac_path_EGREP" 'EGREP$' < "conftest.nl" >"conftest.out" 2>/dev/null || break
! diff "conftest.out" "conftest.nl" >/dev/null 2>&1 || break
! as_fn_arith $ac_count + 1 && ac_count=$as_val
! if test $ac_count -gt ${ac_path_EGREP_max-0}; then
! # Best one so far, save it but keep looking for a better one
! ac_cv_path_EGREP="$ac_path_EGREP"
! ac_path_EGREP_max=$ac_count
! fi
! # 10*(2^10) chars as input seems more than enough
! test $ac_count -gt 10 && break
! done
! rm -f conftest.in conftest.tmp conftest.nl conftest.out;;
! esac
!
! $ac_path_EGREP_found && break 3
! done
! done
! done
! IFS=$as_save_IFS
! if test -z "$ac_cv_path_EGREP"; then
! as_fn_error $? "no acceptable egrep could be found in $PATH$PATH_SEPARATOR/usr/xpg4/bin" "$LINENO" 5
! fi
! else
! ac_cv_path_EGREP=$EGREP
! fi
!
! fi
! fi
! { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_path_EGREP" >&5
! $as_echo "$ac_cv_path_EGREP" >&6; }
! EGREP="$ac_cv_path_EGREP"
!
!
! { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether the compiler is using the ARM hard-float ABI" >&5
! $as_echo_n "checking whether the compiler is using the ARM hard-float ABI... " >&6; }
! if ${libc_cv_arm_pcs_vfp+:} false; then :
! $as_echo_n "(cached) " >&6
! else
! cat confdefs.h - <<_ACEOF >conftest.$ac_ext
! /* end confdefs.h. */
! #ifdef __ARM_PCS_VFP
! yes
! #endif
!
! _ACEOF
! if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
! $EGREP "yes" >/dev/null 2>&1; then :
! libc_cv_arm_pcs_vfp=yes
! else
! libc_cv_arm_pcs_vfp=no
! fi
! rm -f conftest*
!
! fi
! { $as_echo "$as_me:${as_lineno-$LINENO}: result: $libc_cv_arm_pcs_vfp" >&5
! $as_echo "$libc_cv_arm_pcs_vfp" >&6; }
! if test $libc_cv_arm_pcs_vfp = yes; then
! $as_echo "#define HAVE_ARM_PCS_VFP 1" >>confdefs.h
!
fi