ab210104fb
Upstream commit: edcf13e25c1559558a6f12ff5a71d4136a39235e - PTHREAD_STACK_MIN is too small on x86-64 (#1527887) - CVE-2018-1000001: Make getcwd fail if it cannot obtain an absolute path (#1533837) - CVE-2017-16997: Check for empty tokens before dynamic string token expansion in the dynamic linker (#1526866) - CVE-2017-15804: glob: Fix overflow in GLOB_TILDE unescaping (swbz#22332) - CVE-2017-15670: glob: Fix one-byte overflow (#1504807) - CVE-2017-15671: glob: Fix memory leak (#1504807) - nss_files: Avoid large buffers with many host addresses (swbz#22078) - nss_files: Use struct scratch_buffer for gethostbyname (swbz#18023) - posix: Fix improper assert in Linux posix_spawn (BZ#22273) - Don't use IFUNC resolver for longjmp or system in libpthread (swbz#21041) - x86-64: Use fxsave/xsave/xsavec in _dl_runtime_resolve (swbz#21265)
21 lines
564 B
Diff
21 lines
564 B
Diff
commit 60149b28590be28051f99d0a343d7fbe002f2a8c
|
|
Author: Florian Weimer <fweimer@redhat.com>
|
|
Date: Wed Jun 21 13:09:08 2017 +0200
|
|
|
|
__inet_pton_length: Implement new internal helper function
|
|
|
|
diff --git a/resolv/Makefile b/resolv/Makefile
|
|
index 3854ff4ad4156c15..692b2322cf7a3cab 100644
|
|
--- a/resolv/Makefile
|
|
+++ b/resolv/Makefile
|
|
@@ -65,6 +65,9 @@ tests += \
|
|
|
|
endif
|
|
|
|
+# This test accesses __inet_ntop_range, an internal libc function.
|
|
+tests += tst-inet_pton
|
|
+
|
|
# This test sends millions of packets and is rather slow.
|
|
xtests += tst-resolv-qtypes
|
|
endif
|