65faa39b43
Upstream commit: 6548a9bdba95b3e1fcdbd85445342467e4b0cd4f - Avoid warning: overriding recipe for .../tst-ro-dynamic-mod.so - ld.so: Initialize bootstrap_map.l_ld_readonly [BZ #28340] - ld.so: Replace DL_RO_DYN_SECTION with dl_relocate_ld [BZ #28340] - Handle NULL input to malloc_usable_size [BZ #28506] - elf: Avoid deadlock between pthread_create and ctors [BZ #28357] - timex: Use 64-bit fields on 32-bit TIMESIZE=64 systems (BZ #28469) - y2038: Use a common definition for stat for sparc32 - elf: Replace nsid with args.nsid [BZ #27609] - S390: Add PCI_MIO and SIE HWCAPs - support: Also return fd when it is 0
31 lines
1.0 KiB
Diff
31 lines
1.0 KiB
Diff
commit 6548a9bdba95b3e1fcdbd85445342467e4b0cd4f
|
|
Author: H.J. Lu <hjl.tools@gmail.com>
|
|
Date: Fri Sep 24 08:56:42 2021 -0700
|
|
|
|
Avoid warning: overriding recipe for .../tst-ro-dynamic-mod.so
|
|
|
|
Add tst-ro-dynamic-mod to modules-names-nobuild to avoid
|
|
|
|
../Makerules:767: warning: ignoring old recipe for target '.../elf/tst-ro-dynamic-mod.so'
|
|
|
|
This updates BZ #28340 fix.
|
|
|
|
(cherry picked from commit 15e6d6785ac2935bb963506b47a37b3d1f728952)
|
|
|
|
diff --git a/elf/Makefile b/elf/Makefile
|
|
index de854b4d1a815bd3..118d579c42c38110 100644
|
|
--- a/elf/Makefile
|
|
+++ b/elf/Makefile
|
|
@@ -399,8 +399,9 @@ endif
|
|
modules-execstack-yes = tst-execstack-mod
|
|
extra-test-objs += $(addsuffix .os,$(strip $(modules-names)))
|
|
|
|
-# filtmod1.so, tst-big-note-lib.so have special rules.
|
|
-modules-names-nobuild := filtmod1 tst-big-note-lib
|
|
+# filtmod1.so, tst-big-note-lib.so, tst-ro-dynamic-mod.so have special
|
|
+# rules.
|
|
+modules-names-nobuild := filtmod1 tst-big-note-lib tst-ro-dynamic-mod
|
|
|
|
tests += $(tests-static)
|
|
|