a8db42ba53
Upstream commit: 71326f1f2fd09dafb9c34404765fb88129e94237 - nptl: Fix pthread_cancel cancelhandling atomic operations - mips: Fix mips64n32 64 bit time_t stat support (BZ#29069) - hurd: Fix arbitrary error code - nptl: Handle spurious EINTR when thread cancellation is disabled (BZ#29029) - S390: Add new s390 platform z16. - NEWS: Update fixed bug list for LD_AUDIT backports. - hppa: Fix bind-now audit (BZ #28857) - elf: Replace tst-audit24bmod2.so with tst-audit24bmod2 - Fix elf/tst-audit25a with default bind now toolchains - elf: Fix runtime linker auditing on aarch64 (BZ #26643) - elf: Issue la_symbind for bind-now (BZ #23734) - elf: Fix initial-exec TLS access on audit modules (BZ #28096) - elf: Add la_activity during application exit - elf: Do not fail for failed dlmopen on audit modules (BZ #28061) - elf: Issue audit la_objopen for vDSO - elf: Add audit tests for modules with TLSDESC - elf: Avoid unnecessary slowdown from profiling with audit (BZ#15533) - elf: Add _dl_audit_pltexit - elf: Add _dl_audit_pltenter - elf: Add _dl_audit_preinit - elf: Add _dl_audit_symbind_alt and _dl_audit_symbind - elf: Add _dl_audit_objclose - elf: Add _dl_audit_objsearch - elf: Add _dl_audit_activity_map and _dl_audit_activity_nsid - elf: Add _dl_audit_objopen - elf: Move la_activity (LA_ACT_ADD) after _dl_add_to_namespace_list() (BZ #28062) - elf: Move LAV_CURRENT to link_lavcurrent.h - elf: Fix elf_get_dynamic_info() for bootstrap - elf: Fix dynamic-link.h usage on rtld.c - elf: Fix elf_get_dynamic_info definition - elf: Avoid nested functions in the loader [BZ #27220] - powerpc: Delete unneeded ELF_MACHINE_BEFORE_RTLD_RELOC - hppa: Use END instead of PSEUDO_END in swapcontext.S - hppa: Implement swapcontext in assembler (bug 28960) Reviewed-by: Florian Weimer <fweimer at redhat.com>
295 lines
9.2 KiB
Diff
295 lines
9.2 KiB
Diff
commit 02c6a3d35316d360ae08623f617b1873d2f6159a
|
|
Author: Adhemerval Zanella <adhemerval.zanella@linaro.org>
|
|
Date: Wed Jun 30 15:51:31 2021 -0300
|
|
|
|
elf: Add audit tests for modules with TLSDESC
|
|
|
|
Checked on x86_64-linux-gnu, i686-linux-gnu, and aarch64-linux-gnu.
|
|
|
|
Reviewed-by: Florian Weimer <fweimer@redhat.com>
|
|
(cherry picked from commit d1b38173c9255b1a4ae00018ad9b35404a7c74d0)
|
|
|
|
diff --git a/elf/Makefile b/elf/Makefile
|
|
index eab9d46b6165e6be..29f545d2272bf6e2 100644
|
|
--- a/elf/Makefile
|
|
+++ b/elf/Makefile
|
|
@@ -807,6 +807,22 @@ modules-names += tst-gnu2-tls1mod
|
|
$(objpfx)tst-gnu2-tls1: $(objpfx)tst-gnu2-tls1mod.so
|
|
tst-gnu2-tls1mod.so-no-z-defs = yes
|
|
CFLAGS-tst-gnu2-tls1mod.c += -mtls-dialect=gnu2
|
|
+
|
|
+tests += tst-audit-tlsdesc tst-audit-tlsdesc-dlopen
|
|
+modules-names += tst-audit-tlsdesc-mod1 tst-audit-tlsdesc-mod2 tst-auditmod-tlsdesc
|
|
+$(objpfx)tst-audit-tlsdesc: $(objpfx)tst-audit-tlsdesc-mod1.so \
|
|
+ $(objpfx)tst-audit-tlsdesc-mod2.so \
|
|
+ $(shared-thread-library)
|
|
+CFLAGS-tst-audit-tlsdesc-mod1.c += -mtls-dialect=gnu2
|
|
+CFLAGS-tst-audit-tlsdesc-mod2.c += -mtls-dialect=gnu2
|
|
+$(objpfx)tst-audit-tlsdesc-dlopen: $(shared-thread-library)
|
|
+$(objpfx)tst-audit-tlsdesc-dlopen.out: $(objpfx)tst-audit-tlsdesc-mod1.so \
|
|
+ $(objpfx)tst-audit-tlsdesc-mod2.so
|
|
+$(objpfx)tst-audit-tlsdesc-mod1.so: $(objpfx)tst-audit-tlsdesc-mod2.so
|
|
+$(objpfx)tst-audit-tlsdesc.out: $(objpfx)tst-auditmod-tlsdesc.so
|
|
+tst-audit-tlsdesc-ENV = LD_AUDIT=$(objpfx)tst-auditmod-tlsdesc.so
|
|
+$(objpfx)tst-audit-tlsdesc-dlopen.out: $(objpfx)tst-auditmod-tlsdesc.so
|
|
+tst-audit-tlsdesc-dlopen-ENV = LD_AUDIT=$(objpfx)tst-auditmod-tlsdesc.so
|
|
endif
|
|
ifeq (yes,$(have-protected-data))
|
|
modules-names += tst-protected1moda tst-protected1modb
|
|
diff --git a/elf/tst-audit-tlsdesc-dlopen.c b/elf/tst-audit-tlsdesc-dlopen.c
|
|
new file mode 100644
|
|
index 0000000000000000..9c16bb087aca1b77
|
|
--- /dev/null
|
|
+++ b/elf/tst-audit-tlsdesc-dlopen.c
|
|
@@ -0,0 +1,67 @@
|
|
+/* DT_AUDIT with modules with TLSDESC.
|
|
+ Copyright (C) 2021 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <support/check.h>
|
|
+#include <support/xthread.h>
|
|
+#include <support/xdlfcn.h>
|
|
+
|
|
+static void *
|
|
+thr_func (void *mod)
|
|
+{
|
|
+ int* (*get_global1)(void) = xdlsym (mod, "get_global1");
|
|
+ int* (*get_global2)(void) = xdlsym (mod, "get_global2");
|
|
+ void (*set_global2)(int) = xdlsym (mod, "set_global2");
|
|
+ int* (*get_local1)(void) = xdlsym (mod, "get_local1");
|
|
+ int* (*get_local2)(void) = xdlsym (mod, "get_local2");
|
|
+
|
|
+ int *global1 = get_global1 ();
|
|
+ TEST_COMPARE (*global1, 0);
|
|
+ ++*global1;
|
|
+
|
|
+ int *global2 = get_global2 ();
|
|
+ TEST_COMPARE (*global2, 0);
|
|
+ ++*global2;
|
|
+ TEST_COMPARE (*global2, 1);
|
|
+
|
|
+ set_global2 (10);
|
|
+ TEST_COMPARE (*global2, 10);
|
|
+
|
|
+ int *local1 = get_local1 ();
|
|
+ TEST_COMPARE (*local1, 0);
|
|
+ ++*local1;
|
|
+
|
|
+ int *local2 = get_local2 ();
|
|
+ TEST_COMPARE (*local2, 0);
|
|
+ ++*local2;
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static int
|
|
+do_test (void)
|
|
+{
|
|
+ void *mod = xdlopen ("tst-audit-tlsdesc-mod1.so", RTLD_LAZY);
|
|
+
|
|
+ pthread_t thr = xpthread_create (NULL, thr_func, mod);
|
|
+ void *r = xpthread_join (thr);
|
|
+ TEST_VERIFY (r == NULL);
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+#include <support/test-driver.c>
|
|
diff --git a/elf/tst-audit-tlsdesc-mod1.c b/elf/tst-audit-tlsdesc-mod1.c
|
|
new file mode 100644
|
|
index 0000000000000000..61c7dd99a2fb5e28
|
|
--- /dev/null
|
|
+++ b/elf/tst-audit-tlsdesc-mod1.c
|
|
@@ -0,0 +1,41 @@
|
|
+/* DT_AUDIT with modules with TLSDESC.
|
|
+ Copyright (C) 2021 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+__thread int global1;
|
|
+
|
|
+int *
|
|
+get_global1 (void)
|
|
+{
|
|
+ return &global1;
|
|
+}
|
|
+
|
|
+static __thread int local1;
|
|
+
|
|
+void *
|
|
+get_local1 (void)
|
|
+{
|
|
+ return &local1;
|
|
+}
|
|
+
|
|
+extern __thread int global2;
|
|
+
|
|
+void
|
|
+set_global2 (int v)
|
|
+{
|
|
+ global2 = v;
|
|
+}
|
|
diff --git a/elf/tst-audit-tlsdesc-mod2.c b/elf/tst-audit-tlsdesc-mod2.c
|
|
new file mode 100644
|
|
index 0000000000000000..28aef635f688ee03
|
|
--- /dev/null
|
|
+++ b/elf/tst-audit-tlsdesc-mod2.c
|
|
@@ -0,0 +1,33 @@
|
|
+/* DT_AUDIT with modules with TLSDESC.
|
|
+ Copyright (C) 2021 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+__thread int global2;
|
|
+
|
|
+int *
|
|
+get_global2 (void)
|
|
+{
|
|
+ return &global2;
|
|
+}
|
|
+
|
|
+static __thread int local2;
|
|
+
|
|
+void *
|
|
+get_local2 (void)
|
|
+{
|
|
+ return &local2;
|
|
+}
|
|
diff --git a/elf/tst-audit-tlsdesc.c b/elf/tst-audit-tlsdesc.c
|
|
new file mode 100644
|
|
index 0000000000000000..3c8be81c95528f47
|
|
--- /dev/null
|
|
+++ b/elf/tst-audit-tlsdesc.c
|
|
@@ -0,0 +1,60 @@
|
|
+/* DT_AUDIT with modules with TLSDESC.
|
|
+ Copyright (C) 2021 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <support/check.h>
|
|
+#include <support/xthread.h>
|
|
+
|
|
+extern __thread int global1;
|
|
+extern __thread int global2;
|
|
+void *get_local1 (void);
|
|
+void set_global2 (int v);
|
|
+void *get_local2 (void);
|
|
+
|
|
+static void *
|
|
+thr_func (void *clousure)
|
|
+{
|
|
+ TEST_COMPARE (global1, 0);
|
|
+ ++global1;
|
|
+ TEST_COMPARE (global2, 0);
|
|
+ ++global2;
|
|
+ TEST_COMPARE (global2, 1);
|
|
+
|
|
+ set_global2 (10);
|
|
+ TEST_COMPARE (global2, 10);
|
|
+
|
|
+ int *local1 = get_local1 ();
|
|
+ TEST_COMPARE (*local1, 0);
|
|
+ ++*local1;
|
|
+
|
|
+ int *local2 = get_local2 ();
|
|
+ TEST_COMPARE (*local2, 0);
|
|
+ ++*local2;
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static int
|
|
+do_test (void)
|
|
+{
|
|
+ pthread_t thr = xpthread_create (NULL, thr_func, NULL);
|
|
+ void *r = xpthread_join (thr);
|
|
+ TEST_VERIFY (r == NULL);
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+#include <support/test-driver.c>
|
|
diff --git a/elf/tst-auditmod-tlsdesc.c b/elf/tst-auditmod-tlsdesc.c
|
|
new file mode 100644
|
|
index 0000000000000000..e4b835d1f1fb6f73
|
|
--- /dev/null
|
|
+++ b/elf/tst-auditmod-tlsdesc.c
|
|
@@ -0,0 +1,25 @@
|
|
+/* DT_AUDIT with modules with TLSDESC.
|
|
+ Copyright (C) 2021 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#include <link.h>
|
|
+
|
|
+unsigned int
|
|
+la_version (unsigned int version)
|
|
+{
|
|
+ return LAV_CURRENT;
|
|
+}
|