abcc04a5bf
Upstream commit: 224d8c1890b6c57c7e4e8ddbb792dd9552086704 - debug: Synchronize feature guards in fortified functions [BZ #28746] - debug: Autogenerate _FORTIFY_SOURCE tests - Enable _FORTIFY_SOURCE=3 for gcc 12 and above - fortify: Fix spurious warning with realpath - __glibc_unsafe_len: Fix comment - debug: Add tests for _FORTIFY_SOURCE=3 - Make sure that the fortified function conditionals are constant - Don't add access size hints to fortifiable functions - nss: Protect against errno changes in function lookup (bug 28953) - nss: Do not mention NSS test modules in <gnu/lib-names.h> - io: Add fsync call in tst-stat - hppa: Fix warnings from _dl_lookup_address - nptl: Fix cleanups for stack grows up [BZ# 28899] - hppa: Revise gettext trampoline design - hppa: Fix swapcontext - Fix elf/tst-audit2 on hppa - localedef: Handle symbolic links when generating locale-archive - NEWS: Add a bug fix entry for BZ #28896 - x86: Fix TEST_NAME to make it a string in tst-strncmp-rtm.c - x86: Test wcscmp RTM in the wcsncmp overflow case [BZ #28896] - x86: Fallback {str|wcs}cmp RTM in the ncmp overflow case [BZ #28896] - string: Add a testcase for wcsncmp with SIZE_MAX [BZ #28755] - linux: fix accuracy of get_nprocs and get_nprocs_conf [BZ #28865] - Add reference to BZ#28860 on NEWS - linux: Fix missing __convert_scm_timestamps (BZ #28860)
121 lines
4.0 KiB
Diff
121 lines
4.0 KiB
Diff
commit 38e0d2479413ccdbc02b4c9e9e246eca31e956c9
|
|
Author: Noah Goldstein <goldstein.w.n@gmail.com>
|
|
Date: Tue Feb 15 08:18:15 2022 -0600
|
|
|
|
x86: Fallback {str|wcs}cmp RTM in the ncmp overflow case [BZ #28896]
|
|
|
|
In the overflow fallback strncmp-avx2-rtm and wcsncmp-avx2-rtm would
|
|
call strcmp-avx2 and wcscmp-avx2 respectively. This would have
|
|
not checks around vzeroupper and would trigger spurious
|
|
aborts. This commit fixes that.
|
|
|
|
test-strcmp, test-strncmp, test-wcscmp, and test-wcsncmp all pass on
|
|
AVX2 machines with and without RTM.
|
|
|
|
Co-authored-by: H.J. Lu <hjl.tools@gmail.com>
|
|
|
|
(cherry picked from commit c6272098323153db373f2986c67786ea8c85f1cf)
|
|
|
|
diff --git a/sysdeps/x86/Makefile b/sysdeps/x86/Makefile
|
|
index 36ca1a7126047b86..af934d6ccf1fa337 100644
|
|
--- a/sysdeps/x86/Makefile
|
|
+++ b/sysdeps/x86/Makefile
|
|
@@ -105,7 +105,7 @@ CFLAGS-tst-memset-rtm.c += -mrtm
|
|
CFLAGS-tst-strchr-rtm.c += -mrtm
|
|
CFLAGS-tst-strcpy-rtm.c += -mrtm
|
|
CFLAGS-tst-strlen-rtm.c += -mrtm
|
|
-CFLAGS-tst-strncmp-rtm.c += -mrtm
|
|
+CFLAGS-tst-strncmp-rtm.c += -mrtm -Wno-error
|
|
CFLAGS-tst-strrchr-rtm.c += -mrtm
|
|
endif
|
|
|
|
diff --git a/sysdeps/x86/tst-strncmp-rtm.c b/sysdeps/x86/tst-strncmp-rtm.c
|
|
index 236ad951b5b59cd1..4d0004b58aae428d 100644
|
|
--- a/sysdeps/x86/tst-strncmp-rtm.c
|
|
+++ b/sysdeps/x86/tst-strncmp-rtm.c
|
|
@@ -16,6 +16,7 @@
|
|
License along with the GNU C Library; if not, see
|
|
<https://www.gnu.org/licenses/>. */
|
|
|
|
+#include <stdint.h>
|
|
#include <tst-string-rtm.h>
|
|
|
|
#define LOOP 3000
|
|
@@ -45,8 +46,22 @@ function (void)
|
|
return 1;
|
|
}
|
|
|
|
+__attribute__ ((noinline, noclone))
|
|
+static int
|
|
+function_overflow (void)
|
|
+{
|
|
+ if (strncmp (string1, string2, SIZE_MAX) == 0)
|
|
+ return 0;
|
|
+ else
|
|
+ return 1;
|
|
+}
|
|
+
|
|
static int
|
|
do_test (void)
|
|
{
|
|
- return do_test_1 ("strncmp", LOOP, prepare, function);
|
|
+ int status = do_test_1 ("strncmp", LOOP, prepare, function);
|
|
+ if (status != EXIT_SUCCESS)
|
|
+ return status;
|
|
+ status = do_test_1 ("strncmp", LOOP, prepare, function_overflow);
|
|
+ return status;
|
|
}
|
|
diff --git a/sysdeps/x86_64/multiarch/strcmp-avx2.S b/sysdeps/x86_64/multiarch/strcmp-avx2.S
|
|
index 3dfcb1bf803cf9ec..fa70c994fc25dfd8 100644
|
|
--- a/sysdeps/x86_64/multiarch/strcmp-avx2.S
|
|
+++ b/sysdeps/x86_64/multiarch/strcmp-avx2.S
|
|
@@ -95,7 +95,7 @@ ENTRY (STRCMP)
|
|
length to bound a valid memory region. In these cases just use
|
|
'wcscmp'. */
|
|
shrq $56, %rcx
|
|
- jnz __wcscmp_avx2
|
|
+ jnz OVERFLOW_STRCMP
|
|
# endif
|
|
/* Convert units: from wide to byte char. */
|
|
shl $2, %RDX_LP
|
|
diff --git a/sysdeps/x86_64/multiarch/strncmp-avx2-rtm.S b/sysdeps/x86_64/multiarch/strncmp-avx2-rtm.S
|
|
index 37d1224bb9b7056b..68bad365ba728eec 100644
|
|
--- a/sysdeps/x86_64/multiarch/strncmp-avx2-rtm.S
|
|
+++ b/sysdeps/x86_64/multiarch/strncmp-avx2-rtm.S
|
|
@@ -1,3 +1,4 @@
|
|
#define STRCMP __strncmp_avx2_rtm
|
|
#define USE_AS_STRNCMP 1
|
|
+#define OVERFLOW_STRCMP __strcmp_avx2_rtm
|
|
#include "strcmp-avx2-rtm.S"
|
|
diff --git a/sysdeps/x86_64/multiarch/strncmp-avx2.S b/sysdeps/x86_64/multiarch/strncmp-avx2.S
|
|
index 1678bcc235a4bc6a..f138e9f1fdcf277c 100644
|
|
--- a/sysdeps/x86_64/multiarch/strncmp-avx2.S
|
|
+++ b/sysdeps/x86_64/multiarch/strncmp-avx2.S
|
|
@@ -1,3 +1,4 @@
|
|
#define STRCMP __strncmp_avx2
|
|
#define USE_AS_STRNCMP 1
|
|
+#define OVERFLOW_STRCMP __strcmp_avx2
|
|
#include "strcmp-avx2.S"
|
|
diff --git a/sysdeps/x86_64/multiarch/wcsncmp-avx2-rtm.S b/sysdeps/x86_64/multiarch/wcsncmp-avx2-rtm.S
|
|
index 4e88c70cc696b82d..f467582cbedd4535 100644
|
|
--- a/sysdeps/x86_64/multiarch/wcsncmp-avx2-rtm.S
|
|
+++ b/sysdeps/x86_64/multiarch/wcsncmp-avx2-rtm.S
|
|
@@ -1,5 +1,5 @@
|
|
#define STRCMP __wcsncmp_avx2_rtm
|
|
#define USE_AS_STRNCMP 1
|
|
#define USE_AS_WCSCMP 1
|
|
-
|
|
+#define OVERFLOW_STRCMP __wcscmp_avx2_rtm
|
|
#include "strcmp-avx2-rtm.S"
|
|
diff --git a/sysdeps/x86_64/multiarch/wcsncmp-avx2.S b/sysdeps/x86_64/multiarch/wcsncmp-avx2.S
|
|
index 4fa1de4d3f1f97ff..e9ede522b8bde27d 100644
|
|
--- a/sysdeps/x86_64/multiarch/wcsncmp-avx2.S
|
|
+++ b/sysdeps/x86_64/multiarch/wcsncmp-avx2.S
|
|
@@ -1,5 +1,5 @@
|
|
#define STRCMP __wcsncmp_avx2
|
|
#define USE_AS_STRNCMP 1
|
|
#define USE_AS_WCSCMP 1
|
|
-
|
|
+#define OVERFLOW_STRCMP __wcscmp_avx2
|
|
#include "strcmp-avx2.S"
|