glibc/glibc-disable-werror-tst-realloc.patch
Arjun Shankar 6fd5c5a43b Auto-sync with upstream branch master
Apply glibc-disable-werror-tst-realloc.patch to disable spurious GCC
warning, and auto-sync with upstream branch master.

Upstream commit: 885d3cda907d0dee54b13cbbf61b040c9951d5a2

- Allow building with --disable-nscd again
- system: Add "--" after "-c" for sh (BZ #28519)
- posix: Fix some crashes in wordexp [BZ #18096]
- LoongArch: ldconfig: Add comments for using EF_LARCH_OBJABI_V1
- elf: Take into account ${sysconfdir} in elf/tst-ldconfig-p.sh
- Fix tst-glibc-hwcaps-prepend-cache with custom configure prefix value
- Fix tst-ldconfig-ld_so_conf-update with custom configure prefix value
- support: introduce support_sysconfdir_prefix
- Remove set-hooks.h from generic includes
- Remove --with-default-link configure option
- libio: Remove the usage of __libc_IO_vtables
- libio: Do not autogenerate stdio_lim.h
- Move libc_freeres_ptrs and libc_subfreeres to hidden/weak functions
- benchtests: Move libmvec benchtest inputs to benchtests directory
- stdio-common: tests: don't double-define _FORTIFY_SOURCE
- LoongArch: ldconfig: Ignore EF_LARCH_OBJABI_V1 in shared objects
- _dl_map_object_from_fd: Remove unnecessary debugger notification in error path
- hppa: Drop 16-byte pthread lock alignment
- Minor: don't call _dl_debug_update (which can have side effects) inside assert
- x86: Don't check PREFETCHWT1 in tst-cpu-features-cpuinfo.c
- Declare wcstofN, wcstofNx for C2x
- Update printf %b/%B C2x support
- ARC: run child from the separate start block in __clone
- ARC: Add the clone3 wrapper
2023-03-31 14:23:15 +02:00

19 lines
615 B
Diff

Use -Wno-error when compiling malloc/tst-realloc.c until the following
fix lands in GCC:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109238
diff --git a/malloc/Makefile b/malloc/Makefile
index dfb51d344c02b509..a719f4418efc22d0 100644
--- a/malloc/Makefile
+++ b/malloc/Makefile
@@ -122,6 +122,8 @@ tests-exclude-mcheck = tst-mallocstate \
tests-mcheck = $(filter-out $(tests-exclude-mcheck) $(tests-static), $(tests))
endif
+CFLAGS-tst-realloc.c += -Wno-error
+
routines = malloc mcheck mtrace obstack reallocarray \
scratch_buffer_grow scratch_buffer_grow_preserve \
scratch_buffer_set_array_size \