26 lines
1.1 KiB
Diff
26 lines
1.1 KiB
Diff
diff -Nrup a/nptl/Makefile b/nptl/Makefile
|
|
--- a/nptl/Makefile 2012-06-05 07:42:49.000000000 -0600
|
|
+++ b/nptl/Makefile 2012-06-07 12:15:21.816318678 -0600
|
|
@@ -529,15 +529,19 @@ $(addprefix $(objpfx), \
|
|
$(tests) $(xtests) $(test-srcs))): $(objpfx)libpthread.so \
|
|
$(objpfx)libpthread_nonshared.a
|
|
$(objpfx)tst-unload: $(libdl)
|
|
-# $(objpfx)../libc.so is used instead of $(common-objpfx)libc.so,
|
|
+# $(objpfx)linklibc.so is used instead of $(common-objpfx)libc.so,
|
|
# since otherwise libpthread.so comes before libc.so when linking.
|
|
$(addprefix $(objpfx), $(tests-reverse)): \
|
|
- $(objpfx)../libc.so $(objpfx)libpthread.so \
|
|
+ $(objpfx)linklibc.so $(objpfx)libpthread.so \
|
|
$(objpfx)libpthread_nonshared.a
|
|
$(objpfx)../libc.so: $(common-objpfx)libc.so ;
|
|
$(addprefix $(objpfx),$(tests-static) $(xtests-static)): $(objpfx)libpthread.a
|
|
|
|
$(objpfx)tst-atfork2.out: $(objpfx)tst-atfork2mod.so
|
|
+
|
|
+$(objpfx)linklibc.so: $(common-objpfx)libc.so
|
|
+ ln -s ../libc.so $@
|
|
+generated += libclink.so
|
|
else
|
|
$(addprefix $(objpfx),$(tests) $(test-srcs)): $(objpfx)libpthread.a
|
|
endif
|