glibc/glibc-rh731833-rtkaio.patch
Siddhesh Poyarekar 8da75f6fa4 Adjust rtkaio patches to build with latest upstream
Following commit upstream removed the definition for elfobjdir in
favour of elf-objpfx.  Adjust rtkaio to build with this.

commit 4134b50d6789c333707b1861a32314805bd0de5e
Author: Joseph Myers <joseph@codesourcery.com>
Date:   Wed May 21 16:52:08 2014 +0000

    Consistently use $(elf-objpfx).

    As previously noted
    <https://sourceware.org/ml/libc-alpha/2013-05/msg00696.html>,
    $(elf-objpfx) and $(elfobjdir) are redundant and should be
    consolidated.  This patch consolidates on $(elf-objpfx) (for
    consistency with $(csu-objpfx)), also changing direct uses of
    $(common-objpfx)elf/ to use $(elf-objpfx).
2014-05-26 15:50:48 +05:30

32 lines
1.2 KiB
Diff

diff -pruN glibc-2.17-c758a686/rtkaio/Makefile glibc-2.17-c758a686.new/rtkaio/Makefile
--- glibc-2.17-c758a686/rtkaio/Makefile 2011-10-19 16:34:41.000000000 +0530
+++ glibc-2.17-c758a686.new/rtkaio/Makefile 2013-08-13 18:23:21.064888432 +0530
@@ -55,7 +55,7 @@ extra-libs-others := $(extra-libs)
include $(..)Makeconfig
-ifeq (yesyes,$(build-shared)$(elf))
+ifeq (yes,$(build-shared))
generated += librt.so$(librt.so-version)
$(objpfx)librt.so$(librt.so-version): $(objpfx)librtkaio.so; $(make-link)
@@ -73,7 +73,7 @@ CPPFLAGS-librtkaio += -DIS_IN_librt=1 -I
rpath-dirs := $(patsubst rt,rtkaio,$(rpath-dirs))
-ifeq (yesyes,$(build-shared)$(elf))
+ifeq (yes,$(build-shared))
others: $(objpfx)librt.so$(librt.so-version)
endif
@@ -81,8 +81,7 @@ endif
# This ensures they will load libc.so for needed symbols if loaded by
# a statically-linked program that hasn't already loaded it.
$(objpfx)librtkaio.so: $(common-objpfx)libc.so $(common-objpfx)libc_nonshared.a \
- $(shared-thread-library) \
- $(if $(filter yes,$(elf)), $(elf-objpfx)ld.so)
+ $(shared-thread-library) $(elf-objpfx)ld.so
ifeq (yes,$(build-shared))
$(addprefix $(objpfx),$(tests)): $(objpfx)librtkaio.so $(shared-thread-library)