a8db42ba53
Upstream commit: 71326f1f2fd09dafb9c34404765fb88129e94237 - nptl: Fix pthread_cancel cancelhandling atomic operations - mips: Fix mips64n32 64 bit time_t stat support (BZ#29069) - hurd: Fix arbitrary error code - nptl: Handle spurious EINTR when thread cancellation is disabled (BZ#29029) - S390: Add new s390 platform z16. - NEWS: Update fixed bug list for LD_AUDIT backports. - hppa: Fix bind-now audit (BZ #28857) - elf: Replace tst-audit24bmod2.so with tst-audit24bmod2 - Fix elf/tst-audit25a with default bind now toolchains - elf: Fix runtime linker auditing on aarch64 (BZ #26643) - elf: Issue la_symbind for bind-now (BZ #23734) - elf: Fix initial-exec TLS access on audit modules (BZ #28096) - elf: Add la_activity during application exit - elf: Do not fail for failed dlmopen on audit modules (BZ #28061) - elf: Issue audit la_objopen for vDSO - elf: Add audit tests for modules with TLSDESC - elf: Avoid unnecessary slowdown from profiling with audit (BZ#15533) - elf: Add _dl_audit_pltexit - elf: Add _dl_audit_pltenter - elf: Add _dl_audit_preinit - elf: Add _dl_audit_symbind_alt and _dl_audit_symbind - elf: Add _dl_audit_objclose - elf: Add _dl_audit_objsearch - elf: Add _dl_audit_activity_map and _dl_audit_activity_nsid - elf: Add _dl_audit_objopen - elf: Move la_activity (LA_ACT_ADD) after _dl_add_to_namespace_list() (BZ #28062) - elf: Move LAV_CURRENT to link_lavcurrent.h - elf: Fix elf_get_dynamic_info() for bootstrap - elf: Fix dynamic-link.h usage on rtld.c - elf: Fix elf_get_dynamic_info definition - elf: Avoid nested functions in the loader [BZ #27220] - powerpc: Delete unneeded ELF_MACHINE_BEFORE_RTLD_RELOC - hppa: Use END instead of PSEUDO_END in swapcontext.S - hppa: Implement swapcontext in assembler (bug 28960) Reviewed-by: Florian Weimer <fweimer at redhat.com>
70 lines
2.2 KiB
Diff
70 lines
2.2 KiB
Diff
commit a31bbe3242266aaea423e5879f38aed69aea1d5e
|
|
Author: Adhemerval Zanella <adhemerval.zanella@linaro.org>
|
|
Date: Thu Jul 29 11:13:57 2021 -0300
|
|
|
|
elf: Move LAV_CURRENT to link_lavcurrent.h
|
|
|
|
No functional change.
|
|
|
|
(cherry picked from commit 54816ae98d57930b7c945f17485714a5574bfe47)
|
|
|
|
Resolved conflicts:
|
|
elf/Makefile
|
|
|
|
diff --git a/bits/link_lavcurrent.h b/bits/link_lavcurrent.h
|
|
new file mode 100644
|
|
index 0000000000000000..44fbea1e8060997f
|
|
--- /dev/null
|
|
+++ b/bits/link_lavcurrent.h
|
|
@@ -0,0 +1,25 @@
|
|
+/* Data structure for communication from the run-time dynamic linker for
|
|
+ loaded ELF shared objects. LAV_CURRENT definition.
|
|
+ Copyright (C) 2021 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#ifndef _LINK_H
|
|
+# error "Never include <bits/link_lavcurrent.h> directly; use <link.h> instead."
|
|
+#endif
|
|
+
|
|
+/* Version numbers for la_version handshake interface. */
|
|
+#define LAV_CURRENT 1
|
|
diff --git a/elf/Makefile b/elf/Makefile
|
|
index cd8725c76f4cfb48..7fa80946ff3aae42 100644
|
|
--- a/elf/Makefile
|
|
+++ b/elf/Makefile
|
|
@@ -24,6 +24,7 @@ include ../Makeconfig
|
|
headers = \
|
|
bits/elfclass.h \
|
|
bits/link.h \
|
|
+ bits/link_lavcurrent.h \
|
|
elf.h \
|
|
link.h \
|
|
# headers
|
|
diff --git a/elf/link.h b/elf/link.h
|
|
index ff3a85c847930b9b..21a351686b9bf7c8 100644
|
|
--- a/elf/link.h
|
|
+++ b/elf/link.h
|
|
@@ -96,7 +96,7 @@ struct link_map
|
|
#ifdef __USE_GNU
|
|
|
|
/* Version numbers for la_version handshake interface. */
|
|
-#define LAV_CURRENT 1
|
|
+#include <bits/link_lavcurrent.h>
|
|
|
|
/* Activity types signaled through la_activity. */
|
|
enum
|