glibc/glibc-disable-werror-tst-re...

19 lines
615 B
Diff

Use -Wno-error when compiling malloc/tst-realloc.c until the following
fix lands in GCC:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109238
diff --git a/malloc/Makefile b/malloc/Makefile
index dfb51d344c02b509..a719f4418efc22d0 100644
--- a/malloc/Makefile
+++ b/malloc/Makefile
@@ -122,6 +122,8 @@ tests-exclude-mcheck = tst-mallocstate \
tests-mcheck = $(filter-out $(tests-exclude-mcheck) $(tests-static), $(tests))
endif
+CFLAGS-tst-realloc.c += -Wno-error
+
routines = malloc mcheck mtrace obstack reallocarray \
scratch_buffer_grow scratch_buffer_grow_preserve \
scratch_buffer_set_array_size \