fb633eaa14
remaining patches into distinct patchfiles. Thanks to Dmitry V. Levin for identifying them! Drop ia64 specific patches and specfile fragments
19 lines
623 B
Diff
19 lines
623 B
Diff
diff -Nrup a/sysdeps/i386/Makefile b/sysdeps/i386/Makefile
|
|
--- a/sysdeps/i386/Makefile 2012-06-05 07:42:49.000000000 -0600
|
|
+++ b/sysdeps/i386/Makefile 2012-06-07 12:15:21.826318641 -0600
|
|
@@ -62,6 +64,14 @@ endif
|
|
|
|
ifneq (,$(filter -mno-tls-direct-seg-refs,$(CFLAGS)))
|
|
defines += -DNO_TLS_DIRECT_SEG_REFS
|
|
+else
|
|
+# .a libraries are not performance critical and so we
|
|
+# build them without direct TLS segment references
|
|
+# always.
|
|
+CPPFLAGS-.o += -DNO_TLS_DIRECT_SEG_REFS
|
|
+CFLAGS-.o += -mno-tls-direct-seg-refs
|
|
+CPPFLAGS-.oS += -DNO_TLS_DIRECT_SEG_REFS
|
|
+CFLAGS-.oS += -mno-tls-direct-seg-refs
|
|
endif
|
|
|
|
ifeq ($(subdir),elf)
|