a8db42ba53
Upstream commit: 71326f1f2fd09dafb9c34404765fb88129e94237 - nptl: Fix pthread_cancel cancelhandling atomic operations - mips: Fix mips64n32 64 bit time_t stat support (BZ#29069) - hurd: Fix arbitrary error code - nptl: Handle spurious EINTR when thread cancellation is disabled (BZ#29029) - S390: Add new s390 platform z16. - NEWS: Update fixed bug list for LD_AUDIT backports. - hppa: Fix bind-now audit (BZ #28857) - elf: Replace tst-audit24bmod2.so with tst-audit24bmod2 - Fix elf/tst-audit25a with default bind now toolchains - elf: Fix runtime linker auditing on aarch64 (BZ #26643) - elf: Issue la_symbind for bind-now (BZ #23734) - elf: Fix initial-exec TLS access on audit modules (BZ #28096) - elf: Add la_activity during application exit - elf: Do not fail for failed dlmopen on audit modules (BZ #28061) - elf: Issue audit la_objopen for vDSO - elf: Add audit tests for modules with TLSDESC - elf: Avoid unnecessary slowdown from profiling with audit (BZ#15533) - elf: Add _dl_audit_pltexit - elf: Add _dl_audit_pltenter - elf: Add _dl_audit_preinit - elf: Add _dl_audit_symbind_alt and _dl_audit_symbind - elf: Add _dl_audit_objclose - elf: Add _dl_audit_objsearch - elf: Add _dl_audit_activity_map and _dl_audit_activity_nsid - elf: Add _dl_audit_objopen - elf: Move la_activity (LA_ACT_ADD) after _dl_add_to_namespace_list() (BZ #28062) - elf: Move LAV_CURRENT to link_lavcurrent.h - elf: Fix elf_get_dynamic_info() for bootstrap - elf: Fix dynamic-link.h usage on rtld.c - elf: Fix elf_get_dynamic_info definition - elf: Avoid nested functions in the loader [BZ #27220] - powerpc: Delete unneeded ELF_MACHINE_BEFORE_RTLD_RELOC - hppa: Use END instead of PSEUDO_END in swapcontext.S - hppa: Implement swapcontext in assembler (bug 28960) Reviewed-by: Florian Weimer <fweimer at redhat.com>
24 lines
919 B
Diff
24 lines
919 B
Diff
commit 165e7ad459fbba2f89708fba04a55bb3981e884c
|
|
Author: Szabolcs Nagy <szabolcs.nagy@arm.com>
|
|
Date: Wed Feb 2 14:03:58 2022 +0000
|
|
|
|
Fix elf/tst-audit25a with default bind now toolchains
|
|
|
|
This test relies on lazy binding for the executable so request that
|
|
explicitly in case the toolchain defaults to bind now.
|
|
|
|
(cherry picked from commit 80a08d0faa9b224019f895800c4d97de4e23e1aa)
|
|
|
|
diff --git a/elf/Makefile b/elf/Makefile
|
|
index 0ab3e885f5e35671..9e4e056938a75ddb 100644
|
|
--- a/elf/Makefile
|
|
+++ b/elf/Makefile
|
|
@@ -2133,6 +2133,7 @@ $(objpfx)tst-audit25a: $(objpfx)tst-audit25mod1.so \
|
|
$(objpfx)tst-audit25mod2.so \
|
|
$(objpfx)tst-audit25mod3.so \
|
|
$(objpfx)tst-audit25mod4.so
|
|
+LDFLAGS-tst-audit25a = -Wl,-z,lazy
|
|
$(objpfx)tst-audit25mod1.so: $(objpfx)tst-audit25mod3.so
|
|
LDFLAGS-tst-audit25mod1.so = -Wl,-z,now
|
|
$(objpfx)tst-audit25mod2.so: $(objpfx)tst-audit25mod4.so
|