955387a035
Upstream commit: e3976287b22422787f3cc6fc9adda58304b55bd9 - Handle non-hostname CNAME aliases during name resolution (#2129005) - nscd: Drop local address tuple variable [BZ #29607] - x86-64: Require BMI1/BMI2 for AVX2 strrchr and wcsrchr implementations - x86-64: Require BMI2 and LZCNT for AVX2 memrchr implementation - x86-64: Require BMI2 for AVX2 (raw|w)memchr implementations - x86-64: Require BMI2 for AVX2 wcs(n)cmp implementations - x86-64: Require BMI2 for AVX2 strncmp implementation - x86-64: Require BMI2 for AVX2 strcmp implementation - x86-64: Require BMI2 for AVX2 str(n)casecmp implementations - x86: include BMI1 and BMI2 in x86-64-v3 level - nptl: Add backoff mechanism to spinlock loop - sysdeps: Add 'get_fast_jitter' interace in fast-jitter.h - nptl: Effectively skip CAS in spinlock loop - Move assignment out of the CAS condition - Add LLL_MUTEX_READ_LOCK [BZ #28537] - Avoid extra load with CAS in __pthread_mutex_clocklock_common [BZ #28537] - Avoid extra load with CAS in __pthread_mutex_lock_full [BZ #28537] - resolv: Fix building tst-resolv-invalid-cname for earlier C standards - nss_dns: Rewrite _nss_dns_gethostbyname4_r using current interfaces - resolv: Add new tst-resolv-invalid-cname - nss_dns: In gaih_getanswer_slice, skip strange aliases (bug 12154) (#2129005) - nss_dns: Rewrite getanswer_r to match getanswer_ptr (bug 12154, bug 29305) - nss_dns: Remove remnants of IPv6 address mapping - nss_dns: Rewrite _nss_dns_gethostbyaddr2_r and getanswer_ptr - nss_dns: Split getanswer_ptr from getanswer_r - resolv: Add DNS packet parsing helpers geared towards wire format - resolv: Add internal __ns_name_length_uncompressed function - resolv: Add the __ns_samebinaryname function - resolv: Add internal __res_binary_hnok function - resolv: Add tst-resolv-aliases - resolv: Add tst-resolv-byaddr for testing reverse lookup - gconv: Use 64-bit interfaces in gconv_parseconfdir (bug 29583) - elf: Fix hwcaps string size overestimation - nscd: Fix netlink cache invalidation if epoll is used [BZ #29415] - Apply asm redirections in wchar.h before first use - Apply asm redirections in stdio.h before first use [BZ #27087] - elf: Call __libc_early_init for reused namespaces (bug 29528) Reviewed-by: Florian Weimer <fweimer@redhat.com>
335 lines
13 KiB
Diff
335 lines
13 KiB
Diff
commit 2a44960cbc78713c6a2721683a4319d50e71a01f
|
|
Author: Tulio Magno Quites Machado Filho <tuliom@linux.ibm.com>
|
|
Date: Thu Jul 7 18:12:58 2022 -0300
|
|
|
|
Apply asm redirections in stdio.h before first use [BZ #27087]
|
|
|
|
Compilers may not be able to apply asm redirections to functions after
|
|
these functions are used for the first time, e.g. clang 13.
|
|
Fix [BZ #27087] by applying all long double-related asm redirections
|
|
before using functions in bits/stdio.h.
|
|
However, as these asm redirections depend on the declarations provided
|
|
by libio/bits/stdio2.h, this header was split in 2:
|
|
|
|
- libio/bits/stdio2-decl.h contains all function declarations;
|
|
- libio/bits/stdio2.h remains with the remaining contents, including
|
|
redirections.
|
|
|
|
This also adds the access attribute to __vsnprintf_chk that was missing.
|
|
|
|
Tested with build-many-glibcs.py.
|
|
|
|
Reviewed-by: Paul E. Murphy <murphyp@linux.ibm.com>
|
|
(cherry picked from commit d0fa09a7701956036ff36f8ca188e9fff81553d8)
|
|
|
|
diff --git a/include/bits/stdio2-decl.h b/include/bits/stdio2-decl.h
|
|
new file mode 100644
|
|
index 0000000000000000..bbb052f192218219
|
|
--- /dev/null
|
|
+++ b/include/bits/stdio2-decl.h
|
|
@@ -0,0 +1 @@
|
|
+#include <libio/bits/stdio2-decl.h>
|
|
diff --git a/libio/Makefile b/libio/Makefile
|
|
index 5336b7d59584927f..981c876940f67fbf 100644
|
|
--- a/libio/Makefile
|
|
+++ b/libio/Makefile
|
|
@@ -23,7 +23,7 @@ subdir := libio
|
|
include ../Makeconfig
|
|
|
|
headers := stdio.h \
|
|
- bits/stdio.h bits/stdio2.h bits/stdio-ldbl.h \
|
|
+ bits/stdio.h bits/stdio2.h bits/stdio2-decl.h bits/stdio-ldbl.h \
|
|
bits/types/FILE.h bits/types/__FILE.h bits/types/struct_FILE.h \
|
|
bits/types/__fpos_t.h bits/types/__fpos64_t.h \
|
|
bits/types/cookie_io_functions_t.h
|
|
diff --git a/libio/bits/stdio2-decl.h b/libio/bits/stdio2-decl.h
|
|
new file mode 100644
|
|
index 0000000000000000..e398f7182b98e4d7
|
|
--- /dev/null
|
|
+++ b/libio/bits/stdio2-decl.h
|
|
@@ -0,0 +1,111 @@
|
|
+/* Checking macros for stdio functions. Declarations only.
|
|
+ Copyright (C) 2004-2022 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <https://www.gnu.org/licenses/>. */
|
|
+
|
|
+#ifndef _BITS_STDIO2_DEC_H
|
|
+#define _BITS_STDIO2_DEC_H 1
|
|
+
|
|
+#ifndef _STDIO_H
|
|
+# error "Never include <bits/stdio2-decl.h> directly; use <stdio.h> instead."
|
|
+#endif
|
|
+
|
|
+extern int __sprintf_chk (char *__restrict __s, int __flag, size_t __slen,
|
|
+ const char *__restrict __format, ...) __THROW
|
|
+ __attr_access ((__write_only__, 1, 3));
|
|
+extern int __vsprintf_chk (char *__restrict __s, int __flag, size_t __slen,
|
|
+ const char *__restrict __format,
|
|
+ __gnuc_va_list __ap) __THROW
|
|
+ __attr_access ((__write_only__, 1, 3));
|
|
+
|
|
+#if defined __USE_ISOC99 || defined __USE_UNIX98
|
|
+
|
|
+extern int __snprintf_chk (char *__restrict __s, size_t __n, int __flag,
|
|
+ size_t __slen, const char *__restrict __format,
|
|
+ ...) __THROW
|
|
+ __attr_access ((__write_only__, 1, 2));
|
|
+extern int __vsnprintf_chk (char *__restrict __s, size_t __n, int __flag,
|
|
+ size_t __slen, const char *__restrict __format,
|
|
+ __gnuc_va_list __ap) __THROW
|
|
+ __attr_access ((__write_only__, 1, 2));
|
|
+
|
|
+#endif
|
|
+
|
|
+#if __USE_FORTIFY_LEVEL > 1
|
|
+
|
|
+extern int __fprintf_chk (FILE *__restrict __stream, int __flag,
|
|
+ const char *__restrict __format, ...);
|
|
+extern int __printf_chk (int __flag, const char *__restrict __format, ...);
|
|
+extern int __vfprintf_chk (FILE *__restrict __stream, int __flag,
|
|
+ const char *__restrict __format, __gnuc_va_list __ap);
|
|
+extern int __vprintf_chk (int __flag, const char *__restrict __format,
|
|
+ __gnuc_va_list __ap);
|
|
+
|
|
+# ifdef __USE_XOPEN2K8
|
|
+extern int __dprintf_chk (int __fd, int __flag, const char *__restrict __fmt,
|
|
+ ...) __attribute__ ((__format__ (__printf__, 3, 4)));
|
|
+extern int __vdprintf_chk (int __fd, int __flag,
|
|
+ const char *__restrict __fmt, __gnuc_va_list __arg)
|
|
+ __attribute__ ((__format__ (__printf__, 3, 0)));
|
|
+# endif
|
|
+
|
|
+# ifdef __USE_GNU
|
|
+
|
|
+extern int __asprintf_chk (char **__restrict __ptr, int __flag,
|
|
+ const char *__restrict __fmt, ...)
|
|
+ __THROW __attribute__ ((__format__ (__printf__, 3, 4))) __wur;
|
|
+extern int __vasprintf_chk (char **__restrict __ptr, int __flag,
|
|
+ const char *__restrict __fmt, __gnuc_va_list __arg)
|
|
+ __THROW __attribute__ ((__format__ (__printf__, 3, 0))) __wur;
|
|
+extern int __obstack_printf_chk (struct obstack *__restrict __obstack,
|
|
+ int __flag, const char *__restrict __format,
|
|
+ ...)
|
|
+ __THROW __attribute__ ((__format__ (__printf__, 3, 4)));
|
|
+extern int __obstack_vprintf_chk (struct obstack *__restrict __obstack,
|
|
+ int __flag,
|
|
+ const char *__restrict __format,
|
|
+ __gnuc_va_list __args)
|
|
+ __THROW __attribute__ ((__format__ (__printf__, 3, 0)));
|
|
+
|
|
+# endif
|
|
+#endif
|
|
+
|
|
+#if __GLIBC_USE (DEPRECATED_GETS)
|
|
+extern char *__gets_chk (char *__str, size_t) __wur;
|
|
+#endif
|
|
+
|
|
+extern char *__fgets_chk (char *__restrict __s, size_t __size, int __n,
|
|
+ FILE *__restrict __stream)
|
|
+ __wur __attr_access ((__write_only__, 1, 3));
|
|
+
|
|
+extern size_t __fread_chk (void *__restrict __ptr, size_t __ptrlen,
|
|
+ size_t __size, size_t __n,
|
|
+ FILE *__restrict __stream) __wur;
|
|
+
|
|
+#ifdef __USE_GNU
|
|
+extern char *__fgets_unlocked_chk (char *__restrict __s, size_t __size,
|
|
+ int __n, FILE *__restrict __stream)
|
|
+ __wur __attr_access ((__write_only__, 1, 3));
|
|
+#endif
|
|
+
|
|
+#ifdef __USE_MISC
|
|
+# undef fread_unlocked
|
|
+extern size_t __fread_unlocked_chk (void *__restrict __ptr, size_t __ptrlen,
|
|
+ size_t __size, size_t __n,
|
|
+ FILE *__restrict __stream) __wur;
|
|
+#endif
|
|
+
|
|
+#endif /* bits/stdio2-decl.h. */
|
|
diff --git a/libio/bits/stdio2.h b/libio/bits/stdio2.h
|
|
index 40ff16b01b4f4876..4570f86a4496c1ee 100644
|
|
--- a/libio/bits/stdio2.h
|
|
+++ b/libio/bits/stdio2.h
|
|
@@ -23,14 +23,6 @@
|
|
# error "Never include <bits/stdio2.h> directly; use <stdio.h> instead."
|
|
#endif
|
|
|
|
-extern int __sprintf_chk (char *__restrict __s, int __flag, size_t __slen,
|
|
- const char *__restrict __format, ...) __THROW
|
|
- __attr_access ((__write_only__, 1, 3));
|
|
-extern int __vsprintf_chk (char *__restrict __s, int __flag, size_t __slen,
|
|
- const char *__restrict __format,
|
|
- __gnuc_va_list __ap) __THROW
|
|
- __attr_access ((__write_only__, 1, 3));
|
|
-
|
|
#ifdef __va_arg_pack
|
|
__fortify_function int
|
|
__NTH (sprintf (char *__restrict __s, const char *__restrict __fmt, ...))
|
|
@@ -54,15 +46,6 @@ __NTH (vsprintf (char *__restrict __s, const char *__restrict __fmt,
|
|
}
|
|
|
|
#if defined __USE_ISOC99 || defined __USE_UNIX98
|
|
-
|
|
-extern int __snprintf_chk (char *__restrict __s, size_t __n, int __flag,
|
|
- size_t __slen, const char *__restrict __format,
|
|
- ...) __THROW
|
|
- __attr_access ((__write_only__, 1, 2));
|
|
-extern int __vsnprintf_chk (char *__restrict __s, size_t __n, int __flag,
|
|
- size_t __slen, const char *__restrict __format,
|
|
- __gnuc_va_list __ap) __THROW;
|
|
-
|
|
# ifdef __va_arg_pack
|
|
__fortify_function int
|
|
__NTH (snprintf (char *__restrict __s, size_t __n,
|
|
@@ -89,15 +72,6 @@ __NTH (vsnprintf (char *__restrict __s, size_t __n,
|
|
#endif
|
|
|
|
#if __USE_FORTIFY_LEVEL > 1
|
|
-
|
|
-extern int __fprintf_chk (FILE *__restrict __stream, int __flag,
|
|
- const char *__restrict __format, ...);
|
|
-extern int __printf_chk (int __flag, const char *__restrict __format, ...);
|
|
-extern int __vfprintf_chk (FILE *__restrict __stream, int __flag,
|
|
- const char *__restrict __format, __gnuc_va_list __ap);
|
|
-extern int __vprintf_chk (int __flag, const char *__restrict __format,
|
|
- __gnuc_va_list __ap);
|
|
-
|
|
# ifdef __va_arg_pack
|
|
__fortify_function int
|
|
fprintf (FILE *__restrict __stream, const char *__restrict __fmt, ...)
|
|
@@ -136,12 +110,6 @@ vfprintf (FILE *__restrict __stream,
|
|
}
|
|
|
|
# ifdef __USE_XOPEN2K8
|
|
-extern int __dprintf_chk (int __fd, int __flag, const char *__restrict __fmt,
|
|
- ...) __attribute__ ((__format__ (__printf__, 3, 4)));
|
|
-extern int __vdprintf_chk (int __fd, int __flag,
|
|
- const char *__restrict __fmt, __gnuc_va_list __arg)
|
|
- __attribute__ ((__format__ (__printf__, 3, 0)));
|
|
-
|
|
# ifdef __va_arg_pack
|
|
__fortify_function int
|
|
dprintf (int __fd, const char *__restrict __fmt, ...)
|
|
@@ -162,23 +130,6 @@ vdprintf (int __fd, const char *__restrict __fmt, __gnuc_va_list __ap)
|
|
# endif
|
|
|
|
# ifdef __USE_GNU
|
|
-
|
|
-extern int __asprintf_chk (char **__restrict __ptr, int __flag,
|
|
- const char *__restrict __fmt, ...)
|
|
- __THROW __attribute__ ((__format__ (__printf__, 3, 4))) __wur;
|
|
-extern int __vasprintf_chk (char **__restrict __ptr, int __flag,
|
|
- const char *__restrict __fmt, __gnuc_va_list __arg)
|
|
- __THROW __attribute__ ((__format__ (__printf__, 3, 0))) __wur;
|
|
-extern int __obstack_printf_chk (struct obstack *__restrict __obstack,
|
|
- int __flag, const char *__restrict __format,
|
|
- ...)
|
|
- __THROW __attribute__ ((__format__ (__printf__, 3, 4)));
|
|
-extern int __obstack_vprintf_chk (struct obstack *__restrict __obstack,
|
|
- int __flag,
|
|
- const char *__restrict __format,
|
|
- __gnuc_va_list __args)
|
|
- __THROW __attribute__ ((__format__ (__printf__, 3, 0)));
|
|
-
|
|
# ifdef __va_arg_pack
|
|
__fortify_function int
|
|
__NTH (asprintf (char **__restrict __ptr, const char *__restrict __fmt, ...))
|
|
@@ -231,7 +182,6 @@ __NTH (obstack_vprintf (struct obstack *__restrict __obstack,
|
|
#endif
|
|
|
|
#if __GLIBC_USE (DEPRECATED_GETS)
|
|
-extern char *__gets_chk (char *__str, size_t) __wur;
|
|
extern char *__REDIRECT (__gets_warn, (char *__str), gets)
|
|
__wur __warnattr ("please use fgets or getline instead, gets can't "
|
|
"specify buffer size");
|
|
@@ -245,9 +195,6 @@ gets (char *__str)
|
|
}
|
|
#endif
|
|
|
|
-extern char *__fgets_chk (char *__restrict __s, size_t __size, int __n,
|
|
- FILE *__restrict __stream)
|
|
- __wur __attr_access ((__write_only__, 1, 3));
|
|
extern char *__REDIRECT (__fgets_alias,
|
|
(char *__restrict __s, int __n,
|
|
FILE *__restrict __stream), fgets)
|
|
@@ -269,9 +216,6 @@ fgets (char *__restrict __s, int __n, FILE *__restrict __stream)
|
|
return __fgets_chk (__s, sz, __n, __stream);
|
|
}
|
|
|
|
-extern size_t __fread_chk (void *__restrict __ptr, size_t __ptrlen,
|
|
- size_t __size, size_t __n,
|
|
- FILE *__restrict __stream) __wur;
|
|
extern size_t __REDIRECT (__fread_alias,
|
|
(void *__restrict __ptr, size_t __size,
|
|
size_t __n, FILE *__restrict __stream),
|
|
@@ -297,9 +241,6 @@ fread (void *__restrict __ptr, size_t __size, size_t __n,
|
|
}
|
|
|
|
#ifdef __USE_GNU
|
|
-extern char *__fgets_unlocked_chk (char *__restrict __s, size_t __size,
|
|
- int __n, FILE *__restrict __stream)
|
|
- __wur __attr_access ((__write_only__, 1, 3));
|
|
extern char *__REDIRECT (__fgets_unlocked_alias,
|
|
(char *__restrict __s, int __n,
|
|
FILE *__restrict __stream), fgets_unlocked)
|
|
@@ -324,9 +265,6 @@ fgets_unlocked (char *__restrict __s, int __n, FILE *__restrict __stream)
|
|
|
|
#ifdef __USE_MISC
|
|
# undef fread_unlocked
|
|
-extern size_t __fread_unlocked_chk (void *__restrict __ptr, size_t __ptrlen,
|
|
- size_t __size, size_t __n,
|
|
- FILE *__restrict __stream) __wur;
|
|
extern size_t __REDIRECT (__fread_unlocked_alias,
|
|
(void *__restrict __ptr, size_t __size,
|
|
size_t __n, FILE *__restrict __stream),
|
|
diff --git a/libio/stdio.h b/libio/stdio.h
|
|
index abefe640e52d18d5..d36e61c56bbb3117 100644
|
|
--- a/libio/stdio.h
|
|
+++ b/libio/stdio.h
|
|
@@ -879,20 +879,27 @@ extern void funlockfile (FILE *__stream) __THROW;
|
|
extern int __uflow (FILE *);
|
|
extern int __overflow (FILE *, int);
|
|
|
|
+#if __USE_FORTIFY_LEVEL > 0 && defined __fortify_function
|
|
+/* Declare all functions from bits/stdio2-decl.h first. */
|
|
+# include <bits/stdio2-decl.h>
|
|
+#endif
|
|
+
|
|
+/* The following headers provide asm redirections. These redirections must
|
|
+ appear before the first usage of these functions, e.g. in bits/stdio.h. */
|
|
+#if defined __LDBL_COMPAT || __LDOUBLE_REDIRECTS_TO_FLOAT128_ABI == 1
|
|
+# include <bits/stdio-ldbl.h>
|
|
+#endif
|
|
+
|
|
/* If we are compiling with optimizing read this file. It contains
|
|
several optimizing inline functions and macros. */
|
|
#ifdef __USE_EXTERN_INLINES
|
|
# include <bits/stdio.h>
|
|
#endif
|
|
#if __USE_FORTIFY_LEVEL > 0 && defined __fortify_function
|
|
+/* Now include the function definitions and redirects too. */
|
|
# include <bits/stdio2.h>
|
|
#endif
|
|
|
|
-#include <bits/floatn.h>
|
|
-#if defined __LDBL_COMPAT || __LDOUBLE_REDIRECTS_TO_FLOAT128_ABI == 1
|
|
-# include <bits/stdio-ldbl.h>
|
|
-#endif
|
|
-
|
|
__END_DECLS
|
|
|
|
#endif /* <stdio.h> included. */
|